summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-01-06 23:37:14 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-01-06 23:37:14 +0000
commit8782aa21a49b088c6d47c2fc26f1e3f896f9db37 (patch)
tree276fd2c0597cc19374eb1cf78cecf2e3bca74e06 /dev-libs/cloog-ppl
parentAdded some more runtime-dependencies. (diff)
downloadgentoo-2-8782aa21a49b088c6d47c2fc26f1e3f896f9db37.tar.gz
gentoo-2-8782aa21a49b088c6d47c2fc26f1e3f896f9db37.tar.bz2
gentoo-2-8782aa21a49b088c6d47c2fc26f1e3f896f9db37.zip
Version bump allowing use of PPL 0.11. No other code changes. Ported to
EAPI 3 and autotools-utils eclass. Changed include path and etc. to avoid collisions with upstream CLooG. (Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/cloog-ppl')
-rw-r--r--dev-libs/cloog-ppl/ChangeLog9
-rw-r--r--dev-libs/cloog-ppl/cloog-ppl-0.15.10.ebuild40
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-libs/cloog-ppl/ChangeLog b/dev-libs/cloog-ppl/ChangeLog
index 1f48a2b69a39..2cad791e24a0 100644
--- a/dev-libs/cloog-ppl/ChangeLog
+++ b/dev-libs/cloog-ppl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/cloog-ppl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cloog-ppl/ChangeLog,v 1.33 2011/01/06 16:44:55 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cloog-ppl/ChangeLog,v 1.34 2011/01/06 23:37:14 dirtyepic Exp $
+
+*cloog-ppl-0.15.10 (06 Jan 2011)
+
+ 06 Jan 2011; Ryan Hill <dirtyepic@gentoo.org> +cloog-ppl-0.15.10.ebuild:
+ Version bump allowing use of PPL 0.11. No other code changes. Ported to
+ EAPI 3 and autotools-utils eclass. Changed include path and etc. to avoid
+ collisions with upstream CLooG.
06 Jan 2011; Raúl Porcel <armin76@gentoo.org> cloog-ppl-0.15.9.ebuild:
ia64/s390/sh/sparc stable wrt #347239
diff --git a/dev-libs/cloog-ppl/cloog-ppl-0.15.10.ebuild b/dev-libs/cloog-ppl/cloog-ppl-0.15.10.ebuild
new file mode 100644
index 000000000000..8a0cf61550ae
--- /dev/null
+++ b/dev-libs/cloog-ppl/cloog-ppl-0.15.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cloog-ppl/cloog-ppl-0.15.10.ebuild,v 1.1 2011/01/06 23:37:14 dirtyepic Exp $
+
+EAPI="3"
+
+inherit autotools-utils
+
+DESCRIPTION="Port of CLooG (Chunky LOOp Generator) to PPL (Parma Polyhedra Library)"
+HOMEPAGE="http://repo.or.cz/w/cloog-ppl.git"
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/infrastructure/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/ppl
+ dev-libs/gmp"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ mkdir m4
+ eautoreconf
+}
+
+src_configure() {
+ # set includedir to avoid conflicts w/ dev-libs/cloog
+ myeconfargs=(
+ --with-ppl
+ --includedir=/usr/include/cloog-ppl
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ mv "${D}"usr/bin/cloog "${D}"usr/bin/cloog-ppl || die
+ mv "${D}"usr/share/info/cloog.info "${D}"usr/share/info/cloog-ppl.info || die
+}