summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2004-12-09 14:16:52 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2004-12-09 14:16:52 +0000
commit3591032a152a1442ea6ba1062230482f98310550 (patch)
tree3e3b77f88eceb2b480018b04ff8024baa34f2624 /dev-libs/botan
parentoops typo (Manifest recommit) (diff)
downloadgentoo-2-3591032a152a1442ea6ba1062230482f98310550.tar.gz
gentoo-2-3591032a152a1442ea6ba1062230482f98310550.tar.bz2
gentoo-2-3591032a152a1442ea6ba1062230482f98310550.zip
Stable on sparc wrt #71760, fixed the whole sparc mess too
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/ChangeLog5
-rw-r--r--dev-libs/botan/botan-1.4.4.ebuild22
2 files changed, 16 insertions, 11 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index f84465396c3a..3ec1bf417ffc 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/botan
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.3 2004/12/08 10:27:36 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.4 2004/12/09 14:16:52 gustavoz Exp $
+
+ 09 Dec 2004; Gustavo Zacarias <gustavoz@gentoo.org> botan-1.4.4.ebuild:
+ Stable on sparc wrt #71760, fixed the whole sparc mess too
08 Dec 2004; Daniel Black <dragonheart@gentoo.org> botan-1.4.4.ebuild,
+files/botan-1.4.4-gcc34.patch:
diff --git a/dev-libs/botan/botan-1.4.4.ebuild b/dev-libs/botan/botan-1.4.4.ebuild
index 3dd689d7443d..12b27f05a50d 100644
--- a/dev-libs/botan/botan-1.4.4.ebuild
+++ b/dev-libs/botan/botan-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.4.4.ebuild,v 1.2 2004/12/08 10:27:36 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.4.4.ebuild,v 1.3 2004/12/09 14:16:52 gustavoz Exp $
# Comments/fixes to lloyd@randombit.net (author)
@@ -10,7 +10,7 @@ DESCRIPTION="A C++ crypto library"
HOMEPAGE="http://botan.randombit.net/"
SRC_URI="http://botan.randombit.net/files/Botan-${PV}.tgz"
-KEYWORDS="x86 ppc"
+KEYWORDS="x86 ppc sparc"
SLOT="0"
LICENSE="BSD"
IUSE="bzlib zlib gmp ssl debug"
@@ -45,22 +45,24 @@ src_compile() {
if useq ssl; then modules="$modules,eng_ossl"; fi
- # This is also supported on i586+ and sparcv9 - hope this is correct.
+ # This is also supported on i586+ - hope this is correct.
if [ ${ARCH} = 'alpha' -o ${ARCH} = 'amd64' ] || \
- [ ${ARCH} = 'x86' -a ${CHOST:0:4} != "i386" -a ${CHOST:0:4} != "i486" ] || \
- [ ${CHOSTARCH} = 'sparc32-v9' -a ${PROFILE_ARCH} = 'sparc64' ]; then
+ [ ${ARCH} = 'x86' -a ${CHOST:0:4} != "i386" -a ${CHOST:0:4} != "i486" ]; then
modules="$modules,tm_hard"
fi
- # Also works on mips64 and sparc64
+ # Also works on mips64
if [ "${ARCH}" = 'alpha' -o "${ARCH}" = 'amd64' -o \
- "${ARCH}" = 'ia64' -o "${ARCH}" = 'ppc64' -o "${PROFILE_ARCH}" = 'mips64' ] || \
- [ "${CHOSTARCH}" = 'sparc32-v9' -a "${PROFILE_ARCH}" = 'sparc64' ]; then
+ "${ARCH}" = 'ia64' -o "${ARCH}" = 'ppc64' -o "${PROFILE_ARCH}" = 'mips64' ]; then
modules="$modules,mp_asm64"
fi
- # Are there any CHOSTs in use which break this?
- CHOSTARCH=$(echo ${CHOST} | cut -d - -f 1)
+ # Enable v9 instructions for sparc64
+ if [ ${PROFILE_ARCH} = 'sparc64' ]; then
+ CHOSTARCH='sparc32-v9'
+ else
+ CHOSTARCH=$(echo ${CHOST} | cut -d - -f 1)
+ fi
cd ${S}
einfo "Enabling modules: " ${modules}