summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-10-25 22:04:33 +0000
committerMike Gilbert <floppym@gentoo.org>2012-10-25 22:04:33 +0000
commitefc3ca9959ec5b27c6a490ee98425e6fcbef8f80 (patch)
tree57bed2abddfacc84813374410de66f5778644015 /dev-libs/boost
parentVersion bump. Ebuild by Arfrever. (diff)
downloadgentoo-2-efc3ca9959ec5b27c6a490ee98425e6fcbef8f80.tar.gz
gentoo-2-efc3ca9959ec5b27c6a490ee98425e6fcbef8f80.tar.bz2
gentoo-2-efc3ca9959ec5b27c6a490ee98425e6fcbef8f80.zip
Byte-compile Python modules. Create mpi.py for Boost >=1.50. Backported from Progress Overlay. Patch by Arfrever.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog7
-rw-r--r--dev-libs/boost/boost-1.48.0-r2.ebuild12
-rw-r--r--dev-libs/boost/boost-1.49.0-r1.ebuild12
-rw-r--r--dev-libs/boost/boost-1.50.0-r2.ebuild32
4 files changed, 57 insertions, 6 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index d9f768a18f68..275ba667383f 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.264 2012/10/21 09:08:50 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.265 2012/10/25 22:04:33 floppym Exp $
+
+ 25 Oct 2012; Mike Gilbert <floppym@gentoo.org> boost-1.48.0-r2.ebuild,
+ boost-1.49.0-r1.ebuild, boost-1.50.0-r2.ebuild:
+ Byte-compile Python modules. Create mpi.py for Boost >=1.50. Backported from
+ Progress Overlay. Patch by Arfrever.
21 Oct 2012; Markus Meier <maekke@gentoo.org> boost-1.49.0-r1.ebuild:
x86 stable, bug #425354
diff --git a/dev-libs/boost/boost-1.48.0-r2.ebuild b/dev-libs/boost/boost-1.48.0-r2.ebuild
index 3e539f09e2a3..705d48b56dbe 100644
--- a/dev-libs/boost/boost-1.48.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.48.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.48.0-r2.ebuild,v 1.8 2012/08/04 13:39:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.48.0-r2.ebuild,v 1.9 2012/10/25 22:04:33 floppym Exp $
EAPI="4"
PYTHON_DEPEND="python? *"
@@ -612,4 +612,14 @@ pkg_postinst() {
elog "No active boost version found. Calling eselect to select one..."
eselect boost update || ewarn "eselect boost update failed."
fi
+
+ if use python; then
+ python_mod_optimize boost_${MAJOR_PV}
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup boost_${MAJOR_PV}
+ fi
}
diff --git a/dev-libs/boost/boost-1.49.0-r1.ebuild b/dev-libs/boost/boost-1.49.0-r1.ebuild
index 72211a563055..90a5c35de928 100644
--- a/dev-libs/boost/boost-1.49.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.49.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.49.0-r1.ebuild,v 1.8 2012/10/21 09:08:50 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.49.0-r1.ebuild,v 1.9 2012/10/25 22:04:33 floppym Exp $
EAPI="4"
PYTHON_DEPEND="python? *"
@@ -610,4 +610,14 @@ pkg_postinst() {
elog "No active boost version found. Calling eselect to select one..."
eselect boost update || ewarn "eselect boost update failed."
fi
+
+ if use python; then
+ python_mod_optimize boost_${MAJOR_PV}
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup boost_${MAJOR_PV}
+ fi
}
diff --git a/dev-libs/boost/boost-1.50.0-r2.ebuild b/dev-libs/boost/boost-1.50.0-r2.ebuild
index e936858e78e3..6f4d049d2439 100644
--- a/dev-libs/boost/boost-1.50.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.50.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.50.0-r2.ebuild,v 1.2 2012/08/27 08:11:30 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.50.0-r2.ebuild,v 1.3 2012/10/25 22:04:33 floppym Exp $
EAPI="4"
PYTHON_DEPEND="python? *"
@@ -569,7 +569,7 @@ pkg_postinst() {
popd 1>/dev/null
local python_module python_module_dir
- for python_module in mpi.py mpi_debug.py ; do
+ for python_module in mpi.py ; do
for python_module_dir in "${ROOT}"usr/$(get_libdir)/python*/site-packages ; do
if [[ -e "${python_module_dir}/${python_module}" ]] ; then
rm "${python_module_dir}/${python_module}" || die -q "Unable to remove \"${python_module_dir}/${python_module}\""
@@ -577,7 +577,7 @@ pkg_postinst() {
done
done
- # Deprecated code for older versions of Boost.
+ # Deprecated code for Boost <1.48.
local mod="mpi.so"
for moddir in "${ROOT}"/usr/$(get_libdir)/python*/site-packages ; do
if [ -L "${moddir}/${mod}" ] ; then
@@ -592,4 +592,30 @@ pkg_postinst() {
else
[[ -e "${ROOT}/etc/eselect/boost/active" ]] && die -q "\"${ROOT}/etc/eselect/boost/active\" exists and isn't a symlink"
fi
+
+ if use python; then
+ if use mpi; then
+ create_mpi.py() {
+ echo "from boost_${MAJOR_PV}.mpi import *" > "${EROOT}$(python_get_sitedir -b)/mpi.py"
+ }
+ python_execute_function -q create_mpi.py
+ fi
+
+ python_mod_optimize boost_${MAJOR_PV} $(use mpi && echo mpi.py)
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ if use mpi; then
+ delete_mpi.py() {
+ if [[ "$(<"${EROOT}$(python_get_sitedir -b)/mpi.py")" == "from boost_${MAJOR_PV}.mpi import *" ]]; then
+ rm -f "${EROOT}$(python_get_sitedir -b)/mpi.py"
+ fi
+ }
+ python_execute_function -q delete_mpi.py
+ fi
+
+ python_mod_cleanup boost_${MAJOR_PV} $(use mpi && echo mpi.py)
+ fi
}