summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-16 03:26:37 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-16 03:26:37 +0000
commit017df9a011faa4eb6699a3e3ea2bd5e96771a3f2 (patch)
treeb39410788012f933a7c80fcaf6872120a08146f9 /dev-libs/DirectFB
parentremoved older ebuilds (diff)
downloadgentoo-2-017df9a011faa4eb6699a3e3ea2bd5e96771a3f2.tar.gz
gentoo-2-017df9a011faa4eb6699a3e3ea2bd5e96771a3f2.tar.bz2
gentoo-2-017df9a011faa4eb6699a3e3ea2bd5e96771a3f2.zip
libmpeg3 support workaround
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/ChangeLog5
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.9-r2.ebuild25
2 files changed, 20 insertions, 10 deletions
diff --git a/dev-libs/DirectFB/ChangeLog b/dev-libs/DirectFB/ChangeLog
index f754b681b017..112340033e6f 100644
--- a/dev-libs/DirectFB/ChangeLog
+++ b/dev-libs/DirectFB/ChangeLog
@@ -1,12 +1,15 @@
# ChangeLog for dev-libs/DirectFB
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.5 2002/04/16 03:15:43 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.6 2002/04/16 03:26:37 seemant Exp $
*DirectFB-0.9.9-r2 (15 Apr 2002)
15 Apr 2002; Seemant Kulleen <seemant@gentoo.org> DirectFB-0.9.9-r2.ebuild :
+ Update: blah, this needs the unpacked libmpeg3 tarball itself. It seems to
+ completely vomit on an installed libmpeg3. Sigh.
+
avi support is broken, and libmpeg3 support is broken as well. Upstream
has been made aware of the libmpeg3 issue, so that will hopefully get
sorted out soon.
diff --git a/dev-libs/DirectFB/DirectFB-0.9.9-r2.ebuild b/dev-libs/DirectFB/DirectFB-0.9.9-r2.ebuild
index 6112182d7d8f..928227a6f881 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.9-r2.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.9-r2.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: system@gentoo.org
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.9-r2.ebuild,v 1.1 2002/04/16 03:15:43 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.9-r2.ebuild,v 1.2 2002/04/16 03:26:37 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="DirectFB is a thin library on top of the Linux framebuffer devices"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz
+ mpeg? http://heroinewarrior.com/libmpeg3-1.5.tar.gz"
HOMEPAGE="http://www.directfb.org"
DEPEND="sys-devel/perl
@@ -16,13 +17,20 @@ DEPEND="sys-devel/perl
truetype? ( >=media-libs/freetype-2.0.1 )
quicktime? ( media-libs/quicktime4linux )"
# avi? ( =media-video/avifile-0.6* )
-# mpeg? ( >=media-libs/libmpeg3-1.5 )
RDEPEND="${DEPEND}"
#extralibinfo=""
#use mpeg && extralibinfo="LIBMPEG3_DIR=/usr/lib LIBMPEG3_LIBS=-lmpeg3"
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${WORKDIR}/libmpeg3
+ make
+}
+
src_compile() {
local myconf
@@ -37,13 +45,12 @@ src_compile() {
# && myconf="${myconf} --enable-avifile" \
# || myconf="${myconf} --disable-avifile"
-# use mpeg \
-# && myconf="${myconf} --with-libmpeg3=/usr/include/libmpeg3" \
-# && mkdir ${S}/interfaces/IDirectFBVideoProvider/no \
-# || myconf="${myconf} --without-libmpeg3"
-
- myconf="${myconf} --disable-avifile --disable-libmpeg3"
+ myconf="${myconf} --disable-avifile"
+ use mpeg \
+ && myconf="${myconf} --with-libmpeg3=${WORKDIR}/libmpeg3" \
+ || myconf="${myconf} --disable-libmpeg3"
+
use jpeg \
&& myconf="${myconf} --enable-jpeg" \
|| myconf="${myconf} --disable-jpeg"