summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-10-18 21:11:07 +0000
committerMike Frysinger <vapier@gentoo.org>2014-10-18 21:11:07 +0000
commit9f9d6be7c750e61c0c71c633b093ff0e03ca5293 (patch)
treed16b2dcbd21f7d19f1f1a06c012a3c9237f37ea8 /dev-libs/DirectFB/DirectFB-1.7.1.ebuild
parentRemove bogus m-n tag. (diff)
downloadgentoo-2-9f9d6be7c750e61c0c71c633b093ff0e03ca5293.tar.gz
gentoo-2-9f9d6be7c750e61c0c71c633b093ff0e03ca5293.tar.bz2
gentoo-2-9f9d6be7c750e61c0c71c633b093ff0e03ca5293.zip
Hard disable xine vdpau support #499740 by Silvio.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-libs/DirectFB/DirectFB-1.7.1.ebuild')
-rw-r--r--dev-libs/DirectFB/DirectFB-1.7.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-libs/DirectFB/DirectFB-1.7.1.ebuild b/dev-libs/DirectFB/DirectFB-1.7.1.ebuild
index 1e73a0f23bdf..569f0c08dff3 100644
--- a/dev-libs/DirectFB/DirectFB-1.7.1.ebuild
+++ b/dev-libs/DirectFB/DirectFB-1.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.7.1.ebuild,v 1.2 2014/07/31 06:02:26 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.7.1.ebuild,v 1.3 2014/10/18 21:11:07 vapier Exp $
EAPI=5
inherit autotools eutils toolchain-funcs
@@ -123,6 +123,8 @@ src_configure() {
use input_hub && inputdrivers="${inputdrivers},input_hub"
inputdrivers="$(echo ${inputdrivers} | sed 's/none,//')"
+ # The xine-vdpau flag requires a custom patch to xine-lib which we don't carry:
+ # http://git.directfb.org/?p=extras/DirectFB-extra.git;a=blob;f=interfaces/IDirectFBVideoProvider/xine-lib-1.2-vdpau-hooks.patch;hb=HEAD
econf \
$(use_enable static-libs static) \
$(use_enable X x11) \
@@ -148,7 +150,7 @@ src_configure() {
$(use_enable mpeg3 libmpeg3) \
--disable-flash \
$(use_enable xine) \
- $(usex xine "$(use_enable vdpau xine-vdpau)" "--disable-xine-vdpau") \
+ --disable-xine-vdpau \
--disable-ffmpeg \
$(use_enable bmp) \
$(use_enable jpeg2k jpeg2000) \