summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2005-05-07 16:36:19 +0000
committerBryan Østergaard <kloeri@gentoo.org>2005-05-07 16:36:19 +0000
commitbbbec6e3354e7249d5b93df675b18d58693d577e (patch)
tree049f92aa611add7d7bd49d6c1fa6e89b4e30ca80 /dev-lang
parentfinally a new update to openoffice-ximian-bin (diff)
downloadgentoo-2-bbbec6e3354e7249d5b93df675b18d58693d577e.tar.gz
gentoo-2-bbbec6e3354e7249d5b93df675b18d58693d577e.tar.bz2
gentoo-2-bbbec6e3354e7249d5b93df675b18d58693d577e.zip
Don't skip sax test.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.3.5.ebuild31
-rw-r--r--dev-lang/python/python-2.4.1.ebuild4
2 files changed, 4 insertions, 31 deletions
diff --git a/dev-lang/python/python-2.3.5.ebuild b/dev-lang/python/python-2.3.5.ebuild
index 163bcf826dcb..e8ec9d6b1f05 100644
--- a/dev-lang/python/python-2.3.5.ebuild
+++ b/dev-lang/python/python-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.11 2005/05/07 16:30:24 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.12 2005/05/07 16:36:19 kloeri Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -134,33 +134,6 @@ src_compile() {
emake || die "Parallel make failed"
}
-src_test() {
- local skip_tests="import sax"
- #Move known bad tests out of the way while we run good ones
- for test in ${skip_tests} ; do
- mv ${S}/Lib/test/test_${test}.py ${T}
- done
-
- make test || die "make test failed"
-
- #Move bad tests back so they get emerged
- for test in ${skip_tests} ; do
- mv ${T}/test_${test}.py ${S}/Lib/test/test_${test}.py
- done
-
- einfo "Portage skipped the following tests which aren't able to run from emerge:"
- for test in ${skip_tests} ; do
- einfo "test_${test}.py"
- done
- einfo "These tests normally pass when not run from emerge."
- einfo "If you'd like to run them, you may:"
- einfo "cd /usr/lib/python${PYVER}/test"
- einfo "and run the tests separately."
- einfo "See bug# 67970"
- ebeep 2
-}
-
-
src_install() {
dodir /usr
src_configure
@@ -240,7 +213,7 @@ src_test() {
#skip all tests that fail during emerge but pass without emerge:
#(See bug# 67970)
- local skip_tests="sax subprocess tcl urllib urllib2"
+ local skip_tests="subprocess tcl urllib urllib2"
for test in ${skip_tests} ; do
mv ${S}/Lib/test/test_${test}.py ${T}
diff --git a/dev-lang/python/python-2.4.1.ebuild b/dev-lang/python/python-2.4.1.ebuild
index 6081b77bc045..7773397d5e50 100644
--- a/dev-lang/python/python-2.4.1.ebuild
+++ b/dev-lang/python/python-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.1.ebuild,v 1.3 2005/05/07 16:30:24 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.1.ebuild,v 1.4 2005/05/07 16:36:19 kloeri Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -231,7 +231,7 @@ src_test() {
#skip all tests that fail during emerge but pass without emerge:
#(See bug# 67970)
- local skip_tests="sax subprocess tcl urllib urllib2"
+ local skip_tests="subprocess tcl urllib urllib2"
for test in ${skip_tests} ; do
mv ${S}/Lib/test/test_${test}.py ${T}