summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-28 00:30:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-28 00:30:08 +0000
commit82cfbb087f17cab6e844c8698696d0a2cc96bc7a (patch)
tree3f1a92f34ca8bef0e172f9ea064b49d8df997c34 /dev-lang
parentnet-analyzer/piwi masked per bug 66167 and bug 91466 (diff)
downloadgentoo-2-82cfbb087f17cab6e844c8698696d0a2cc96bc7a.tar.gz
gentoo-2-82cfbb087f17cab6e844c8698696d0a2cc96bc7a.tar.bz2
gentoo-2-82cfbb087f17cab6e844c8698696d0a2cc96bc7a.zip
use versionator eclass instead of echo|cut
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.1.3-r1.ebuild16
-rw-r--r--dev-lang/python/python-2.2.3-r6.ebuild12
-rw-r--r--dev-lang/python/python-2.3.4-r1.ebuild9
-rw-r--r--dev-lang/python/python-2.3.5.ebuild9
-rw-r--r--dev-lang/python/python-2.4-r3.ebuild14
-rw-r--r--dev-lang/python/python-2.4.1.ebuild6
6 files changed, 30 insertions, 36 deletions
diff --git a/dev-lang/python/python-2.1.3-r1.ebuild b/dev-lang/python/python-2.1.3-r1.ebuild
index 4ac663a9160f..01df0de99c29 100644
--- a/dev-lang/python/python-2.1.3-r1.ebuild
+++ b/dev-lang/python/python-2.1.3-r1.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3-r1.ebuild,v 1.20 2005/05/28 00:21:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3-r1.ebuild,v 1.21 2005/05/28 00:30:08 vapier Exp $
-IUSE="readline tcltk berkdb"
-
-PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
+PYVER_MAJOR=$(get_major_version)
+PYVER_MINOR=$(get_version_component_range 2)
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
S=${WORKDIR}/Python-${PV}
+
DESCRIPTION="A really great language"
+HOMEPAGE="http://www.python.org"
SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz"
-HOMEPAGE="http://www.python.org"
LICENSE="PSF-2.1.1"
+SLOT="2.1"
KEYWORDS="x86 sparc alpha ia64 ppc"
+IUSE="readline tcltk berkdb"
-DEPEND="virtual/libc >=sys-libs/zlib-1.1.3
+DEPEND=">=sys-libs/zlib-1.1.3
readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
berkdb? ( >=sys-libs/db-3 )
tcltk? ( >=dev-lang/tk-8.0 )"
@@ -24,7 +25,6 @@ DEPEND="virtual/libc >=sys-libs/zlib-1.1.3
# the functionality expected from previous pythons.
PROVIDE="virtual/python"
-SLOT="2.1"
src_compile() {
export OPT="$CFLAGS"
diff --git a/dev-lang/python/python-2.2.3-r6.ebuild b/dev-lang/python/python-2.2.3-r6.ebuild
index b2bbe9e425e9..3cefb614fbda 100644
--- a/dev-lang/python/python-2.2.3-r6.ebuild
+++ b/dev-lang/python/python-2.2.3-r6.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r6.ebuild,v 1.2 2005/05/28 00:21:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r6.ebuild,v 1.3 2005/05/28 00:30:08 vapier Exp $
inherit flag-o-matic eutils python
-PYVER_MAJOR="`echo ${PV%_*} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV%_*} | cut -d '.' -f 2`"
+PYVER_MAJOR=$(get_major_version)
+PYVER_MINOR=$(get_version_component_range 2)
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
S="${WORKDIR}/Python-${PV}"
@@ -14,11 +14,11 @@ HOMEPAGE="http://www.python.org"
SRC_URI="http://www.python.org/ftp/python/${PV%_*}/Python-${PV}.tgz"
LICENSE="PSF-2.2"
+SLOT="2.2"
KEYWORDS="amd64 x86 ppc sparc alpha mips hppa ia64 ppc64"
IUSE="berkdb bootstrap build doc gdbm ncurses readline ssl tcltk nocxx"
-DEPEND="virtual/libc
- >=sys-libs/zlib-1.1.3
+DEPEND=">=sys-libs/zlib-1.1.3
!build? ( tcltk? ( >=dev-lang/tk-8.0 )
ncurses? ( >=sys-libs/ncurses-5.2 readline? ( >=sys-libs/readline-4.1 ) )
berkdb? ( >=sys-libs/db-3 )
@@ -35,8 +35,6 @@ RDEPEND="${DEPEND} dev-python/python-fchksum"
PROVIDE="virtual/python"
-SLOT="2.2"
-
src_unpack() {
unpack ${A}
#Fixes security vulnerability in XML-RPC server - pythonhead (06 Feb 05)
diff --git a/dev-lang/python/python-2.3.4-r1.ebuild b/dev-lang/python/python-2.3.4-r1.ebuild
index 96820a75ec55..5a5ecc3f90c6 100644
--- a/dev-lang/python/python-2.3.4-r1.ebuild
+++ b/dev-lang/python/python-2.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4-r1.ebuild,v 1.6 2005/05/28 00:21:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4-r1.ebuild,v 1.7 2005/05/28 00:30:08 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -9,8 +9,8 @@
inherit eutils flag-o-matic python
-PYVER_MAJOR="`echo ${PV%_*} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV%_*} | cut -d '.' -f 2`"
+PYVER_MAJOR=$(get_major_version)
+PYVER_MINOR=$(get_version_component_range 2)
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
S="${WORKDIR}/Python-${PV}"
@@ -23,8 +23,7 @@ SLOT="2.3"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc s390 sh sparc x86 ppc64"
IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X uclibc nocxx"
-DEPEND="virtual/libc
- >=sys-libs/zlib-1.1.3
+DEPEND=">=sys-libs/zlib-1.1.3
!build? (
X? ( tcltk? ( >=dev-lang/tk-8.0 ) )
ncurses? ( >=sys-libs/ncurses-5.2 readline? ( >=sys-libs/readline-4.1 ) )
diff --git a/dev-lang/python/python-2.3.5.ebuild b/dev-lang/python/python-2.3.5.ebuild
index 3cad0db65697..73217dd60a85 100644
--- a/dev-lang/python/python-2.3.5.ebuild
+++ b/dev-lang/python/python-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.15 2005/05/28 00:21:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.16 2005/05/28 00:30:08 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -9,8 +9,8 @@
inherit eutils flag-o-matic python
-PYVER_MAJOR="`echo ${PV%_*} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV%_*} | cut -d '.' -f 2`"
+PYVER_MAJOR=$(get_major_version)
+PYVER_MINOR=$(get_version_component_range 2)
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
S="${WORKDIR}/Python-${PV}"
@@ -23,8 +23,7 @@ SLOT="2.3"
KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ~ppc64 s390 sh sparc x86"
IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X uclibc nocxx"
-DEPEND="virtual/libc
- >=sys-libs/zlib-1.1.3
+DEPEND=">=sys-libs/zlib-1.1.3
!build? (
X? ( tcltk? ( >=dev-lang/tk-8.0 ) )
ncurses? ( >=sys-libs/ncurses-5.2 readline? ( >=sys-libs/readline-4.1 ) )
diff --git a/dev-lang/python/python-2.4-r3.ebuild b/dev-lang/python/python-2.4-r3.ebuild
index edd9598e6008..82c7c77bb87f 100644
--- a/dev-lang/python/python-2.4-r3.ebuild
+++ b/dev-lang/python/python-2.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4-r3.ebuild,v 1.4 2005/05/28 00:21:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4-r3.ebuild,v 1.5 2005/05/28 00:30:08 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -9,23 +9,21 @@
inherit eutils flag-o-matic python multilib
-PYVER_MAJOR="`echo ${PV%_*} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV%_*} | cut -d '.' -f 2`"
+PYVER_MAJOR=$(get_major_version)
+PYVER_MINOR=$(get_version_component_range 2)
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
MY_P="Python-${PV}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="A really great language"
+HOMEPAGE="http://www.python.org/"
SRC_URI="http://www.python.org/ftp/python/${PYVER}/${MY_P}.tar.bz2"
-HOMEPAGE="http://www.python.org"
-IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X uclibc nocxx"
LICENSE="PSF-2.2"
SLOT="2.4"
-
KEYWORDS="~x86 ~ppc ~sparc ~arm ~hppa ~amd64 ~s390 ~alpha ~ia64 ~mips"
+IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X uclibc nocxx"
-DEPEND="virtual/libc
- >=sys-libs/zlib-1.1.3
+DEPEND=">=sys-libs/zlib-1.1.3
!build? (
X? ( tcltk? ( >=dev-lang/tk-8.0 ) )
ncurses? ( >=sys-libs/ncurses-5.2 readline? ( >=sys-libs/readline-4.1 ) )
diff --git a/dev-lang/python/python-2.4.1.ebuild b/dev-lang/python/python-2.4.1.ebuild
index 2652a4499098..61e77447c9c3 100644
--- a/dev-lang/python/python-2.4.1.ebuild
+++ b/dev-lang/python/python-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.1.ebuild,v 1.5 2005/05/28 00:21:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.1.ebuild,v 1.6 2005/05/28 00:30:08 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -10,8 +10,8 @@
inherit eutils flag-o-matic python multilib
# we need this so that we don't depends on python.eclass
-PYVER_MAJOR="`echo ${PV%_*} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV%_*} | cut -d '.' -f 2`"
+PYVER_MAJOR=$(get_major_version)
+PYVER_MINOR=$(get_version_component_range 2)
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
MY_P="Python-${PV}"