summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-01-26 03:37:44 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-01-26 03:37:44 +0000
commit76af8186387d83195851c83b9478bc60b2fc6610 (patch)
treeaf79f864e575f04eefc796a8ff081b0acaf20197 /dev-lang
parentBump (diff)
downloadgentoo-2-76af8186387d83195851c83b9478bc60b2fc6610.tar.gz
gentoo-2-76af8186387d83195851c83b9478bc60b2fc6610.tar.bz2
gentoo-2-76af8186387d83195851c83b9478bc60b2fc6610.zip
Bump
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nqp/ChangeLog7
-rw-r--r--dev-lang/nqp/nqp-2015.01.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-lang/nqp/ChangeLog b/dev-lang/nqp/ChangeLog
index 7ff3b94f6172..f8c1bfa2d5f9 100644
--- a/dev-lang/nqp/ChangeLog
+++ b/dev-lang/nqp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/nqp
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.58 2015/01/23 03:50:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.59 2015/01/26 03:37:44 patrick Exp $
+
+*nqp-2015.01 (26 Jan 2015)
+
+ 26 Jan 2015; Patrick Lauer <patrick@gentoo.org> +nqp-2015.01.ebuild:
+ Bump
23 Jan 2015; Patrick Lauer <patrick@gentoo.org> nqp-2014.12.ebuild:
Work around weird build system failure with libffi, add missing dep on libffi
diff --git a/dev-lang/nqp/nqp-2015.01.ebuild b/dev-lang/nqp/nqp-2015.01.ebuild
new file mode 100644
index 000000000000..f9aaf60ad1ad
--- /dev/null
+++ b/dev-lang/nqp/nqp-2015.01.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2015.01.ebuild,v 1.1 2015/01/26 03:37:44 patrick Exp $
+
+EAPI=5
+
+# still not working
+RESTRICT="test"
+
+inherit eutils multilib versionator
+
+GITCRAP=bba0461
+PARROT_VERSION="6.7.0"
+
+DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
+HOMEPAGE="http://rakudo.org/"
+SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc +parrot java moar"
+REQUIRED_USE="|| ( parrot java moar )"
+
+RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
+ java? ( >=virtual/jre-1.7 )
+ moar? ( =dev-lang/moarvm-${PV} )
+ dev-libs/libffi"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.7 )
+ dev-lang/perl"
+
+S=${WORKDIR}/perl6-nqp-${GITCRAP}
+
+src_configure() {
+ use java && myconf+="jvm,"
+ use parrot && myconf+="parrot,"
+ use moar && myconf+="moar,"
+ perl Configure.pl --backend=${myconf} --prefix=/usr || die
+ # dirty hack to make dyncall not fail
+ sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
+ sed -i -e 's/-Werror=missing-declarations//' Makefile || die
+ sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
+
+ # more dirty hack to allow building with newer gcc
+ sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
+ sed -i -e 's/-Werror=nested-externs//' Makefile || die
+
+ # horrible hackery, but we need to know where libffi hides its headers ...
+ libffi_path=$(echo /usr/lib64/libffi-*)
+ sed -i -e "s:/usr/lib64/libffi-3.1:${libffi_path}:" Makefile || die
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ dodoc CREDITS README.pod || die
+
+ if use doc; then
+ dodoc -r docs/* || die
+ fi
+}