summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-12-07 14:34:21 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-12-07 14:34:21 +0000
commit382cae9e8fcbe67389fdc9a72c1c20bc4a859a2b (patch)
tree93b205b840b28205a680e88fe23677d8c0f584c4 /dev-lang
parentVersion bumped. (diff)
downloadgentoo-2-382cae9e8fcbe67389fdc9a72c1c20bc4a859a2b.tar.gz
gentoo-2-382cae9e8fcbe67389fdc9a72c1c20bc4a859a2b.tar.bz2
gentoo-2-382cae9e8fcbe67389fdc9a72c1c20bc4a859a2b.zip
Version bumped.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcl/Manifest2
-rw-r--r--dev-lang/tcl/files/digest-tcl-8.4.51
-rw-r--r--dev-lang/tcl/tcl-8.4.5.ebuild82
-rw-r--r--dev-lang/tk/ChangeLog7
-rw-r--r--dev-lang/tk/Manifest4
-rw-r--r--dev-lang/tk/files/digest-tk-8.4.51
-rw-r--r--dev-lang/tk/tk-8.4.5.ebuild72
7 files changed, 165 insertions, 4 deletions
diff --git a/dev-lang/tcl/Manifest b/dev-lang/tcl/Manifest
index 07866ecf2599..dbfb85ad44db 100644
--- a/dev-lang/tcl/Manifest
+++ b/dev-lang/tcl/Manifest
@@ -1,5 +1,5 @@
MD5 efce7f63c18f3658617fda1b3f7d5838 tcl-8.3.3-r1.ebuild 2065
-MD5 46b516f94bc74d0d88d9242cf2aa5b13 tcl-8.4.5.ebuild 2623
+MD5 a601490dc762a9394a37a16e4fd64b36 tcl-8.4.5.ebuild 2623
MD5 13074b32eac31e630c13fedfca62cba6 ChangeLog 3098
MD5 056b9e2cb6cdb3310174a9a2d3a90b62 tcl-8.4.3.ebuild 2668
MD5 46b516f94bc74d0d88d9242cf2aa5b13 tcl-8.4.4.ebuild 2623
diff --git a/dev-lang/tcl/files/digest-tcl-8.4.5 b/dev-lang/tcl/files/digest-tcl-8.4.5
new file mode 100644
index 000000000000..f0ee055c52f4
--- /dev/null
+++ b/dev-lang/tcl/files/digest-tcl-8.4.5
@@ -0,0 +1 @@
+MD5 3fb354dba28166a1004f9103553a3974 tcl8.4.5-src.tar.gz 3444510
diff --git a/dev-lang/tcl/tcl-8.4.5.ebuild b/dev-lang/tcl/tcl-8.4.5.ebuild
new file mode 100644
index 000000000000..476820bc6e88
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.4.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.5.ebuild,v 1.1 2003/12/07 14:33:30 mholzer Exp $
+
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tool Command Language"
+
+DEPEND="virtual/glibc
+ >=app-portage/gentoolkit-0.1.22"
+RDEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc ~mips amd64"
+IUSE=""
+
+# hyper-optimizations untested...
+#
+
+src_compile() {
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die
+ # threading is not recommended as it breaks some packages
+ # --enable-threads \
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ S= make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ -e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tcl${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
+ dodir /usr/lib/tcl${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
+ dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
+
+ ln -sf tclsh${v1} ${D}/usr/bin/tclsh
+
+ cd ${S}
+ dodoc README changes license.terms
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you're upgrading from tcl-8.3, you must recompile the other"
+ ewarn "packages on your system that link with tcl after the upgrade"
+ ewarn "completes. To perform this action, please run revdep-rebuild."
+ ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
+ ewarn "upgrade them before this recompilation, too,"
+ ewarn
+ sleep 5
+}
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index e7ed2ef95594..368acbcaacf0 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/tk
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.21 2003/12/07 14:19:55 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.22 2003/12/07 14:34:09 mholzer Exp $
+
+*tk-8.4.5 (07 Dec 2003)
+
+ 07 Dec 2003; Martin Holzer <mholzer@gentoo.org> tk-8.4.5.ebuild:
+ Version bumped.
07 Dec 2003; Martin Holzer <mholzer@gentoo.org> tk-8.4.3.ebuild,
tk-8.4.4.ebuild:
diff --git a/dev-lang/tk/Manifest b/dev-lang/tk/Manifest
index b165cad022fb..54527e1d3335 100644
--- a/dev-lang/tk/Manifest
+++ b/dev-lang/tk/Manifest
@@ -1,11 +1,11 @@
MD5 3bf4cdc593e70a244ff64a90edcaa10f tk-8.3.4-r1.ebuild 2002
MD5 5fab02ac34ec7fc0046c6a8f7c39144a tk-8.4.3.ebuild 1998
-MD5 908b4cc01befef3412530ce7dd7234d1 tk-8.4.5.ebuild 2011
+MD5 2e0631828d684219d9be8298dca4491a tk-8.4.5.ebuild 2011
MD5 54cdba17fa649ca601f6e7fdac0b18e2 tk-8.3.3.ebuild 2011
MD5 8a95a04a3123e4062f4524f88fb46e27 tk-8.3.3-r2.ebuild 2068
MD5 908b4cc01befef3412530ce7dd7234d1 tk-8.4.4.ebuild 2011
MD5 ddf741f74e32a66149d087fde2b44160 tk-8.3.4.ebuild 2180
-MD5 8256ad3cc6aa45b100b60d5d6edc17a6 ChangeLog 3349
+MD5 46c77ca3a1d7074bdc02e2b4ab132534 ChangeLog 3460
MD5 d0c04c9c5e0966aeec62ce08ba5ec5eb tk-8.3.3-r3.ebuild 2178
MD5 2ba3335fd9167fef8f3f99be70675257 files/digest-tk-8.3.3-r2 60
MD5 b3e7fb189b73f361f1fa7abddd3ee14a files/digest-tk-8.4.3 64
diff --git a/dev-lang/tk/files/digest-tk-8.4.5 b/dev-lang/tk/files/digest-tk-8.4.5
new file mode 100644
index 000000000000..b3eadf92c13d
--- /dev/null
+++ b/dev-lang/tk/files/digest-tk-8.4.5
@@ -0,0 +1 @@
+MD5 3bafe03fc79dc72c3c8bfbe2c54cc52a tk8.4.5-src.tar.gz 3218856
diff --git a/dev-lang/tk/tk-8.4.5.ebuild b/dev-lang/tk/tk-8.4.5.ebuild
new file mode 100644
index 000000000000..c2f3fcace675
--- /dev/null
+++ b/dev-lang/tk/tk-8.4.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.5.ebuild,v 1.1 2003/12/07 14:34:09 mholzer Exp $
+
+inherit eutils
+
+DESCRIPTION="Tk Widget Set"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
+RESTRICT="nomirror"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~mips amd64"
+
+DEPEND=">=sys-apps/sed-4.0.5
+ >=sys-apps/portage-2.0.47-r10
+ virtual/x11
+ =dev-lang/tcl-${PV}*"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/library
+ epatch ${FILESDIR}/remove-control-v-8.4.diff || die
+}
+
+# hyper-optimizations untested...
+#
+src_compile() {
+ cd ${S}/unix
+ econf \
+ --with-tcl=/usr/lib \
+ --enable-threads || die
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tkConfig.sh to eliminate refs to the build directory
+ sed -i \
+ -e "s,^\(TK_BUILD_LIB_SPEC='-L\)${S}/unix,\1/usr/lib," \
+ -e "s,^\(TK_SRC_DIR='\)${S}',\1/usr/lib/tk${v1}/include'," \
+ -e "s,^\(TK_BUILD_STUB_LIB_SPEC='-L\)${S}/unix,\1/usr/lib," \
+ -e "s,^\(TK_BUILD_STUB_LIB_PATH='\)${S}/unix,\1/usr/lib," \
+ ${D}/usr/lib/tkConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tk${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tk${v1}/include/unix
+ dodir /usr/lib/tk${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tk${v1}/include/generic
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tk.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkDecls.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkPlatDecls.h
+
+ # install symlink for libraries
+ #dosym /usr/lib/libtk${v1}.a /usr/lib/libtk.a
+ dosym /usr/lib/libtk${v1}.so /usr/lib/libtk.so
+ dosym /usr/lib/libtkstub${v1}.a /usr/lib/libtkstub.a
+
+ ln -sf wish${v1} ${D}/usr/bin/wish
+
+ cd ${S}
+ dodoc README changes license.terms
+}