summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2009-11-04 15:05:55 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2009-11-04 15:05:55 +0000
commit2a555efd8a11fcd092548d2b5f3a83ca1a7b1a58 (patch)
tree3a087a1421e29ed28dd0795258b7b27db7a7d95c /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-2a555efd8a11fcd092548d2b5f3a83ca1a7b1a58.tar.gz
gentoo-2-2a555efd8a11fcd092548d2b5f3a83ca1a7b1a58.tar.bz2
gentoo-2-2a555efd8a11fcd092548d2b5f3a83ca1a7b1a58.zip
Respect CFLAGS also when linking executables, not just for libperl
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog6
-rw-r--r--dev-lang/perl/files/perl-5.8.8-ccld-cflags.patch22
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index 2638bdce6b5b..62bfa80d5c2c 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/perl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.293 2009/11/04 12:39:15 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.294 2009/11/04 15:05:54 haubi Exp $
+
+ 04 Nov 2009; Michael Haubenwallner <haubi@gentoo.org>
+ files/perl-5.8.8-ccld-cflags.patch:
+ Respect CFLAGS also when linking executables, not just for libperl
04 Nov 2009; Michael Haubenwallner <haubi@gentoo.org>
perl-5.8.8-r6.ebuild, +files/perl-5.8.8-ccld-cflags.patch:
diff --git a/dev-lang/perl/files/perl-5.8.8-ccld-cflags.patch b/dev-lang/perl/files/perl-5.8.8-ccld-cflags.patch
index d1fcbb4a2315..85f66fe2c99c 100644
--- a/dev-lang/perl/files/perl-5.8.8-ccld-cflags.patch
+++ b/dev-lang/perl/files/perl-5.8.8-ccld-cflags.patch
@@ -9,3 +9,25 @@
else
echo "I'll use ld to build dynamic libraries."
dflt='ld'
+--- Makefile.SH.orig 2009-11-04 15:34:22.643322823 +0100
++++ Makefile.SH 2009-11-04 15:34:30.110147884 +0100
+@@ -201,7 +201,7 @@
+ LD = $ld
+
+ LDFLAGS = $ldflags
+-CLDFLAGS = $ldflags
++CLDFLAGS = \$(OPTIMIZE) $ldflags
+
+ mallocsrc = $mallocsrc
+ mallocobj = $mallocobj
+--- x2p/Makefile.SH.orig 2009-11-04 15:54:14.146759212 +0100
++++ x2p/Makefile.SH 2009-11-04 15:54:19.963253154 +0100
+@@ -107,7 +107,7 @@
+ $(REALPERL) -I../lib ../utils/perlcc -I .. -L .. $(plextract) -v -log ../compilelog;
+
+ a2p$(EXE_EXT): $(obj) a2p$(OBJ_EXT)
+- $(CC) -o a2p $(LDFLAGS) $(obj) a2p$(OBJ_EXT) $(libs)
++ $(CC) -o a2p $(OPTIMIZE) $(LDFLAGS) $(obj) a2p$(OBJ_EXT) $(libs)
+
+ # I now supply a2p.c with the kits, so the following section is
+ # used only if you force byacc to run by saying