summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-11-12 15:38:02 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-11-12 15:38:02 +0000
commit106f4b2a8ad777e36c512718c3eddd3c28e987ea (patch)
tree8edd56a7a2c4d6a8a09253dd3afedfa57926c43a /dev-lang
parentBump to stable on x86 (diff)
downloadgentoo-2-106f4b2a8ad777e36c512718c3eddd3c28e987ea.tar.gz
gentoo-2-106f4b2a8ad777e36c512718c3eddd3c28e987ea.tar.bz2
gentoo-2-106f4b2a8ad777e36c512718c3eddd3c28e987ea.zip
Prettier fPIC support
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/Manifest5
-rw-r--r--dev-lang/python/files/python-2.2.3-fPIC.patch15
-rw-r--r--dev-lang/python/python-2.2.3-r5.ebuild4
4 files changed, 27 insertions, 4 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 7ff82fe130e6..8de8f4b6715c 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.48 2003/11/03 20:57:50 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.49 2003/11/12 15:37:56 aliz Exp $
+
+ 12 Nov 2003; Daniel Ahlberg <aliz@gentoo.org> python-2.2.3-r5.ebuild :
+ Add a patch that adds CFLAGSFORSHARED variable to some extra modules defined in the Makefile.
+ This variable could hold -fPIC so that the compiled libraries will work on amd64 (and maybe others)
+ without using append-flags -fPIC.
03 Nov 2003; Alastair Tse <liquidx@gentoo.org> python-2.2.3-r5.ebuild,
python-2.3.2-r1.ebuild:
diff --git a/dev-lang/python/Manifest b/dev-lang/python/Manifest
index 89701e0c71c2..8eaa13348ff6 100644
--- a/dev-lang/python/Manifest
+++ b/dev-lang/python/Manifest
@@ -1,7 +1,7 @@
MD5 48d3de450107a8702bbd30ddfdceeed2 python-2.2.3-r3.ebuild 3488
MD5 b5ce70d94f27185e138e67267ff416fe python-2.2.2-r1.ebuild 3123
MD5 789d8555967a31cc0de2126fa6468fc2 python-2.2.3.ebuild 2999
-MD5 3cd89fdbd28f90e7cea2ea70b90a67e7 python-2.2.3-r5.ebuild 4332
+MD5 ed2d4e2aa82ebe752d2d35b864325c1f python-2.2.3-r5.ebuild 4445
MD5 a5eec23c78d6a0923c477e34ce969392 python-2.3.2-r1.ebuild 4812
MD5 0a274212a2a49a52600b617a38bafa09 python-2.2.3-r2.ebuild 3441
MD5 c70d578ef0b3e6358108691e8b88d458 python-2.2.2.ebuild 3027
@@ -10,7 +10,7 @@ MD5 5806acebfc91d925f328a751fd5503e5 python-2.2.3-r4.ebuild 3491
MD5 f7959cf61958991a7e25f83a4e8b2ff8 python-2.2.1-r5.ebuild 2912
MD5 7c0dcd5a1aa1ec0db97cd0847faab0d7 python-2.3.2.ebuild 3675
MD5 58ed89f3cc48f16f8bc96b76490e5b6a python-2.2.3-r1.ebuild 3293
-MD5 503d0b0e7c89b76f8593493c78a86ff1 ChangeLog 9114
+MD5 e12392431d48506d39dd55068bd3c1af ChangeLog 9419
MD5 8145ce0144332d6caca98fa5fb648741 metadata.xml 221
MD5 b0e12c8b4f21bea05842149e9bd5ac94 files/python-updater 7397
MD5 5f2361b3e770981b737a9ad3d2863931 files/python-2.2.1-r5-gentoo.diff 4152
@@ -20,6 +20,7 @@ MD5 aafa57d90e8894592bdf346eedc77faa files/digest-python-2.3.2 62
MD5 11aa066154fe2e0a4c306124c7e5dd4a files/python-2.2.2-tk-8.4.x.patch 2997
MD5 07398060a831f18193315973df204cbf files/python-2.2.3-gentoo_py_dontcompile.patch 732
MD5 96d4207fb41391c70d5f02e1785c9527 files/python-2.2.3-db4.patch 1220
+MD5 9fe31aedbbc7e8ea1847ed6dd70bf15b files/python-2.2.3-fPIC.patch 767
MD5 b530d6f9dbcf30239061be3de80932cc files/python-config-2.2 178
MD5 201acd1cfd5124f25c58a8db3f78a502 files/python-config-2.3 178
MD5 7808762bbf53647c7cd597be4044e9f7 files/python-2.3-gentoo_py_dontcompile.patch 478
diff --git a/dev-lang/python/files/python-2.2.3-fPIC.patch b/dev-lang/python/files/python-2.2.3-fPIC.patch
new file mode 100644
index 000000000000..8d7941425701
--- /dev/null
+++ b/dev-lang/python/files/python-2.2.3-fPIC.patch
@@ -0,0 +1,15 @@
+--- Makefile.pre.in 2003-11-12 16:26:28.343596800 +0100
++++ Makefile.pre.in 2003-11-12 16:27:19.098880824 +0100
+@@ -418,10 +418,10 @@
+ Python/compile.o Python/symtable.o: $(GRAMMAR_H)
+
+ Python/getplatform.o: $(srcdir)/Python/getplatform.c
+- $(CC) -c $(CFLAGS) $(CPPFLAGS) -DPLATFORM='"$(MACHDEP)"' -o $@ $(srcdir)/Python/getplatform.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) $(CFLAGSFORSHARED) -DPLATFORM='"$(MACHDEP)"' -o $@ $(srcdir)/Python/getplatform.c
+
+ Python/importdl.o: $(srcdir)/Python/importdl.c
+- $(CC) -c $(CFLAGS) $(CPPFLAGS) -I$(DLINCLDIR) -o $@ $(srcdir)/Python/importdl.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) $(CFLAGSFORSHARED) -I$(DLINCLDIR) -o $@ $(srcdir)/Python/importdl.c
+
+ Objects/object.o: $(srcdir)/Objects/object.c $(srcdir)/Objects/obmalloc.c
+
diff --git a/dev-lang/python/python-2.2.3-r5.ebuild b/dev-lang/python/python-2.2.3-r5.ebuild
index 420de0cb9740..83a05262932b 100644
--- a/dev-lang/python/python-2.2.3-r5.ebuild
+++ b/dev-lang/python/python-2.2.3-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r5.ebuild,v 1.6 2003/11/03 22:17:40 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r5.ebuild,v 1.7 2003/11/12 15:37:56 aliz Exp $
inherit flag-o-matic eutils python
@@ -44,6 +44,7 @@ src_unpack() {
EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${P}-disable_modules_and_ssl.patch
EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-2.3-add_portage_search_path.patch
epatch ${FILESDIR}/${PN}-2.2.3-gentoo_py_dontcompile.patch
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${P}-fPIC.patch
}
src_configure() {
@@ -73,6 +74,7 @@ src_compile() {
[ "${ARCH}" = "hppa" ] && append-flags -fPIC
[ "${ARCH}" = "alpha" ] && append-flags -fPIC
+ [ "${ARCH}" = "amd64" ] && export CFLAGSFORSHARED="-fPIC"
export OPT="${CFLAGS}"
# adjust makefile to install pydoc into ${D} correctly