summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2009-01-16 08:42:13 +0000
committerKeri Harris <keri@gentoo.org>2009-01-16 08:42:13 +0000
commitf42019e9b29e632011bad99314a9457908e245fa (patch)
tree38c4f513158f43c2051e6672c9a9c0c548f7d26c /dev-lang/yap
parentremove never used, obsolete libvserver (diff)
downloadgentoo-2-f42019e9b29e632011bad99314a9457908e245fa.tar.gz
gentoo-2-f42019e9b29e632011bad99314a9457908e245fa.tar.bz2
gentoo-2-f42019e9b29e632011bad99314a9457908e245fa.zip
Revbump to install docs and support dynamic-loading
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r3 x86_64)
Diffstat (limited to 'dev-lang/yap')
-rw-r--r--dev-lang/yap/ChangeLog10
-rw-r--r--dev-lang/yap/files/yap-5.1.3-bootdir.patch59
-rw-r--r--dev-lang/yap/yap-5.1.3-r1.ebuild91
3 files changed, 158 insertions, 2 deletions
diff --git a/dev-lang/yap/ChangeLog b/dev-lang/yap/ChangeLog
index f06a1a6fe870..35b805123e2e 100644
--- a/dev-lang/yap/ChangeLog
+++ b/dev-lang/yap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/yap
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/ChangeLog,v 1.22 2008/07/27 05:11:50 keri Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/ChangeLog,v 1.23 2009/01/16 08:42:13 keri Exp $
+
+*yap-5.1.3-r1 (16 Jan 2009)
+
+ 16 Jan 2009; <keri@gentoo.org> +files/yap-5.1.3-bootdir.patch,
+ +yap-5.1.3-r1.ebuild:
+ Revbump to install docs and support dynamic-loading
*yap-5.1.3 (27 Jul 2008)
diff --git a/dev-lang/yap/files/yap-5.1.3-bootdir.patch b/dev-lang/yap/files/yap-5.1.3-bootdir.patch
new file mode 100644
index 000000000000..27c8c144803b
--- /dev/null
+++ b/dev-lang/yap/files/yap-5.1.3-bootdir.patch
@@ -0,0 +1,59 @@
+--- Yap-5.1.3.orig/console/yap.c 2008-06-05 01:58:37.000000000 +1200
++++ Yap-5.1.3/console/yap.c 2008-08-24 14:31:21.000000000 +1200
+@@ -82,6 +82,7 @@
+ static int output_msg;
+ #endif
+
++static char *YapBootDir = NULL;
+ static char BootFile[] = "boot.yap";
+ static char InitFile[] = "init.yap";
+
+@@ -595,11 +596,22 @@
+ BootMode = parse_yap_arguments(argc,argv,iap);
+
+ if (BootMode == YAP_FULL_BOOT_FROM_PROLOG) {
++ YapBootDir = getenv("YAPBOOTDIR");
++ if (YapBootDir) {
+ #if HAVE_STRNCAT
+- strncpy(boot_file, PL_SRC_DIR, 256);
++ strncpy(boot_file, YapBootDir, 256);
+ #else
+- strcpy(boot_file, PL_SRC_DIR);
++ strcpy(boot_file, YapBootDir);
+ #endif
++ strcat(boot_file, "/");
++ }
++ else {
++#if HAVE_STRNCAT
++ strncpy(boot_file, PL_SRC_DIR, 256);
++#else
++ strcpy(boot_file, PL_SRC_DIR);
++#endif
++ }
+ #if HAVE_STRNCAT
+ strncat(boot_file, BootFile, 256);
+ #else
+@@ -649,11 +661,21 @@
+ YAP_Functor fgoal;
+ YAP_Term goal, as[2];
+
++ if (YapBootDir) {
+ #if HAVE_STRNCAT
+- strncpy(init_file, PL_SRC_DIR, 256);
++ strncpy(init_file, YapBootDir, 256);
+ #else
+- strcpy(init_file, PL_SRC_DIR);
++ strcpy(init_file, YapBootDir);
+ #endif
++ strcat(init_file, "/");
++ }
++ else {
++#if HAVE_STRNCAT
++ strncpy(init_file, PL_SRC_DIR, 256);
++#else
++ strcpy(init_file, PL_SRC_DIR);
++#endif
++ }
+ #if HAVE_STRNCAT
+ strncat(init_file, InitFile, 256);
+ #else
diff --git a/dev-lang/yap/yap-5.1.3-r1.ebuild b/dev-lang/yap/yap-5.1.3-r1.ebuild
new file mode 100644
index 000000000000..4711c6970988
--- /dev/null
+++ b/dev-lang/yap/yap-5.1.3-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/yap-5.1.3-r1.ebuild,v 1.1 2009/01/16 08:42:13 keri Exp $
+
+inherit autotools eutils java-pkg-opt-2
+
+MY_P="Yap-${PV}"
+
+DESCRIPTION="YAP is a high-performance Prolog compiler."
+HOMEPAGE="http://www.ncc.up.pt/~vsc/Yap/"
+SRC_URI="http://www.ncc.up.pt/~vsc/Yap/current/Yap-5.1.3.tar.gz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc examples gmp java mpi mysql odbc readline static tk threads"
+
+DEPEND="gmp? ( dev-libs/gmp )
+ java? ( >=virtual/jdk-1.4 )
+ mpi? ( virtual/mpi )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ readline? ( sys-libs/readline )
+ doc? ( app-text/texi2html )"
+
+RDEPEND="${DEPEND}
+ tk? ( dev-lang/tk )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-config.h.patch
+ epatch "${FILESDIR}"/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-multilib.patch
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+ epatch "${FILESDIR}"/${P}-bootdir.patch
+ epatch "${FILESDIR}"/${P}-chr.patch
+ epatch "${FILESDIR}"/${P}-tkyap.patch
+
+ eautoconf
+}
+
+src_compile() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --enable-cut-c \
+ $(use_enable !static dynamic-loading) \
+ $(use_enable threads) \
+ $(use_enable threads pthread-locking) \
+ $(use_enable debug debug-yap) \
+ $(use_enable debug low-level-tracer) \
+ $(use_enable mysql myddas-mysql) \
+ $(use_enable mysql myddas-stats) \
+ $(use_enable mysql myddas-top-level) \
+ $(use_enable odbc myddas-odbc) \
+ $(use_with gmp) \
+ $(use_with readline) \
+ $(use_with mpi) \
+ $(use_with mpi mpe) \
+ $(use_with java jpl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+
+ if use doc ; then
+ emake html || die "emake html failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed."
+
+ if use tk ; then
+ exeinto /usr/bin
+ doexe misc/tkyap
+ fi
+
+ dodoc changes*.html README
+
+ if use doc ; then
+ dodoc yap.html
+ fi
+
+ if use examples ; then
+ docinto examples
+ dodoc CLPBN/clpbn/examples/cg.yap
+ dodoc CLPBN/clpbn/examples/School/*
+ fi
+}