summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2010-12-14 12:45:45 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2010-12-14 12:45:45 +0000
commit29bf174828c1de1471f208de6c939f16b06e8f6d (patch)
treecc768ad9bbf905b84304885562cbc5c616fd2c19 /dev-lang/pike
parentstable x86, security bug 348316 (diff)
downloadgentoo-2-29bf174828c1de1471f208de6c939f16b06e8f6d.tar.gz
gentoo-2-29bf174828c1de1471f208de6c939f16b06e8f6d.tar.bz2
gentoo-2-29bf174828c1de1471f208de6c939f16b06e8f6d.zip
Update to new version. Bug#337492
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/pike')
-rw-r--r--dev-lang/pike/ChangeLog7
-rw-r--r--dev-lang/pike/pike-7.8.352.ebuild115
2 files changed, 121 insertions, 1 deletions
diff --git a/dev-lang/pike/ChangeLog b/dev-lang/pike/ChangeLog
index 6ad58b061462..c6609132defa 100644
--- a/dev-lang/pike/ChangeLog
+++ b/dev-lang/pike/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/pike
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.36 2010/09/16 16:41:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.37 2010/12/14 12:45:45 araujo Exp $
+
+*pike-7.8.352 (14 Dec 2010)
+
+ 14 Dec 2010; Luis F. Araujo <araujo@gentoo.org> +pike-7.8.352.ebuild:
+ Updating to new version. Bug #337492
16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org>
pike-7.6.86-r1.ebuild, pike-7.6.112.ebuild, pike-7.6.112-r1.ebuild,
diff --git a/dev-lang/pike/pike-7.8.352.ebuild b/dev-lang/pike/pike-7.8.352.ebuild
new file mode 100644
index 000000000000..a0af8bcb7db1
--- /dev/null
+++ b/dev-lang/pike/pike-7.8.352.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.8.352.ebuild,v 1.1 2010/12/14 12:45:45 araujo Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="Pike programming language and runtime"
+HOMEPAGE="http://pike.ida.liu.se/"
+SRC_URI="http://pike.ida.liu.se/pub/pike/all/${PV}/Pike-v${PV}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 debug doc fftw gdbm glut gnome gtk hardened java jpeg kerberos mysql odbc opengl pcre pdf scanner sdl sqlite svg test tiff truetype zlib"
+
+DEPEND="<=dev-libs/nettle-2.0
+ dev-libs/gmp
+ media-libs/giflib
+ bzip2? ( app-arch/bzip2 )
+ fftw? ( sci-libs/fftw )
+ gdbm? ( sys-libs/gdbm )
+ gtk? ( =x11-libs/gtk+-1.2* >x11-libs/gtk+-2 )
+ gtk? ( gnome? ( gnome-base/libgnome gnome-base/libgnomeui gnome-base/gnome-applets gnome-base/libglade ) )
+ gtk? ( opengl? ( x11-libs/gtkglarea ) )
+ java? ( virtual/jdk virtual/libffi )
+ jpeg? ( media-libs/jpeg )
+ kerberos? ( virtual/krb5 net-libs/libgssglue )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/libiodbc )
+ opengl? ( virtual/opengl glut? ( media-libs/freeglut ) )
+ pcre? ( dev-libs/libpcre )
+ pdf? ( media-libs/pdflib )
+ !x86-fbsd? ( scanner? ( media-gfx/sane-backends ) )
+ sdl? ( media-libs/libsdl media-libs/sdl-mixer )
+ sqlite? ( dev-db/sqlite )
+ svg? ( gnome-base/librsvg )
+ test? ( sys-devel/m4 )
+ tiff? ( media-libs/tiff )
+ truetype? ( >media-libs/freetype-2 )
+ zlib? ( sys-libs/zlib )"
+RDEPEND=""
+
+S=${WORKDIR}/Pike-v${PV}
+
+src_compile() {
+ local myconf=""
+ # ffmpeg is broken atm #110136
+ myconf="${myconf} --without-_Ffmpeg"
+ # on hardened, disable runtime-generated code
+ # otherwise let configure work it out for itself
+ use hardened && myconf="${myconf} --without-machine-code"
+
+ make \
+ CONFIGUREARGS=" \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --disable-make_conf \
+ --disable-noopty-retry \
+ --without-cdebug \
+ --without-bundles \
+ --without-copt \
+ --without-ssleay \
+ --with-crypt \
+ --with-gif \
+ --with-gmp \
+ --with-bignums \
+ $(use_with bzip2 Bz2) \
+ $(use_with debug rtldebug) \
+ $(use_with fftw) \
+ $(use_with gdbm) \
+ $(use_with java Java) \
+ $(use_with jpeg jpeglib) \
+ $(use_with kerberos Kerberos) \
+ $(use_with kerberos gssapi) \
+ $(use_with mysql) \
+ $(use_with odbc Odbc) \
+ $(use_with opengl GL) \
+ $(use opengl && use_with glut GLUT) \
+ $(use opengl || use_with opengl GLUT) \
+ $(use_with pcre _Regexp_PCRE) \
+ $(use_with pdf libpdf) \
+ $(use_with scanner sane) \
+ $(use_with sdl SDL) \
+ $(use_with sdl SDL_mixer) \
+ $(use_with svg) \
+ $(use_with tiff tifflib) \
+ $(use_with truetype freetype) \
+ $(use_with zlib) \
+ ${myconf} \
+ " || die "compilation failed"
+
+ if use doc; then
+ PATH="${S}/bin:${PATH}" emake doc || die "doc failed"
+ fi
+}
+
+src_install() {
+ # do not remove modules to avoid sandbox violation.
+ # The sandbox really ought to allow deletion of files
+ # that belong to previous installs of the ebuild, or
+ # even better: hide them.
+ if use doc ; then
+ emake INSTALLARGS="--traditional" buildroot="${D}" install || die "emake failed"
+ einfo "Installing 60MB of docs, this could take some time ..."
+ dohtml -r "${S}"/refdoc/traditional_manual "${S}"/refdoc/modref
+ else
+ emake INSTALLARGS="--traditional" buildroot="${D}" install_nodoc || die "emake failed"
+ fi
+ # Installation is a bit broken.. remove the doc sources.
+ rm -rf "${D}/usr/doc"
+ # Install the man pages in the proper location.
+ rm -rf "${D}/usr/man" && doman "${S}/man/pike.1"
+}