summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-10-29 14:52:52 +0000
committerUlrich Müller <ulm@gentoo.org>2007-10-29 14:52:52 +0000
commit56df1750efa19adc9c4125feaf82145cf7d3804a (patch)
tree5dc93cb5ce4605bd9b3c15ee94298f52ccb5668b /dev-lang/ocaml
parentAdd local xemacs flag for dev-lang/ocaml. (diff)
downloadgentoo-2-56df1750efa19adc9c4125feaf82145cf7d3804a.tar.gz
gentoo-2-56df1750efa19adc9c4125feaf82145cf7d3804a.tar.bz2
gentoo-2-56df1750efa19adc9c4125feaf82145cf7d3804a.zip
Add app-emacs/ocaml-mode and app-xemacs/ocaml to PDEPEND, bug #43128.
(Portage version: 2.1.3.16)
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog8
-rw-r--r--dev-lang/ocaml/files/digest-ocaml-3.09.3-r23
-rw-r--r--dev-lang/ocaml/ocaml-3.09.3-r2.ebuild161
-rw-r--r--dev-lang/ocaml/ocaml-3.10.0.ebuild7
4 files changed, 176 insertions, 3 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 2ea3f3733767..04b48c4a9c84 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.123 2007/10/15 14:10:11 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.124 2007/10/29 14:52:52 ulm Exp $
+
+*ocaml-3.09.3-r2 (29 Oct 2007)
+
+ 29 Oct 2007; Ulrich Mueller <ulm@gentoo.org> +ocaml-3.09.3-r2.ebuild,
+ ocaml-3.10.0.ebuild:
+ Add app-emacs/ocaml-mode and app-xemacs/ocaml to PDEPEND, bug #43128.
15 Oct 2007; Markus Rothe <corsair@gentoo.org> ocaml-3.09.3-r1.ebuild:
Stable on ppc64
diff --git a/dev-lang/ocaml/files/digest-ocaml-3.09.3-r2 b/dev-lang/ocaml/files/digest-ocaml-3.09.3-r2
new file mode 100644
index 000000000000..231a74a7d1d6
--- /dev/null
+++ b/dev-lang/ocaml/files/digest-ocaml-3.09.3-r2
@@ -0,0 +1,3 @@
+MD5 8b3744efd0d51b82d55b61d0e2bf0e2b ocaml-3.09.3.tar.bz2 2038617
+RMD160 fdc124218c556c62c897ee6720970279e2d5426b ocaml-3.09.3.tar.bz2 2038617
+SHA256 607842b4f4917a759f19541a421370a834f5b948855ca54cef40d22b19a0934f ocaml-3.09.3.tar.bz2 2038617
diff --git a/dev-lang/ocaml/ocaml-3.09.3-r2.ebuild b/dev-lang/ocaml/ocaml-3.09.3-r2.ebuild
new file mode 100644
index 000000000000..21212c9c4306
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.09.3-r2.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.3-r2.ebuild,v 1.1 2007/10/29 14:52:52 ulm Exp $
+
+inherit flag-o-matic eutils multilib pax-utils versionator toolchain-funcs
+
+DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
+HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/ocaml-$( get_version_component_range 1-2 )/${P}.tar.bz2"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs gdbm latex ncurses tk X xemacs"
+
+DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
+ ncurses? ( sys-libs/ncurses )
+ X? ( x11-libs/libX11 x11-proto/xproto )
+ gdbm? ( sys-libs/gdbm )"
+
+PDEPEND="emacs? ( app-emacs/ocaml-mode )
+ xemacs? ( app-xemacs/ocaml )"
+
+# ocaml deletes the *.opt files when running make bootstrap
+
+QA_EXECSTACK="/usr/lib/ocaml/compiler-*"
+
+pkg_setup() {
+ # dev-lang/ocaml fails with -fPIC errors due to a "relocation R_X86_64_32S" on AMD64/hardened
+ if use amd64 && gcc-specs-pie ; then
+ echo
+ eerror "${CATEGORY}/${PF} is currently broken on this platform with specfiles injecting -PIE."
+ eerror "Please switch to your \"${CHOST}-$(gcc-fullversion)-hardenednopie\" specfile via gcc-config!"
+ die "Current specfile (${CHOST}-$(gcc-fullversion)) not supported by ${PF}!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix the EXEC_STACK in ocaml compiled binaries (#153382)
+ epatch "${FILESDIR}"/${P}-exec-stack-fixes.patch
+
+ # Quick and somewhat dirty fix for bug #110541
+ epatch "${FILESDIR}"/${P}-execheap.patch
+
+ # The configure script doesn't inherit previous defined variables,
+ # overwriting previous declarations of bytecccompopts, bytecclinkopts,
+ # nativecccompopts and nativecclinkopts. Reported upstream as issue 0004267.
+ epatch "${FILESDIR}"/${P}-configure.patch
+
+ # The sed in the Makefile doesn't replace all occurences of @compiler@
+ # in driver/ocamlcomp.sh.in. Reported upstream as issue 0004268.
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+
+ # ocaml has automagics on libX11 and gdbm
+ # http://caml.inria.fr/mantis/view.php?id=4278
+ epatch "${FILESDIR}/${P}-automagic.patch"
+
+ # Call ld with proper flags, different from gcc ones
+ # This happens when calling ocamlc -pack
+ # See comment in the patch
+ epatch "${FILESDIR}/${P}-call_ld_with_proper_flags.patch"
+
+ # Ocaml native code generation for hppa has a bug
+ # See comments in the patch
+ # http://bugs.gentoo.org/show_bug.cgi?id=178256
+ use hppa && epatch "${FILESDIR}/${P}-hppa-optimize-for-size-ocamlp4.patch"
+
+ # Change the configure script to add the CFLAGS to bytecccompopts, LDFLAGS
+ # to bytecclinkopts.
+ sed -i -e "s,bytecccompopts=\"\",bytecccompopts=\"\${CFLAGS}\"," \
+ -e "s,bytecclinkopts=\"\",bytecclinkopts=\"\${LDFLAGS}\"," \
+ "${S}"/configure
+}
+
+src_compile() {
+ local myconf="--host ${CHOST}"
+
+ # dev-lang/ocaml tends to break/give unexpected results with "unsafe" CFLAGS.
+ strip-flags
+ replace-flags "-O?" -O2
+
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ use tk || myconf="${myconf} -no-tk"
+ use ncurses || myconf="${myconf} -no-curses"
+ use X || myconf="${myconf} -no-graph"
+ use gdbm || myconf="${myconf} -no-dbm"
+
+ # ocaml uses a home-brewn configure script, preventing it to use econf.
+ ./configure -prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/$(get_libdir)/ocaml \
+ --mandir /usr/share/man \
+ --with-pthread ${myconf} || die "configure failed!"
+
+ make world || die "make world failed!"
+
+ # Native code generation is unsupported on some archs
+ if ! use ppc64 ; then
+ make opt || die "make opt failed!"
+ make opt.opt || die "make opt.opt failed!"
+ fi
+}
+
+src_install() {
+ make BINDIR="${D}"/usr/bin \
+ LIBDIR="${D}"/usr/$(get_libdir)/ocaml \
+ MANDIR="${D}"/usr/share/man \
+ install || die "make install failed!"
+
+ # Install the compiler libs
+ dodir /usr/$(get_libdir)/ocaml/compiler-libs
+ insinto /usr/$(get_libdir)/ocaml/compiler-libs
+ doins {utils,typing,parsing}/*.{mli,cmi,cmo,cmx,o}
+
+ # Symlink the headers to the right place
+ dodir /usr/include
+ dosym /usr/$(get_libdir)/ocaml/caml /usr/include/
+
+ # Remove ${D} from ld.conf, as the buildsystem isn't $(DESTDIR) aware
+ dosed "s:${D}::g" /usr/$(get_libdir)/ocaml/ld.conf
+
+ dodoc Changes INSTALL LICENSE README Upgrading
+
+ # Turn MPROTECT off for some of the ocaml binaries, since they are trying to
+ # rewrite the segment (which will obviously fail on systems having
+ # PAX_MPROTECT enabled).
+ pax-mark -m "${D}"/usr/bin/ocamldoc.opt "${D}"/usr/bin/ocamldep.opt \
+ "${D}"/usr/bin/ocamllex.opt "${D}"/usr/bin/camlp4r.opt \
+ "${D}"/usr/bin/camlp4o.opt
+
+ # Create and envd entry for latex input files (this definitely belongs into
+ # CONTENT and not in pkg_postinst.
+ if use latex ; then
+ echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > "${T}"/99ocamldoc
+ doenvd "${T}"/99ocamldoc
+ fi
+
+ # Install ocaml-rebuild.sh script rather than keeping it in $PORTDIR
+ dosbin "${FILESDIR}/ocaml-rebuild.sh"
+}
+
+pkg_postinst() {
+ if use amd64 && gcc-specs-ssp ; then
+ ewarn
+ ewarn "Make sure, you switch back to the default specfile ${CHOST}-$(gcc-fullversion) via gcc-config!"
+ ewarn
+ fi
+
+ echo
+ elog "OCaml is not binary compatible from version to version, so you (may)"
+ elog "need to rebuild all packages depending on it, that are actually"
+ elog "installed on your system. To do so, you can run:"
+ elog "/usr/sbin/ocaml-rebuild.sh [-h | emerge options]"
+ elog "Which will call emerge on all old packages with the given options"
+ echo
+}
diff --git a/dev-lang/ocaml/ocaml-3.10.0.ebuild b/dev-lang/ocaml/ocaml-3.10.0.ebuild
index 7a9600a0f4f3..1554c52f12f6 100644
--- a/dev-lang/ocaml/ocaml-3.10.0.ebuild
+++ b/dev-lang/ocaml/ocaml-3.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.0.ebuild,v 1.4 2007/06/26 01:51:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.0.ebuild,v 1.5 2007/10/29 14:52:52 ulm Exp $
inherit flag-o-matic eutils multilib pax-utils versionator toolchain-funcs
@@ -11,13 +11,16 @@ SRC_URI="http://caml.inria.fr/distrib/ocaml-$( get_version_component_range 1-2)/
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="gdbm ncurses tk latex X"
+IUSE="emacs gdbm latex ncurses tk X xemacs"
DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
ncurses? ( sys-libs/ncurses )
X? ( x11-libs/libX11 x11-proto/xproto )
gdbm? ( sys-libs/gdbm )"
+PDEPEND="emacs? ( app-emacs/ocaml-mode )
+ xemacs? ( app-xemacs/ocaml )"
+
QA_EXECSTACK="/usr/lib/ocaml/compiler-*"
pkg_setup() {