summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-12-20 09:01:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-12-20 09:01:39 +0000
commit1e250c513474fb3b39fcbc5a856e1e06932bf197 (patch)
tree072f2b3ecdb5615a63b98665efd97b72dedd1929 /dev-lang/nqp
parentBump (diff)
downloadgentoo-2-1e250c513474fb3b39fcbc5a856e1e06932bf197.tar.gz
gentoo-2-1e250c513474fb3b39fcbc5a856e1e06932bf197.tar.bz2
gentoo-2-1e250c513474fb3b39fcbc5a856e1e06932bf197.zip
Bump
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/nqp')
-rw-r--r--dev-lang/nqp/ChangeLog7
-rw-r--r--dev-lang/nqp/nqp-2014.12.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-lang/nqp/ChangeLog b/dev-lang/nqp/ChangeLog
index ff4bb388bbe0..37e57be9f02e 100644
--- a/dev-lang/nqp/ChangeLog
+++ b/dev-lang/nqp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/nqp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.56 2014/11/25 04:10:34 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.57 2014/12/20 09:01:39 patrick Exp $
+
+*nqp-2014.12 (20 Dec 2014)
+
+ 20 Dec 2014; Patrick Lauer <patrick@gentoo.org> +nqp-2014.12.ebuild:
+ Bump
*nqp-2014.11-r1 (25 Nov 2014)
diff --git a/dev-lang/nqp/nqp-2014.12.ebuild b/dev-lang/nqp/nqp-2014.12.ebuild
new file mode 100644
index 000000000000..680ee7b118f2
--- /dev/null
+++ b/dev-lang/nqp/nqp-2014.12.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2014.12.ebuild,v 1.1 2014/12/20 09:01:39 patrick Exp $
+
+EAPI=5
+
+# still not working
+RESTRICT="test"
+
+inherit eutils multilib
+
+GITCRAP=64e7d41
+PARROT_VERSION="6.7.0"
+
+DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
+HOMEPAGE="http://rakudo.org/"
+SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc +parrot java moar"
+REQUIRED_USE="|| ( parrot java moar )"
+
+RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
+ java? ( >=virtual/jre-1.7 )
+ moar? ( =dev-lang/moarvm-${PV} )"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.7 )
+ dev-lang/perl"
+
+S=${WORKDIR}/perl6-nqp-${GITCRAP}
+
+src_configure() {
+ use java && myconf+="jvm,"
+ use parrot && myconf+="parrot,"
+ use moar && myconf+="moar,"
+ perl Configure.pl --backend=${myconf} --prefix=/usr || die
+ # dirty hack to make dyncall not fail
+ sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
+ sed -i -e 's/-Werror=missing-declarations//' Makefile || die
+ sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
+
+ # more dirty hack to allow building with newer gcc
+ sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
+ sed -i -e 's/-Werror=nested-externs//' Makefile || die
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ dodoc CREDITS README.pod || die
+
+ if use doc; then
+ dodoc -r docs/* || die
+ fi
+}