summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-05-06 20:48:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-05-06 20:48:51 +0000
commitb3f98f48fe11e6f1d7279f51405701c9dede6bbc (patch)
tree27f59e127ed5e6ddf8ac12994165e56c8de7fd7d /dev-lang/nasm
parentVersion bump (diff)
downloadgentoo-2-b3f98f48fe11e6f1d7279f51405701c9dede6bbc.tar.gz
gentoo-2-b3f98f48fe11e6f1d7279f51405701c9dede6bbc.tar.bz2
gentoo-2-b3f98f48fe11e6f1d7279f51405701c9dede6bbc.zip
version bump; clean old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/nasm')
-rw-r--r--dev-lang/nasm/ChangeLog8
-rw-r--r--dev-lang/nasm/nasm-2.10.05.ebuild44
-rw-r--r--dev-lang/nasm/nasm-2.11.03.ebuild (renamed from dev-lang/nasm/nasm-2.11.02.ebuild)2
-rw-r--r--dev-lang/nasm/nasm-2.11.ebuild42
4 files changed, 8 insertions, 88 deletions
diff --git a/dev-lang/nasm/ChangeLog b/dev-lang/nasm/ChangeLog
index 86e377a581ea..740996951d43 100644
--- a/dev-lang/nasm/ChangeLog
+++ b/dev-lang/nasm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/nasm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.114 2014/04/14 21:10:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.115 2014/05/06 20:48:51 mr_bones_ Exp $
+
+*nasm-2.11.03 (06 May 2014)
+
+ 06 May 2014; Michael Sterrett <mr_bones_@gentoo.org> +nasm-2.11.03.ebuild,
+ -nasm-2.10.05.ebuild, -nasm-2.11.02.ebuild, -nasm-2.11.ebuild:
+ version bump; clean old
*nasm-2.11.02 (14 Apr 2014)
diff --git a/dev-lang/nasm/nasm-2.10.05.ebuild b/dev-lang/nasm/nasm-2.10.05.ebuild
deleted file mode 100644
index e991b7040e3d..000000000000
--- a/dev-lang/nasm/nasm-2.10.05.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.10.05.ebuild,v 1.5 2013/01/11 05:39:58 zerochaos Exp $
-
-EAPI=2
-inherit flag-o-matic
-
-DESCRIPTION="groovy little assembler"
-HOMEPAGE="http://nasm.sourceforge.net/"
-SRC_URI="http://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="-* amd64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc"
-
-DEPEND="dev-lang/perl
- doc? ( app-text/ghostscript-gpl sys-apps/texinfo )"
-RDEPEND=""
-
-S=${WORKDIR}/${P/_}
-
-src_configure() {
- strip-flags
- econf
-}
-
-src_compile() {
- emake nasmlib.o || die
- emake all || die
- if use doc ; then
- emake doc || die
- fi
-}
-
-src_install() {
- emake INSTALLROOT="${D}" install install_rdf || die
- dodoc AUTHORS CHANGES ChangeLog README TODO
- if use doc ; then
- doinfo doc/info/*
- dohtml doc/html/*
- dodoc doc/nasmdoc.*
- fi
-}
diff --git a/dev-lang/nasm/nasm-2.11.02.ebuild b/dev-lang/nasm/nasm-2.11.03.ebuild
index 82bd896e342a..2f49352b9728 100644
--- a/dev-lang/nasm/nasm-2.11.02.ebuild
+++ b/dev-lang/nasm/nasm-2.11.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.11.02.ebuild,v 1.1 2014/04/14 21:10:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.11.03.ebuild,v 1.1 2014/05/06 20:48:51 mr_bones_ Exp $
EAPI=5
inherit flag-o-matic
diff --git a/dev-lang/nasm/nasm-2.11.ebuild b/dev-lang/nasm/nasm-2.11.ebuild
deleted file mode 100644
index 57408e5c0b84..000000000000
--- a/dev-lang/nasm/nasm-2.11.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.11.ebuild,v 1.2 2014/01/30 21:47:58 vapier Exp $
-
-EAPI=5
-inherit flag-o-matic
-
-DESCRIPTION="groovy little assembler"
-HOMEPAGE="http://nasm.sourceforge.net/"
-SRC_URI="http://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc"
-
-DEPEND="dev-lang/perl
- doc? ( app-text/ghostscript-gpl sys-apps/texinfo )"
-RDEPEND=""
-
-S=${WORKDIR}/${P/_}
-
-src_configure() {
- strip-flags
- econf
-}
-
-src_compile() {
- emake nasmlib.o
- emake all
- use doc && emake doc
-}
-
-src_install() {
- emake INSTALLROOT="${D}" install install_rdf
- dodoc AUTHORS CHANGES ChangeLog README TODO
- if use doc ; then
- doinfo doc/info/*
- dohtml doc/html/*
- dodoc doc/nasmdoc.*
- fi
-}