summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-27 01:39:47 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-27 01:39:47 +0000
commit616627d8af7872ca6995c6166d43ebb470d6cffe (patch)
tree132fa247dbb4c67db6cd032a376286754210c431 /dev-lang/mono/mono-1.2.2.1.ebuild
parentmono.eclass: now exporting LC_ALL=C, added some descriptions (diff)
downloadgentoo-2-616627d8af7872ca6995c6166d43ebb470d6cffe.tar.gz
gentoo-2-616627d8af7872ca6995c6166d43ebb470d6cffe.tar.bz2
gentoo-2-616627d8af7872ca6995c6166d43ebb470d6cffe.zip
dev-lang/mono: LC_ALL=C is now being set in mono.eclass
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lang/mono/mono-1.2.2.1.ebuild')
-rw-r--r--dev-lang/mono/mono-1.2.2.1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-lang/mono/mono-1.2.2.1.ebuild b/dev-lang/mono/mono-1.2.2.1.ebuild
index e458dcc0a5c0..affe8e1d9586 100644
--- a/dev-lang/mono/mono-1.2.2.1.ebuild
+++ b/dev-lang/mono/mono-1.2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.2.1.ebuild,v 1.8 2007/06/26 22:48:49 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.2.1.ebuild,v 1.9 2007/06/27 01:39:47 jurek Exp $
inherit eutils flag-o-matic multilib autotools
@@ -85,11 +85,9 @@ src_compile() {
# Force the use of monolite mcs to prevent issues with classlibs (bug #118062)
touch ${S}/mcs/build/deps/use-monolite
- econf ${myconf} || die "configure failed"
- # Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
- # I18N.dll (bug #146424)
- LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false
+ econf ${myconf} || die "configure failed"
+ emake EXTERNAL_MCS=false EXTERNAL_MONO=false
if [[ "$?" -ne "0" ]]; then
ewarn "If you are using any hardening features such as"