summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-10-15 21:53:18 +0000
committerPeter Johanson <latexer@gentoo.org>2005-10-15 21:53:18 +0000
commitdaef076c77c3a043d1d0ccd639f72b457a5e5b65 (patch)
treed4f58721483892a06501834fc3ac3bd1b84d4e2b /dev-lang/mono/mono-1.1.9.2.ebuild
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-daef076c77c3a043d1d0ccd639f72b457a5e5b65.tar.gz
gentoo-2-daef076c77c3a043d1d0ccd639f72b457a5e5b65.tar.bz2
gentoo-2-daef076c77c3a043d1d0ccd639f72b457a5e5b65.zip
Bumpity bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-lang/mono/mono-1.1.9.2.ebuild')
-rw-r--r--dev-lang/mono/mono-1.1.9.2.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/dev-lang/mono/mono-1.1.9.2.ebuild b/dev-lang/mono/mono-1.1.9.2.ebuild
new file mode 100644
index 000000000000..7d03f301df7b
--- /dev/null
+++ b/dev-lang/mono/mono-1.1.9.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.9.2.ebuild,v 1.1 2005/10/15 21:53:18 latexer Exp $
+
+inherit eutils mono flag-o-matic
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/sources/mono-${PV:0:3}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11)"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="nptl X"
+
+DEPEND="virtual/libc
+ >=dev-libs/glib-2.0
+ sys-devel/bc
+ !<dev-dotnet/pnet-0.6.12
+ nptl? ( >=sys-devel/gcc-3.3.5-r1 )
+ ppc? (
+ >=sys-devel/gcc-3.2.3-r4
+ >=sys-libs/glibc-2.3.3_pre20040420
+ )"
+
+RDEPEND="${DEPEND}
+ X? ( >=dev-dotnet/libgdiplus-1.1.9.2 )
+ dev-util/pkgconfig
+ dev-libs/libxml2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix munging of Unix paths
+ epatch ${FILESDIR}/${PN}-1.1.5-pathfix.diff
+
+ # Install all our .dlls under $(libdir), not $(prefix)/lib
+ sed -i -e 's:$(prefix)/lib:$(libdir):' \
+ -e 's:$(exec_prefix)/lib:$(libdir):' \
+ -e "s:'mono_libdir=\${exec_prefix}/lib':\"mono_libdir=\$libdir\":" \
+ ${S}/{scripts,mono/metadata}/Makefile.am ${S}/configure.in || die
+
+ libtoolize --copy --force || die "libtoolize failed"
+ aclocal || die "aclocal failed"
+ autoconf || die "autoconf failed"
+ automake || die "automake failed"
+}
+
+src_compile() {
+ strip-flags
+ # Replace O2 flag on amd64. See bug #96719
+ if use amd64
+ then
+ replace-flags -O2 -O1
+ fi
+
+ local myconf="--with-preview=yes"
+
+ # Force __thread on amd64. See bug #83770
+ if use amd64
+ then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ if use nptl
+ then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ myconf="${myconf} --with-tls=pthread"
+ fi
+ fi
+
+ econf ${myconf} || die
+ emake -j1 || die "MONO compilation failure"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # Fix incorrect path to makecert EXE file
+ #sed -i "s:makecert.exe:MakeCert.exe:" ${D}/usr/bin/makecert || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+ docinto docs
+ dodoc docs/*
+ docinto libgc
+ dodoc libgc/ChangeLog
+}