summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-04 15:21:19 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-10-04 15:21:19 +0000
commitcb9b33a056ca568d5d1802945e5143fac259f4bf (patch)
treef14c2a89e16361befbf6eb96fa999da0e5869f18 /dev-lang/icon
parentAdd doc USE-flag wrt bug #437174, thanks to Nikoli (diff)
downloadgentoo-2-cb9b33a056ca568d5d1802945e5143fac259f4bf.tar.gz
gentoo-2-cb9b33a056ca568d5d1802945e5143fac259f4bf.tar.bz2
gentoo-2-cb9b33a056ca568d5d1802945e5143fac259f4bf.zip
added prefix support (bug #433832)
(Portage version: 2.2.0_alpha135/cvs/Linux i686)
Diffstat (limited to 'dev-lang/icon')
-rw-r--r--dev-lang/icon/ChangeLog7
-rw-r--r--dev-lang/icon/icon-9.5.0.ebuild36
2 files changed, 27 insertions, 16 deletions
diff --git a/dev-lang/icon/ChangeLog b/dev-lang/icon/ChangeLog
index c0fead3bef51..214e64322437 100644
--- a/dev-lang/icon/ChangeLog
+++ b/dev-lang/icon/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/icon
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/ChangeLog,v 1.46 2010/09/19 17:42:20 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/ChangeLog,v 1.47 2012/10/04 15:21:19 ottxor Exp $
+
+ 04 Oct 2012; Christoph Junghans <ottxor@gentoo.org> icon-9.5.0.ebuild:
+ added prefix support (bug #433832)
19 Sep 2010; Raúl Porcel <armin76@gentoo.org> icon-9.5.0.ebuild:
Add ~s390 wrt #316195
diff --git a/dev-lang/icon/icon-9.5.0.ebuild b/dev-lang/icon/icon-9.5.0.ebuild
index cb1605e990e0..5451f41bb157 100644
--- a/dev-lang/icon/icon-9.5.0.ebuild
+++ b/dev-lang/icon/icon-9.5.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/icon-9.5.0.ebuild,v 1.2 2010/09/19 17:42:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/icon-9.5.0.ebuild,v 1.3 2012/10/04 15:21:19 ottxor Exp $
+
+EAPI=4
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -11,7 +13,7 @@ DESCRIPTION="very high level language"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="X iplsrc"
S="${WORKDIR}/icon-v${MY_PV}src"
@@ -21,19 +23,16 @@ DEPEND="X? ( x11-proto/xextproto
x11-libs/libX11
x11-libs/libXpm
x11-libs/libXt )
- sys-devel/gcc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+ || ( sys-devel/gcc sys-devel/gcc-apple )"
+src_prepare() {
epatch "${FILESDIR}"/${P}-flags.patch
# do not prestrip files
find "${S}"/src -name 'Makefile' | xargs sed -i -e "/strip/d" || die
}
-src_compile() {
+src_configure() {
# select the right compile target. Note there are many platforms
# available
local mytarget;
@@ -49,9 +48,18 @@ src_compile() {
emake Configure name=${mytarget} -j1 || die
fi
+ # sanitise the Makedefs file generated by Configure
+ sed -i \
+ -e 's:-L/usr/X11R6/lib64::g' \
+ -e 's:-L/usr/X11R6/lib::g' \
+ -e 's:-I/usr/X11R6/include::g' \
+ Makedefs || die "sed of Makedefs failed"
+
append-flags $(test-flags -fno-strict-aliasing -fwrapv)
+}
- emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "Make Failed"
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_test() {
@@ -73,14 +81,14 @@ src_install() {
cd "${S}/man/man1"
doman icont.1
doman icon.1
- rm -rf "${D}"/usr/$(get_libdir)/icon/man
+ rm -rf "${ED}"/usr/$(get_libdir)/icon/man
cd "${S}/doc"
dodoc *.txt *.sed ../README
# dohtml ignores all anything except .html files, no use here
- mkdir -p "${D}"/usr/share/doc/${PF}/html
- cp -dpR *.htm *.gif *.jpg *.css "${D}"/usr/share/doc/${PF}/html
- rm -rf "${D}"/usr/$(get_libdir)/icon/{doc,README}
+ mkdir -p "${ED}"/usr/share/doc/${PF}/html
+ cp -dpR *.htm *.gif *.jpg *.css "${ED}"/usr/share/doc/${PF}/html
+ rm -rf "${ED}"/usr/$(get_libdir)/icon/{doc,README}
# optional Icon Programming Library
if use iplsrc; then