summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam McArthur <sandymac@gentoo.org>2002-04-24 06:02:31 +0000
committerWilliam McArthur <sandymac@gentoo.org>2002-04-24 06:02:31 +0000
commitd43901d7849b06b3ae35f52cff662413aaf40366 (patch)
treecd73d3280d1eee061b3db245f07f4b97b3e81061 /dev-lang/icc
parentremoved old, crusty ebuilds (diff)
downloadgentoo-2-d43901d7849b06b3ae35f52cff662413aaf40366.tar.gz
gentoo-2-d43901d7849b06b3ae35f52cff662413aaf40366.tar.bz2
gentoo-2-d43901d7849b06b3ae35f52cff662413aaf40366.zip
ICC 6.0 is now available from Intel's website. Just adding the new package.
Anyone that has compiled apps will need to recompile them again, see the end of the ebuild for details.
Diffstat (limited to 'dev-lang/icc')
-rw-r--r--dev-lang/icc/ChangeLog11
-rw-r--r--dev-lang/icc/files/6.0/05icc6
-rw-r--r--dev-lang/icc/files/digest-icc-6.01
-rw-r--r--dev-lang/icc/icc-6.0.ebuild90
4 files changed, 106 insertions, 2 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
index 2b01b2665626..84eec7fd9617 100644
--- a/dev-lang/icc/ChangeLog
+++ b/dev-lang/icc/ChangeLog
@@ -1,10 +1,17 @@
# ChangeLog for dev-lang/icc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.1 2002/04/13 20:23:46 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.2 2002/04/24 06:02:29 sandymac Exp $
+
+*icc-6.0 (24 Apr 2002)
+
+ 24 Apr 2002 William McArthur <sandymac@gentoo.org> icc-6.0.ebuild :
+
+ The icc-6.0.ebuild is functionally identical to the icc-5.0.1.ebuild . A few
+ tweaks were made for the minor differeces in Intel's package.
*icc-5.0.1 (12 Apr 2002)
- 12 Apr 2002; William McArthur <Leknor@Leknor.com> ChangeLog :
+ 12 Apr 2002; William McArthur <sandymac@gentoo.org> ChangeLog :
Initial Gentoo package. The install from Intel is RPM based so I extract
the i386 RPMs manually using rpm2cpio and cpio. (Idea taken from the
diff --git a/dev-lang/icc/files/6.0/05icc b/dev-lang/icc/files/6.0/05icc
new file mode 100644
index 000000000000..f5f50b9cc29f
--- /dev/null
+++ b/dev-lang/icc/files/6.0/05icc
@@ -0,0 +1,6 @@
+IA32ROOT=/opt/intel/compiler60/ia32
+INTEL_FLEXLM_LICENSE=/opt/intel/licenses
+LDPATH=/opt/intel/compiler60/ia32/lib
+MANPATH=/opt/intel/compiler60/man
+PATH=/opt/intel/compiler60/ia32/bin
+ROOTPATH=/opt/intel/compiler60/ia32/bin
diff --git a/dev-lang/icc/files/digest-icc-6.0 b/dev-lang/icc/files/digest-icc-6.0
new file mode 100644
index 000000000000..6f88b8077df2
--- /dev/null
+++ b/dev-lang/icc/files/digest-icc-6.0
@@ -0,0 +1 @@
+MD5 a8143725154434763b32926f8aca2473 l_cc_p_6.0.139.tar 40775680
diff --git a/dev-lang/icc/icc-6.0.ebuild b/dev-lang/icc/icc-6.0.ebuild
new file mode 100644
index 000000000000..c92eb84b7406
--- /dev/null
+++ b/dev-lang/icc/icc-6.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: William McArthur <sandymac@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-6.0.ebuild,v 1.1 2002/04/24 06:02:31 sandymac Exp $
+
+S=${WORKDIR}
+
+DESCRIPTION="Intel C++ Compiler - The Pentium optimized compiler for Linux"
+
+#RESTRICT="fetch"
+
+SRC_URI1="http://developer.intel.com/software/products/compilers/downloads/l_cc_p_6.0.139.tar"
+SRC_URI2="ftp://download.intel.com/software/products/compilers/downloads/l_cc_p_6.0.139.tar"
+SRC_URI3="ftp://download.intel.co.jp/software/products/compilers/downloads/l_cc_p_6.0.139.tar"
+SRC_URI="${SRC_URI1} ${SRC_URI2} ${SRC_URI3}"
+
+HOMEPAGE="http://www.intel.com/software/products/compilers/c60l/"
+
+DEPEND=">=sys-kernel/linux-sources-2.4
+ >=sys-libs/glibc-2.2.2
+ sys-apps/cpio
+ app-arch/rpm"
+
+RDEPEND=">=sys-kernel/linux-sources-2.4
+ >=sys-libs/glibc-2.2.2"
+
+src_compile() {
+ # Keep disk space to a minimum
+ rm -f intel-*.ia64.rpm
+
+ mkdir opt
+
+ for x in intel-*.i386.rpm
+ do
+ einfo "Extracting: ${x}"
+ rpm2cpio ${x} | cpio --extract --make-directories --unconditional
+ done
+
+ # From UNTAG_CFG_FILES in 'install'
+ SD=${S}/opt/intel # Build DESTINATION
+ RD=/opt/intel # Real DESTINATION
+ for FILE in $(find $SD/compiler60/ia??/bin/ -regex '.*[ei][cf]p?c$\|.*cfg$\|.*pcl$\|.*vars[^/]*.c?sh$' 2>/dev/null)
+ do
+ sed s@\<INSTALLDIR\>@$RD@g ${FILE} > ${FILE}.abs
+ mv -f ${FILE}.abs ${FILE}
+ chmod 755 ${FILE}
+ done
+
+ # From UNTAG_SUPPORT in 'install'
+ SUPPORTFILE=${SD}/compiler60/docs/csupport
+ eval `grep "^[ ]*COMBOPACKAGEID=" install`
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@$COMBOPACKAGEID@g $SUPPORTFILE > $SUPPORTFILE.abs
+ mv $SUPPORTFILE.abs $SUPPORTFILE
+ chmod 644 $SUPPORTFILE
+}
+
+src_install () {
+ dodoc lgpltext
+ dodoc clicense
+ cp -a opt ${D}
+
+ # icc enviroment
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/05icc
+}
+
+pkg_postinst () {
+ einfo
+ einfo "http://www.intel.com/software/products/compilers/c60l/c60l_noncom_lic.htm"
+ einfo "From the above url you can get a free, non-time limited, non-commercial"
+ einfo "personal use license key that comes with no support. You will need to read"
+ einfo "and agree to the license and then fill in your info to have one emailed to"
+ einfo "you. Read the website for the details."
+ einfo
+ einfo "Documentation can be found in /opt/intel/compiler60/docs/ ."
+ einfo
+ einfo "You will need to place your license in /opt/intel/licenses/ ."
+ einfo
+ if [ -d /opt/intel/compiler50 ]
+ then
+ ewarn
+ ewarn "Packages compiled with icc-5 will need to be recompiled."
+ ewarn "Until you can do that the old packages will work if you edit /etc/ld.so.conf and"
+ ewarn "change the 'compiler60' to 'compiler50' and run 'ldconfig'. Note that this edit"
+ ewarn "won't persist and will require you to re-edit after each package you re-install."
+ ewarn
+ ewarn "I know it sucks, and I've complained to Intel with all the details."
+ ewarn
+ fi
+}