summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-05-13 21:09:04 +0000
committerPacho Ramos <pacho@gentoo.org>2015-05-13 21:09:04 +0000
commit0d63612810a0dc30090b24f9cbfdc9e064b6d9f0 (patch)
tree1b3bd77dac19101414f9eaead8917fb2cc407273 /dev-lang/gnat-gcc
parentAdd doc and lto USEs as they are used from eclass for this version (#515408) (diff)
downloadgentoo-2-0d63612810a0dc30090b24f9cbfdc9e064b6d9f0.tar.gz
gentoo-2-0d63612810a0dc30090b24f9cbfdc9e064b6d9f0.tar.bz2
gentoo-2-0d63612810a0dc30090b24f9cbfdc9e064b6d9f0.zip
Drop old
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-lang/gnat-gcc')
-rw-r--r--dev-lang/gnat-gcc/ChangeLog6
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild72
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.4.5.ebuild62
3 files changed, 5 insertions, 135 deletions
diff --git a/dev-lang/gnat-gcc/ChangeLog b/dev-lang/gnat-gcc/ChangeLog
index 665cac08ccd2..682d619b474c 100644
--- a/dev-lang/gnat-gcc/ChangeLog
+++ b/dev-lang/gnat-gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/gnat-gcc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.68 2015/05/13 21:08:11 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.69 2015/05/13 21:09:04 pacho Exp $
+
+ 13 May 2015; Pacho Ramos <pacho@gentoo.org> -gnat-gcc-4.4.3.ebuild,
+ -gnat-gcc-4.4.5.ebuild:
+ Drop old
13 May 2015; Pacho Ramos <pacho@gentoo.org> gnat-gcc-4.3.6.ebuild,
gnat-gcc-4.4.7.ebuild, gnat-gcc-4.5.4.ebuild, gnat-gcc-4.6.4.ebuild:
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild
deleted file mode 100644
index 5316a9efa8e9..000000000000
--- a/dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild,v 1.4 2014/08/05 11:42:10 armin76 Exp $
-
-# Need to let configure know where to find stddef.h
-#EXTRA_CONFGCC="${WORKDIR}/usr/lib/include/"
-
-inherit gnatbuild
-
-DESCRIPTION="GNAT Ada Compiler - gcc version"
-HOMEPAGE="http://gcc.gnu.org/"
-LICENSE="GMGPL"
-
-IUSE=""
-
-# using new bootstrap
-BOOT_SLOT="4.3"
-
-# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
-# so the URI's are static.
-SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
- ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
- amd64? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )
- sparc? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-sparc.tar.bz2 )
- x86? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-i686.tar.bz2 )"
-# ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
-
-KEYWORDS=" ~amd64 ~x86"
-
-# starting with 4.3.0 gnat needs these libs
-RDEPEND=">=dev-libs/mpfr-2.3.1
- >=dev-libs/gmp-4.2.2
- >=sys-libs/zlib-1.1.4
- >=sys-libs/ncurses-5.2-r2"
-
-DEPEND="${RDEPEND}
- >=sys-devel/bison-1.875
- >=sys-libs/glibc-2.8
- >=sys-devel/binutils-2.15.94"
-
-#QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
-# ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
-
-src_unpack() {
- gnatbuild_src_unpack
-
- #fixup some hardwired flags
- cd "${S}"/gcc/ada
-
- # universal gcc -> gnatgcc substitution occasionally produces lines too long
- # and then build halts on the style check.
- #
- sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
- die "reversing [gnat]gcc substitution in comments failed"
-
- # gcc pretty much ignores --with-system-zlib. At least it still descends
- # into zlib and does configure and build there (gcc bug@7125?). For whatever
- # reason this conflicts with multilib in gcc-4.4..
- sed -i -e "s:libgui zlib:libgui:" "${S}"/configure
-
- # looks like wrapper has problems with all the quotation
- sed -i -e "/-DREVISION/d" -e "/-DDEVPHASE/d" \
- -e "s: -DDATESTAMP=\$(DATESTAMP_s)::" "${S}"/gcc/Makefile.in
- sed -i -e "s: DATESTAMP DEVPHASE REVISION::" \
- -e "s:PKGVERSION:\"\":" "${S}"/gcc/version.c
-}
-
-src_compile() {
- # looks like gnatlib_and_tools and gnatlib_shared have become part of
- # bootstrap
- gnatbuild_src_compile configure make-tools bootstrap
-}
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.4.5.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.4.5.ebuild
deleted file mode 100644
index 4b0b983f9330..000000000000
--- a/dev-lang/gnat-gcc/gnat-gcc-4.4.5.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.4.5.ebuild,v 1.6 2014/08/05 11:42:10 armin76 Exp $
-
-inherit gnatbuild
-
-DESCRIPTION="GNAT Ada Compiler - gcc version"
-HOMEPAGE="http://gcc.gnu.org/"
-LICENSE="GMGPL"
-
-IUSE=""
-
-BOOT_SLOT="4.3"
-
-# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
-# so the URI's are static.
-SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
- ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
- amd64? ( http://dev.gentoo.org/~george/src/gnatboot-${SLOT}-amd64.tar.bz2 )
- sparc? ( http://dev.gentoo.org/~george/src/gnatboot-${SLOT}-sparc.tar.bz2 )
- x86? ( http://dev.gentoo.org/~george/src/gnatboot-${SLOT}-i686.tar.bz2 )"
-# ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
-
-KEYWORDS="~amd64 ~x86"
-
-# starting with 4.3.0 gnat needs these libs
-RDEPEND=">=dev-libs/mpfr-3.0.1
- >=dev-libs/gmp-5.0
- >=sys-libs/zlib-1.2
- >=sys-libs/ncurses-5.7"
-
-DEPEND="${RDEPEND}
- >=sys-devel/bison-1.875
- >=sys-libs/glibc-2.8
- >=sys-devel/binutils-2.20"
-
-#QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
-# ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
-
-src_unpack() {
- gnatbuild_src_unpack
-
- #fixup some hardwired flags
- cd "${S}"/gcc/ada
-
- # universal gcc -> gnatgcc substitution occasionally produces lines too long
- # and then build halts on the style check.
- #
- sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
- die "reversing [gnat]gcc substitution in comments failed"
-
- # gcc pretty much ignores --with-system-zlib. At least it still descends
- # into zlib and does configure and build there (gcc bug@7125?). For whatever
- # reason this conflicts with multilib in gcc-4.4..
- sed -i -e "s:libgui zlib:libgui:" "${S}"/configure
-}
-
-src_compile() {
- # looks like gnatlib_and_tools and gnatlib_shared have become part of
- # bootstrap
- gnatbuild_src_compile configure make-tools bootstrap
-}