summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Pukhlikov <cynede@gentoo.org>2014-01-01 13:45:36 +0000
committerMikhail Pukhlikov <cynede@gentoo.org>2014-01-01 13:45:36 +0000
commit1dcad6bcce91817ee05fb46180316499427a2091 (patch)
tree08a224a8e6e00a0201bb1c72a2b900a1a40da96d /dev-lang/fsharp
parentRemove unused useflag description (diff)
downloadgentoo-2-1dcad6bcce91817ee05fb46180316499427a2091.tar.gz
gentoo-2-1dcad6bcce91817ee05fb46180316499427a2091.tar.bz2
gentoo-2-1dcad6bcce91817ee05fb46180316499427a2091.zip
F# bump to 3.1
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/fsharp')
-rw-r--r--dev-lang/fsharp/ChangeLog9
-rw-r--r--dev-lang/fsharp/fsharp-3.1.0.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-lang/fsharp/ChangeLog b/dev-lang/fsharp/ChangeLog
index 4e991ae88b91..2be388686d28 100644
--- a/dev-lang/fsharp/ChangeLog
+++ b/dev-lang/fsharp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/fsharp
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fsharp/ChangeLog,v 1.8 2013/11/14 06:46:00 cynede Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fsharp/ChangeLog,v 1.9 2014/01/01 13:45:36 cynede Exp $
+
+*fsharp-3.1.0 (01 Jan 2014)
+
+ 01 Jan 2014; Heather Cynede <cynede@gentoo.org> +fsharp-3.1.0.ebuild:
+ F# bump to 3.1
14 Nov 2013; Heather Cynede <cynede@gentoo.org> -fsharp-3.0.27.ebuild,
-fsharp-3.0.28.ebuild, -fsharp-3.0.29.ebuild:
diff --git a/dev-lang/fsharp/fsharp-3.1.0.ebuild b/dev-lang/fsharp/fsharp-3.1.0.ebuild
new file mode 100644
index 000000000000..09e4a1f9fb5f
--- /dev/null
+++ b/dev-lang/fsharp/fsharp-3.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fsharp/fsharp-3.1.0.ebuild,v 1.1 2014/01/01 13:45:36 cynede Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils mono-env
+
+DESCRIPTION="The F# Compiler"
+HOMEPAGE="https://github.com/fsharp/fsharp"
+SRC_URI="https://github.com/fsharp/fsharp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+MAKEOPTS+=" -j1" #nowarn
+DEPEND="dev-lang/mono"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_install() {
+ autotools-utils_src_install
+}