summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-05-29 10:05:25 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-05-29 10:05:25 +0000
commit96dc687a63b262716fc985177bfc2d91df7a8872 (patch)
tree9e112f5e12c654965d0a1f38f33a0b3222837617 /dev-lang/erlang
parentsparc stable wrt #223705, thanks to Friedrich Oslage for testing (diff)
downloadgentoo-2-96dc687a63b262716fc985177bfc2d91df7a8872.tar.gz
gentoo-2-96dc687a63b262716fc985177bfc2d91df7a8872.tar.bz2
gentoo-2-96dc687a63b262716fc985177bfc2d91df7a8872.zip
clean up
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/erlang')
-rw-r--r--dev-lang/erlang/ChangeLog10
-rw-r--r--dev-lang/erlang/erlang-11.2.5-r3.ebuild169
-rw-r--r--dev-lang/erlang/erlang-12.2.1.ebuild163
-rw-r--r--dev-lang/erlang/files/erlang-10.2.6-export-TARGET.patch11
-rw-r--r--dev-lang/erlang/files/erlang-11.2.5-build.patch13
-rw-r--r--dev-lang/erlang/files/erlang-11.2.5-gethostbyname.patch20
-rw-r--r--dev-lang/erlang/files/erlang-11.2.5-hipe.patch12
-rw-r--r--dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch17
8 files changed, 9 insertions, 406 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index c281b757aa2e..a80a040f2e82 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.119 2008/05/28 19:47:35 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.120 2008/05/29 10:05:24 opfer Exp $
+
+ 29 May 2008; Christian Faulhammer <opfer@gentoo.org>
+ -files/erlang-10.2.6-export-TARGET.patch,
+ -files/erlang-11.2.5-build.patch,
+ -files/erlang-11.2.5-gethostbyname.patch, -files/erlang-11.2.5-hipe.patch,
+ -files/erlang-11.2.5-odbc-support-amd64.patch, -erlang-11.2.5-r3.ebuild,
+ -erlang-12.2.1.ebuild:
+ clean up
28 May 2008; Peter Volkov <pva@gentoo.org> erlang-12.2.2.ebuild:
amd64 stable, bug #223707.
diff --git a/dev-lang/erlang/erlang-11.2.5-r3.ebuild b/dev-lang/erlang/erlang-11.2.5-r3.ebuild
deleted file mode 100644
index 11d9dff662d2..000000000000
--- a/dev-lang/erlang/erlang-11.2.5-r3.ebuild
+++ /dev/null
@@ -1,169 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.5-r3.ebuild,v 1.8 2008/01/25 07:17:49 opfer Exp $
-
-inherit elisp-common eutils flag-o-matic multilib versionator
-
-# NOTE: You need to adjust the version number in the last comment. If you need symlinks for
-# binaries please tell maintainers or open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
- http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="~alpha amd64 ppc ~ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc smp ssl tk"
-
-RDEPEND=">=dev-lang/perl-5.6.1
- ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50erlang-gentoo.el
-
-src_unpack() {
-
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-build.patch #184419
-
- # needed for amd64
- epatch "${FILESDIR}/${PN}-10.2.6-export-TARGET.patch"
-
- # needed for FreeBSD
- epatch "${FILESDIR}/${P}-gethostbyname.patch"
-
- # odbc is disabled in the amd64 code, but it works
- if use amd64 && use odbc; then
- epatch "${FILESDIR}/${P}-odbc-support-amd64.patch"
- fi
-
- # needed for building with hipe and recent coreutils
- use hipe && epatch "${FILESDIR}"/${P}-hipe.patch
-
- use odbc || sed -i 's: odbc : :' lib/Makefile
-
- # make sure we only link ssl dynamically
- sed -i '/SSL_DYNAMIC_ONLY=/s:no:yes:' erts/configure #184419
-
- if use hipe; then
- ewarn
- ewarn "You enabled High performance Erlang. Be aware that this extension"
- ewarn "can break the compilation in many ways, especially on hardened systems."
- ewarn "Don't cry, don't file bugs, just disable it!"
- ewarn
- fi
-}
-
-src_compile() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable hipe) \
- $(use_with ssl) \
- $(use_enable kpoll kernell-poll) \
- $(use_enable smp smp-support) \
- || die "econf failed"
- emake -j1 || die "emake failed"
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
- dodoc AUTHORS README
-
- dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
- dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
- dosym "${ERL_LIBDIR}/bin/ear" /usr/bin/ear
- dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
- dosym \
- "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
- /usr/bin/erl_call
- dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
-
- ## Remove ${D} from the following files
- dosed "${ERL_LIBDIR}/bin/erl"
- dosed "${ERL_LIBDIR}/bin/start"
- grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${D}/${ERL_LIBDIR}/Install"
-
- if use doc ; then
- for i in "${WORKDIR}"/man/man* ; do
- dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # Man page processing tools expect a capitalized "SEE ALSO" section
- # header, has been reported upstream, should be fixed in R12
- sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${file}
- # doman sucks so we can't use it
- cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
- done
- # extend MANPATH, so the normal man command can find it
- # see bug 189639
- dodir /etc/env.d/
- echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- popd
- fi
-
- # prepare erl for SMP, fixes bug #188112
- use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
- "${D}/${ERL_LIBDIR}/bin/erl"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- elog
- elog "If you need a symlink to one of erlang's binaries,"
- elog "please open a bug and tell the maintainers."
- elog
- elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R11B-5"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/erlang-12.2.1.ebuild b/dev-lang/erlang/erlang-12.2.1.ebuild
deleted file mode 100644
index 5c7d5e19aa0e..000000000000
--- a/dev-lang/erlang/erlang-12.2.1.ebuild
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.1.ebuild,v 1.9 2008/04/01 18:16:44 opfer Exp $
-
-inherit elisp-common eutils flag-o-matic multilib versionator
-
-# NOTE: You need to adjust the version number in the last comment. If you need symlinks for
-# binaries please tell maintainers or open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
- http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc smp ssl tk"
-
-RDEPEND=">=dev-lang/perl-5.6.1
- ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50erlang-gentoo.el
-
-pkg_setup() {
- if use ssl; then
- if is-ldflag --as-needed || is-flag --as-needed; then
- eerror "Don't use --as-needed in your LDFLAGS or CFLAGS for SSL support, this will fail."
- die
- fi
- fi
-}
-
-src_unpack() {
-
- unpack ${A}
- cd "${S}"
-
- use odbc || sed -i 's: odbc : :' lib/Makefile
-
- # make sure we only link ssl dynamically
- # will not be integrated by upstream for various reasons
- sed -i '/SSL_DYNAMIC_ONLY=/s:no:yes:' erts/configure #184419
-
- if use hipe; then
- ewarn
- ewarn "You enabled High performance Erlang. Be aware that this extension"
- ewarn "can break the compilation in many ways, especially on hardened systems."
- ewarn "Don't cry, don't file bugs, just disable it! If you have fix, tell us."
- ewarn
- fi
-}
-
-src_compile() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable hipe) \
- $(use_with ssl) \
- $(use_enable kpoll kernel-poll) \
- $(use_enable smp smp-support) \
- || die "econf failed"
- emake -j1 || die "emake failed"
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
- dodoc AUTHORS README
-
- dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
- dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
- dosym "${ERL_LIBDIR}/bin/ear" /usr/bin/ear
- dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
- dosym \
- "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
- /usr/bin/erl_call
- dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
-
- ## Remove ${D} from the following files
- dosed "${ERL_LIBDIR}/bin/erl"
- dosed "${ERL_LIBDIR}/bin/start"
- grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${D}/${ERL_LIBDIR}/Install"
-
- if use doc ; then
- for i in "${WORKDIR}"/man/man* ; do
- dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # Man page processing tools expect a capitalized "SEE ALSO" section
- # header, has been reported upstream, should be fixed in R12
- sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${file}
- # doman sucks so we can't use it
- cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
- done
- # extend MANPATH, so the normal man command can find it
- # see bug 189639
- dodir /etc/env.d/
- echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- popd
- fi
-
- # prepare erl for SMP, fixes bug #188112
- use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
- "${D}/${ERL_LIBDIR}/bin/erl"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- elog
- elog "If you need a symlink to one of Erlang's binaries,"
- elog "please open a bug on http://bugs.gentoo.org/"
- elog
- elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R12B-1"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/files/erlang-10.2.6-export-TARGET.patch b/dev-lang/erlang/files/erlang-10.2.6-export-TARGET.patch
deleted file mode 100644
index 13a68021e8be..000000000000
--- a/dev-lang/erlang/files/erlang-10.2.6-export-TARGET.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in
-+++ Makefile.in
-@@ -85,7 +85,7 @@
- MAKE = @MAKE_PROG@
-
- # This should be set to the target "arch-vendor-os"
--TARGET = @TARGET@
-+export TARGET = @TARGET@
-
- # A BSD compatible install program
- INSTALL = @INSTALL@
diff --git a/dev-lang/erlang/files/erlang-11.2.5-build.patch b/dev-lang/erlang/files/erlang-11.2.5-build.patch
deleted file mode 100644
index 3f68b32e78ba..000000000000
--- a/dev-lang/erlang/files/erlang-11.2.5-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-make sure errors actually get passed back up
-
---- make/otp_subdir.m
-+++ make/otp_subdir.mk
-@@ -44,7 +44,7 @@
- if test -f $$d/ignore_config_record.inf; then \
- xflag=$$tflag ; \
- fi ; \
-- (cd $$d && $(MAKE) $$xflag $@) ; \
-+ (cd $$d && $(MAKE) $$xflag $@) || exit $$? ; \
- fi ; \
- fi ; \
- done ; \
diff --git a/dev-lang/erlang/files/erlang-11.2.5-gethostbyname.patch b/dev-lang/erlang/files/erlang-11.2.5-gethostbyname.patch
deleted file mode 100644
index 8bef15046edc..000000000000
--- a/dev-lang/erlang/files/erlang-11.2.5-gethostbyname.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -Naur otp_src_R11B-4.orig/lib/erl_interface/src/connect/ei_resolve.c otp_src_R11B-4/lib/erl_interface/src/connect/ei_resolve.c
---- otp_src_R11B-4.orig/lib/erl_interface/src/connect/ei_resolve.c 2006-11-06 14:53:29 +0100
-+++ otp_src_R11B-4/lib/erl_interface/src/connect/ei_resolve.c 2007-06-13 23:14:06 +0200
-@@ -44,6 +44,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <errno.h>
-+#include <sys/param.h>
- #endif
-
- /* common to all platforms */
-@@ -614,7 +615,7 @@
- #ifndef HAVE_GETHOSTBYNAME_R
- return my_gethostbyname_r(name,hostp,buffer,buflen,h_errnop);
- #else
--#ifdef __GLIBC__
-+#if (defined(__GLIBC__) || (__FreeBSD_version >= 602000))
- struct hostent *result;
-
- gethostbyname_r(name, hostp, buffer, buflen, &result, h_errnop);
diff --git a/dev-lang/erlang/files/erlang-11.2.5-hipe.patch b/dev-lang/erlang/files/erlang-11.2.5-hipe.patch
deleted file mode 100644
index 08cbbfec8c71..000000000000
--- a/dev-lang/erlang/files/erlang-11.2.5-hipe.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Fix duplicate entry in makefile
-
---- otp_src_R11B-5.orig/lib/hipe/regalloc/Makefile 2007-09-12 12:45:03.000000000 -0600
-+++ otp_src_R11B-5/lib/hipe/regalloc/Makefile 2007-09-12 12:46:01.000000000 -0600
-@@ -43,7 +43,6 @@
- hipe_temp_map \
- hipe_optimistic_regalloc \
- hipe_coalescing_regalloc \
-- hipe_optimistic_regalloc \
- hipe_graph_coloring_regalloc \
- hipe_regalloc_loop \
- hipe_ls_regalloc \ \ No newline at end of file
diff --git a/dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch b/dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch
deleted file mode 100644
index 243448744401..000000000000
--- a/dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -urN otp_src_R11B-5/lib/odbc/c_src/Makefile.in otp_src_R11B-5.odbc/lib/odbc/c_src/Makefile.in
---- otp_src_R11B-5/lib/odbc/c_src/Makefile.in 2006-05-03 11:18:45.000000000 +0300
-+++ otp_src_R11B-5/lib/odbc/c_src/Makefile.in 2007-11-07 00:24:36.000000000 +0200
-@@ -57,11 +57,11 @@
- WIN32_TARGET = $(WIN_BIN_DIR)/odbcserver.exe
- EXE_TARGET = $(WIN32_TARGET)
- else
--ifneq ($(BITS64),yes)
-+#ifneq ($(BITS64),yes)
- EI_LIB = -lerl_interface -lei
- UNIX_TARGET = $(BIN_DIR)/odbcserver
- EXE_TARGET = $(UNIX_TARGET)
--endif
-+#endif
- endif
-
- C_FILES = odbcserver.c