summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-09-06 16:45:00 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-09-06 16:45:00 +0000
commit5e1b51552993fa37744af1193c477b04ab0120ac (patch)
tree7366cdadba96c15b64b2faee38fd40d28c14925f /dev-java
parentStable for amd64 wrt bug #518202 (diff)
downloadgentoo-2-5e1b51552993fa37744af1193c477b04ab0120ac.tar.gz
gentoo-2-5e1b51552993fa37744af1193c477b04ab0120ac.tar.bz2
gentoo-2-5e1b51552993fa37744af1193c477b04ab0120ac.zip
EAPI bump; make use of java-pkg-simple
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/higlayout/ChangeLog10
-rw-r--r--dev-java/higlayout/higlayout-1.0-r2.ebuild42
2 files changed, 49 insertions, 3 deletions
diff --git a/dev-java/higlayout/ChangeLog b/dev-java/higlayout/ChangeLog
index cddfe04144c6..62869267c389 100644
--- a/dev-java/higlayout/ChangeLog
+++ b/dev-java/higlayout/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/higlayout
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/higlayout/ChangeLog,v 1.5 2007/10/27 14:01:14 angelos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/higlayout/ChangeLog,v 1.6 2014/09/06 16:45:00 ercpe Exp $
+
+*higlayout-1.0-r2 (06 Sep 2014)
+
+ 06 Sep 2014; Johann Schmitz <ercpe@gentoo.org> +higlayout-1.0-r2.ebuild:
+ EAPI bump; make use of java-pkg-simple
27 Oct 2007; Christoph Mende <angelos@gentoo.org> higlayout-1.0-r1.ebuild:
Stable on amd64 wrt bug #190643
@@ -24,4 +29,3 @@
07 Jan 2007; Vlastimil Babka <caster@gentoo.org> +metadata.xml,
+higlayout-1.0.ebuild:
New package, as Heaven requested in bug #160773.
-
diff --git a/dev-java/higlayout/higlayout-1.0-r2.ebuild b/dev-java/higlayout/higlayout-1.0-r2.ebuild
new file mode 100644
index 000000000000..b48ae8b6c227
--- /dev/null
+++ b/dev-java/higlayout/higlayout-1.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/higlayout/higlayout-1.0-r2.ebuild,v 1.1 2014/09/06 16:45:00 ercpe Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java Swing layout manager that's powerful and easy to use"
+
+HOMEPAGE="http://www.autel.cz/dmi/tutorial.html"
+SRC_URI="http://www.autel.cz/dmi/HIGLayout${PV}.zip"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}"
+
+java_prepare() {
+ cd tutorial || die
+ for d in *.GIF;
+ do
+ mv $d $(basename $d .GIF).gif || die
+ done
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}