summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-06-25 15:50:22 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-06-25 15:50:22 +0000
commit59cdc77622af50a5382202ac3ba515cdee9e0e24 (patch)
treed51b1af22293c9390b111b0ee7463f72c7ba2591 /dev-java
parentRemove KDE Plasma 5.3.1 mask for wider testing. (diff)
downloadgentoo-2-59cdc77622af50a5382202ac3ba515cdee9e0e24.tar.gz
gentoo-2-59cdc77622af50a5382202ac3ba515cdee9e0e24.tar.bz2
gentoo-2-59cdc77622af50a5382202ac3ba515cdee9e0e24.zip
Package so-called deprecated files in jar. Fix bug 553234.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> (Portage version: 2.2.18/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 93491BB8)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/httpcomponents-core/ChangeLog8
-rw-r--r--dev-java/httpcomponents-core/httpcomponents-core-4.4.1-r1.ebuild84
2 files changed, 91 insertions, 1 deletions
diff --git a/dev-java/httpcomponents-core/ChangeLog b/dev-java/httpcomponents-core/ChangeLog
index b2a77dd0fa39..535d0483ac08 100644
--- a/dev-java/httpcomponents-core/ChangeLog
+++ b/dev-java/httpcomponents-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/httpcomponents-core
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/httpcomponents-core/ChangeLog,v 1.6 2015/06/23 15:25:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/httpcomponents-core/ChangeLog,v 1.7 2015/06/25 15:50:22 monsieurp Exp $
+
+*httpcomponents-core-4.4.1-r1 (25 Jun 2015)
+
+ 25 Jun 2015; Patrice Clement <monsieurp@gentoo.org>
+ +httpcomponents-core-4.4.1-r1.ebuild:
+ Package so-called deprecated files in jar. Fix bug 553234.
23 Jun 2015; Agostino Sarubbo <ago@gentoo.org>
httpcomponents-core-4.4.1.ebuild:
diff --git a/dev-java/httpcomponents-core/httpcomponents-core-4.4.1-r1.ebuild b/dev-java/httpcomponents-core/httpcomponents-core-4.4.1-r1.ebuild
new file mode 100644
index 000000000000..f0add5a96c2e
--- /dev/null
+++ b/dev-java/httpcomponents-core/httpcomponents-core-4.4.1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/httpcomponents-core/httpcomponents-core-4.4.1-r1.ebuild,v 1.1 2015/06/25 15:50:22 monsieurp Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source examples test"
+
+# "components"
+CMPT=${PN%%-*}
+
+# "core"
+CORE=${PN##*-}
+
+# "httpcore"
+HTTPCORE="http${CORE}"
+
+# "httpcore-nio"
+HTTPNIO="${HTTPCORE}-nio"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A low level toolset of Java components focused on HTTP and associated protocols"
+HOMEPAGE="http://hc.apache.org/index.html"
+SRC_URI="mirror://apache/httpcomponents/${HTTPCORE}/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="4.4"
+KEYWORDS="amd64 x86"
+
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/commons-logging:0
+ dev-java/ant-junit:0
+ dev-java/mockito:0
+ )"
+RDEPEND=">=virtual/jre-1.6"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_BUILD_TARGET="package"
+EANT_GENTOO_CLASSPATH_EXTRA="${S}/${HTTPCORE}/target/${HTTPCORE}-${PV}.jar"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-${HTTPCORE}-build.xml ${HTTPCORE}/build.xml
+ cp "${FILESDIR}"/${P}-${HTTPNIO}-build.xml ${HTTPNIO}/build.xml
+
+ # Why have these classes been deprecated although other libraries are built
+ # on them (i.e. httpcomponents-client) is mindboggling. See bug 553234.
+ cp -r "${S}"/httpcore/src/main/java-deprecated/* \
+ "${S}"/httpcore/src/main/java/* || die
+ cp -r "${S}"/httpcore-nio/src/main/java-deprecated/* \
+ "${S}"/httpcore-nio/src/main/java/* || die
+}
+
+src_compile() {
+ # first, compile httpcore module
+ EANT_BUILD_XML="${HTTPCORE}/build.xml" java-pkg-2_src_compile
+
+ # then, httpnio module
+ EANT_BUILD_XML="${HTTPNIO}/build.xml" java-pkg-2_src_compile
+}
+
+EANT_TEST_GENTOO_CLASSPATH="
+ commons-logging
+ mockito
+"
+
+src_test() {
+ # run junit tests for httpcore module
+ EANT_BUILD_XML="${HTTPCORE}/build.xml" java-pkg-2_src_test
+
+ # run junit tests for httpcore-nio module
+ EANT_BUILD_XML="${HTTPNIO}/build.xml" java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar ${HTTPCORE}/target/${HTTPCORE}-${PV}.jar ${HTTPCORE}.jar
+ java-pkg_newjar ${HTTPNIO}/target/${HTTPNIO}-${PV}.jar ${HTTPNIO}.jar
+
+ use source && java-pkg_dosrc httpcore{,-nio}/src/main/java
+ use examples && java-pkg_doexamples httpcore{,-nio}/src/examples
+
+ dodoc {README,RELEASE_NOTES,NOTICE}.txt
+}