summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-25 06:18:10 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-25 06:18:10 +0000
commit58f02a064dae8814212e559458124f7c82ae67e8 (patch)
treeaec53ebae7f3b7b298dc6d56745478f3a02a266e /dev-java
parentChange the SRC_URI to use the source file manually copied to the gentoo mirror. (diff)
downloadgentoo-2-58f02a064dae8814212e559458124f7c82ae67e8.tar.gz
gentoo-2-58f02a064dae8814212e559458124f7c82ae67e8.tar.bz2
gentoo-2-58f02a064dae8814212e559458124f7c82ae67e8.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/joda-time/ChangeLog10
-rw-r--r--dev-java/joda-time/files/joda-time-2.3-build.xml267
-rw-r--r--dev-java/joda-time/joda-time-2.3.ebuild55
3 files changed, 330 insertions, 2 deletions
diff --git a/dev-java/joda-time/ChangeLog b/dev-java/joda-time/ChangeLog
index 11c9dedb68a3..ccb9d8098a21 100644
--- a/dev-java/joda-time/ChangeLog
+++ b/dev-java/joda-time/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/joda-time
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/ChangeLog,v 1.46 2013/05/09 22:07:46 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/ChangeLog,v 1.47 2014/01/25 06:18:09 radhermit Exp $
+
+*joda-time-2.3 (25 Jan 2014)
+
+ 25 Jan 2014; Tim Harder <radhermit@gentoo.org> +joda-time-2.3.ebuild,
+ +files/joda-time-2.3-build.xml:
+ Version bump.
09 May 2013; Tim Harder <radhermit@gentoo.org> joda-time-2.2.ebuild:
Fix source and doc install.
diff --git a/dev-java/joda-time/files/joda-time-2.3-build.xml b/dev-java/joda-time/files/joda-time-2.3-build.xml
new file mode 100644
index 000000000000..5327843a0b9d
--- /dev/null
+++ b/dev-java/joda-time/files/joda-time-2.3-build.xml
@@ -0,0 +1,267 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 1/25/14 5:06 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="joda-time-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="joda-time-2.3"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="."/>
+ <property name="maven.build.resourceDir.1" value="src/main/java"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/joda/joda-convert/1.2/joda-convert-1.2.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/joda/joda-convert/1.2/joda-convert-1.2.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="true"
+ deprecation="false"
+ target="1.5"
+ verbose="true"
+ fork="true"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <include name="LICENSE.txt"/>
+ <include name="NOTICE.txt"/>
+ </fileset>
+ </copy>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="**/*.properties"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="true"
+ deprecation="false"
+ target="1.5"
+ verbose="true"
+ fork="true"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/TestAllPackages.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="UTF-8"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/1.5.0/docs/api/"/>
+ <group title="User packages"/>
+ <group title="Implementation packages"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="src/conf/MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/org/joda/joda-convert/1.2"/>
+ <get src="http://repo.maven.apache.org/maven2/org/joda/joda-convert/1.2/joda-convert-1.2.jar"
+ dest="${maven.repo.local}/org/joda/joda-convert/1.2/joda-convert-1.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/3.8.2"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/3.8.2/junit-3.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/joda-time/joda-time-2.3.ebuild b/dev-java/joda-time/joda-time-2.3.ebuild
new file mode 100644
index 000000000000..71c3c960ea3f
--- /dev/null
+++ b/dev-java/joda-time/joda-time-2.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/joda-time-2.3.ebuild,v 1.1 2014/01/25 06:18:09 radhermit Exp $
+
+EAPI="5"
+JAVA_PKG_IUSE="doc examples source test"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A quality open-source replacement for the Java Date and Time classes."
+HOMEPAGE="http://www.joda.org/joda-time/ https://github.com/JodaOrg/joda-time/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-dist.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+DEPEND=">=virtual/jdk-1.5
+ dev-java/joda-convert:0
+ test? (
+ dev-java/junit:0
+ dev-java/ant-junit:0
+ )"
+RDEPEND=">=virtual/jre-1.5"
+
+java_prepare() {
+ rm -v *.jar || die "Failed to remove bundled jars."
+ cp "${FILESDIR}"/${P}-build.xml "${S}"/build.xml || die "Failed to copy build file."
+
+ mkdir -p "${S}"/target/classes || die "Failed to create target classes directory."
+ cp -Rv "${S}"/src/tz-data/* "${S}"/target/classes/ || die "Failed to copy timezone data."
+}
+
+src_compile() {
+ EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjar --build-only joda-convert joda-convert.jar)"
+
+ java-pkg-2_src_compile
+}
+
+src_test() {
+ EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjar --build-only joda-convert joda-convert.jar):$(java-pkg_getjar --build-only junit junit.jar)"
+
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ dodoc NOTICE.txt RELEASE-NOTES.txt
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use examples && java-pkg_doexamples src/example
+ use source && java-pkg_dosrc src/main/java/*
+}