summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-05-10 09:11:42 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-05-10 09:11:42 +0000
commit4e827c6e0bfeb4ff6fa32eff4a7152e9ee645fd8 (patch)
treea0060bae37b9259b3521c7b980d21c4b75ed7aa1 /dev-java
parentRemove unused flag from metadata (diff)
downloadgentoo-2-4e827c6e0bfeb4ff6fa32eff4a7152e9ee645fd8.tar.gz
gentoo-2-4e827c6e0bfeb4ff6fa32eff4a7152e9ee645fd8.tar.bz2
gentoo-2-4e827c6e0bfeb4ff6fa32eff4a7152e9ee645fd8.zip
Version bump to 1.9.18. Fixes bug #426382, reported by Manuel Rüger (mrueg) and contributed by Ivan Baidakou (dmol).
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/nekohtml/ChangeLog13
-rw-r--r--dev-java/nekohtml/files/nekohtml-1.9.18-remove-obsolete-xerces-bridges.patch12
-rw-r--r--dev-java/nekohtml/nekohtml-1.9.18.ebuild59
3 files changed, 81 insertions, 3 deletions
diff --git a/dev-java/nekohtml/ChangeLog b/dev-java/nekohtml/ChangeLog
index 3fc5d51765db..be957097522f 100644
--- a/dev-java/nekohtml/ChangeLog
+++ b/dev-java/nekohtml/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/nekohtml
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/nekohtml/ChangeLog,v 1.12 2012/07/05 19:50:21 sera Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/nekohtml/ChangeLog,v 1.13 2013/05/10 09:11:41 tomwij Exp $
+
+*nekohtml-1.9.18 (10 May 2013)
+
+ 10 May 2013; Tom Wijsman <TomWij@gentoo.org>
+ +files/nekohtml-1.9.18-remove-obsolete-xerces-bridges.patch,
+ +nekohtml-1.9.18.ebuild:
+ Version bump to 1.9.18. Fixes bug #426382, reported by Manuel Rüger (mrueg)
+ and contributed by Ivan Baidakou (dmol).
05 Jul 2012; Ralph Sennhauser <sera@gentoo.org> nekohtml-1.9.6.ebuild:
Fix tests. Thanks to Ivan Baidakou <the.dmol@gmail.com> for the patch.
@@ -47,4 +55,3 @@
12 Oct 2006; Joshua Nichols <nichoj@gentoo.org>
+files/nekohtml-0.9.5-xerces.patch, +metadata.xml, +nekohtml-0.9.5.ebuild:
Initial commit, from bug #88617.
-
diff --git a/dev-java/nekohtml/files/nekohtml-1.9.18-remove-obsolete-xerces-bridges.patch b/dev-java/nekohtml/files/nekohtml-1.9.18-remove-obsolete-xerces-bridges.patch
new file mode 100644
index 000000000000..2f4a6c655cac
--- /dev/null
+++ b/dev-java/nekohtml/files/nekohtml-1.9.18-remove-obsolete-xerces-bridges.patch
@@ -0,0 +1,12 @@
+diff -Nru /tmp/nekohtml-1.9.16.orig/build.xml ./build.xml
+--- /tmp/nekohtml-1.9.16.orig/build.xml 2012-07-31 18:12:48.559950104 +0300
++++ ./build.xml 2012-07-31 18:12:53.887883123 +0300
+@@ -103,8 +103,6 @@
+ unless="compile.skip">
+ <mkdir dir="${build.classes.dir}"/>
+
+- <compileWith xercesVersion="2.0.2" bridge="2_0"/>
+- <compileWith xercesVersion="2.1.0" bridge="2_1"/>
+ <compileWith xercesVersion="2.2.1" bridge="2_2"/>
+ <compileWith xercesVersion="2.3.0" bridge="2_3"/>
+ <compileWith xercesVersion="2.8.1" bridge="2_3"/>
diff --git a/dev-java/nekohtml/nekohtml-1.9.18.ebuild b/dev-java/nekohtml/nekohtml-1.9.18.ebuild
new file mode 100644
index 000000000000..53b652d66eee
--- /dev/null
+++ b/dev-java/nekohtml/nekohtml-1.9.18.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/nekohtml/nekohtml-1.9.18.ebuild,v 1.1 2013/05/10 09:11:41 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="A simple HTML scanner and tag balancer using standard XML interfaces."
+
+HOMEPAGE="http://nekohtml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+COMMON_DEP=">=dev-java/xerces-2.7"
+DEPEND=">=virtual/jdk-1.4
+ test? (
+ dev-java/junit:0
+ dev-java/ant-junit:0
+ )
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+JAVA_ANT_CLASSPATH_TAGS="${JAVA_ANT_CLASSPATH_TAGS} taskdef"
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+EANT_GENTOO_CLASSPATH="xerces-2"
+EANT_TEST_GENTOO_CLASSPATH="ant-junit,junit,xerces-2"
+
+# Do not generate docs, use bundled.
+EANT_DOC_TARGET=""
+
+src_prepare() {
+ find . -iname '*.jar' -delete
+
+ epatch "${FILESDIR}"/${P}-remove-obsolete-xerces-bridges.patch
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar build/lib/${PN}.jar
+
+ if use doc; then
+ java-pkg_dojavadoc --symlink javadoc doc/javadoc
+ dohtml -r doc/*
+ fi
+
+ use source && java-pkg_dosrc src/org
+ use examples && java-pkg_doexamples src/sample
+}