summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2013-02-13 09:30:08 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2013-02-13 09:30:08 +0000
commit262b637a59d9e779234b904e44c1169321e99146 (patch)
treedb7e7d5640c992d1fe8732eb5df28cc4b3bcbfe4 /dev-java/tomcat-native
parentRemove old development versions (diff)
downloadgentoo-2-262b637a59d9e779234b904e44c1169321e99146.tar.gz
gentoo-2-262b637a59d9e779234b904e44c1169321e99146.tar.bz2
gentoo-2-262b637a59d9e779234b904e44c1169321e99146.zip
dev-java/tomcat-native: version bump
(Portage version: 2.1.11.51/cvs/Linux x86_64, signed Manifest commit with key CFE47E2F)
Diffstat (limited to 'dev-java/tomcat-native')
-rw-r--r--dev-java/tomcat-native/ChangeLog10
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.27.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index ef4b11aa6c32..13b9384f00e4 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.39 2012/08/04 10:27:22 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.40 2013/02/13 09:30:08 fordfrog Exp $
+
+*tomcat-native-1.1.27 (13 Feb 2013)
+
+ 13 Feb 2013; Miroslav Šulc <fordfrog@gentoo.org>
+ +tomcat-native-1.1.27.ebuild:
+ version bump
04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> tomcat-native-1.1.24.ebuild:
Stable for amd64, wrt bug #427332
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.27.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.27.ebuild
new file mode 100644
index 000000000000..fad4714ab7e4
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.27.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.27.ebuild,v 1.1 2013/02/13 09:30:08 fordfrog Exp $
+
+EAPI="2"
+
+inherit base eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src/jni/native
+
+src_configure(){
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+}
+
+src_compile() {
+ base_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}