summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-05-01 18:49:34 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-05-01 18:49:34 +0000
commitb319c51ba4b9089a4266124c6542ae0c4e8d703c (patch)
treed3f066100b3ed36b36be2d610fa4fe1415e51872 /dev-java/sjsxp/sjsxp-1.0.1.ebuild
parentInitial commit of codemodel. (diff)
downloadgentoo-2-b319c51ba4b9089a4266124c6542ae0c4e8d703c.tar.gz
gentoo-2-b319c51ba4b9089a4266124c6542ae0c4e8d703c.tar.bz2
gentoo-2-b319c51ba4b9089a4266124c6542ae0c4e8d703c.zip
Initial commit of sjsxp.
(Portage version: 2.1.2.5)
Diffstat (limited to 'dev-java/sjsxp/sjsxp-1.0.1.ebuild')
-rw-r--r--dev-java/sjsxp/sjsxp-1.0.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/sjsxp/sjsxp-1.0.1.ebuild b/dev-java/sjsxp/sjsxp-1.0.1.ebuild
new file mode 100644
index 000000000000..e9d684c07580
--- /dev/null
+++ b/dev-java/sjsxp/sjsxp-1.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sjsxp/sjsxp-1.0.1.ebuild,v 1.1 2007/05/01 18:49:34 nelchael Exp $
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The Sun Java Streaming XML Parser (SJSXP) is an efficient implementation of the StAX API."
+HOMEPAGE="http://sjsxp.dev.java.net/"
+# CVS: cvs -d :pserver:guest@cvs.dev.java.net:/cvs checkout -r sjsxp-1_0_1 sjsxp/zephyr
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="bea.ri.jsr173"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+COMMON_DEP="dev-java/jsr173"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/zephyr"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}/lib"
+ java-pkg_jar-from jsr173 jsr173.jar jsr173_1.0_api.jar
+}
+
+EANT_BUILD_TARGET="jar"
+EANT_DOC_TARGET="javadocs"
+
+src_install() {
+ java-pkg_dojar "build/${PN}.jar"
+
+ use doc && java-pkg_dojavadoc build/docs/javadocs
+ use source && java-pkg_dosrc src
+}