summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-07-20 21:46:23 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-07-20 21:46:23 +0000
commit083b34d84fd2326c565651281e07ee1566126f0e (patch)
tree964ddc0c56e932ab4a5f6191c162df3c7775b0fa /dev-java/junit
parentDrop unused version. (diff)
downloadgentoo-2-083b34d84fd2326c565651281e07ee1566126f0e.tar.gz
gentoo-2-083b34d84fd2326c565651281e07ee1566126f0e.tar.bz2
gentoo-2-083b34d84fd2326c565651281e07ee1566126f0e.zip
Rewrite using java-pkg-simple to avoid a generated build.xml file and
a cyclic dependency when testing. Fixes bug #554876. I notice that the previous 4.12 ebuild didn't apply the gentoo-manifest.mf file like earlier versions did. I doubt this is needed any more and it was broken in 4.11 anyway because it was pointing at the wrong hamcrest-core SLOT. I'll leave it out and see what happens. (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'dev-java/junit')
-rw-r--r--dev-java/junit/ChangeLog13
-rw-r--r--dev-java/junit/files/junit-4.12-build.xml260
-rw-r--r--dev-java/junit/junit-4.12-r1.ebuild53
-rw-r--r--dev-java/junit/junit-4.12.ebuild70
4 files changed, 65 insertions, 331 deletions
diff --git a/dev-java/junit/ChangeLog b/dev-java/junit/ChangeLog
index 7f477012e54b..cfe4715427aa 100644
--- a/dev-java/junit/ChangeLog
+++ b/dev-java/junit/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-java/junit
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.88 2015/07/12 12:19:16 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.89 2015/07/20 21:46:23 chewi Exp $
+
+*junit-4.12-r1 (20 Jul 2015)
+
+ 20 Jul 2015; James Le Cuirot <chewi@gentoo.org> +junit-4.12-r1.ebuild,
+ -files/junit-4.12-build.xml, -junit-4.12.ebuild:
+ Rewrite using java-pkg-simple to avoid a generated build.xml file and a cyclic
+ dependency when testing. Fixes bug #554876. I notice that the previous 4.12
+ ebuild didn't apply the gentoo-manifest.mf file like earlier versions did. I
+ doubt this is needed any more and it was broken in 4.11 anyway because it was
+ pointing at the wrong hamcrest-core SLOT. I'll leave it out and see what
+ happens.
12 Jul 2015; Patrice Clement <monsieurp@gentoo.org>
files/junit-4.12-build.xml, junit-4.12.ebuild:
diff --git a/dev-java/junit/files/junit-4.12-build.xml b/dev-java/junit/files/junit-4.12-build.xml
deleted file mode 100644
index a7d5f6a44571..000000000000
--- a/dev-java/junit/files/junit-4.12-build.xml
+++ /dev/null
@@ -1,260 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 7/10/15 10:33 AM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="junit-4.12" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="junit-4.12"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.resourceDir.1" value="."/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath">
- <pathelement location="lib/hamcrest-core.jar"/>
- </path>
- <path id="build.test.classpath">
- <pathelement location="lib/hamcrest-core.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- encoding="ISO-8859-1"
- nowarn="true"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="true"
- memoryInitialSize="128m"
- source="1.6">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}"/>
- </copy>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.1}">
- <include name="LICENSE-junit.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- encoding="ISO-8859-1"
- nowarn="true"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="true"
- memoryInitialSize="128m"
- source="1.6">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- <copy todir="${maven.build.testOutputDir}">
- <fileset dir="${maven.build.testResourceDir.0}"/>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- <exclude name="**/NotPublicTestCase.java"/>
- <exclude name="**/TestWatchmanTest.java"/>
- <exclude name="**/TestWatcherTest.java"/>
- <exclude name="**/SimpleTest.java"/>
- <exclude name="**/TestSystem.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.Missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="true"
- locale="en"
- encoding="UTF-8"
- version="false"
- use="false"
- author="false"
- splitindex="false"
- windowtitle="JUnit API"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- failonerror="false"
- stylesheetfile="/var/tmp/portage/dev-java/junit-4.12/work/junit-r4.12/src/main/javadoc/stylesheet.css"
- charset="ISO-8859-1"
- linksource="true"
- breakiterator="false"
- maxmemory="128m" />
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html">
- <manifest>
- <attribute name="Main-Class" value="Main"/>
- </manifest>
- </jar>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
-</project>
diff --git a/dev-java/junit/junit-4.12-r1.ebuild b/dev-java/junit/junit-4.12-r1.ebuild
new file mode 100644
index 000000000000..9a423ebd5edf
--- /dev/null
+++ b/dev-java/junit/junit-4.12-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-4.12-r1.ebuild,v 1.1 2015/07/20 21:46:23 chewi Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Simple framework to write repeatable tests"
+SRC_URI="https://github.com/${PN}-team/${PN}/archive/r${PV}.zip"
+HOMEPAGE="http://junit.org/"
+LICENSE="EPL-1.0"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+CDEPEND="dev-java/hamcrest-core:1.3"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${PN}-r${PV}"
+JAVA_SRC_DIR="src/main/java"
+JAVA_GENTOO_CLASSPATH="hamcrest-core-1.3"
+
+java_prepare() {
+ rm -v lib/*.jar || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ java-pkg_addres ${PN}.jar src/main/resources
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc {acknowledgements,{LEGACY_,}CODING_STYLE,NOTICE,to-do}.txt {CONTRIBUTING,README,doc/ReleaseNotes${PV}}.md
+ use examples && java-pkg_doexamples src/test/java/org/junit/samples
+}
+
+src_test() {
+ cd src/test/java || die
+
+ local CP=".:../resources:${S}/${PN}.jar:$(java-pkg_getjars ${JAVA_GENTOO_CLASSPATH})"
+
+ ejavac -cp "${CP}" -d . $(find * -name "*.java")
+ java -cp "${CP}" -Djava.awt.headless=true org.junit.runner.JUnitCore junit.tests.AllTests || die "Running junit failed"
+}
diff --git a/dev-java/junit/junit-4.12.ebuild b/dev-java/junit/junit-4.12.ebuild
deleted file mode 100644
index cbadbe9003ef..000000000000
--- a/dev-java/junit/junit-4.12.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-4.12.ebuild,v 1.2 2015/07/12 12:19:16 monsieurp Exp $
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc examples source test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Simple framework to write repeatable tests"
-SRC_URI="https://github.com/${PN}-team/${PN}/archive/r${PV}.zip"
-HOMEPAGE="http://www.junit.org/"
-
-LICENSE="CPL-1.0"
-SLOT="4"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-
-CDEPEND="dev-java/hamcrest-core:1.3"
-
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-
-DEPEND=">=virtual/jdk-1.6
- userland_GNU? ( >=sys-apps/findutils-4.3 )
- ${CDEPEND}"
-
-S="${WORKDIR}/${PN}-r${PV}"
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-EANT_BUILD_XML="build.xml"
-EANT_DOC_TARGET="javadoc"
-
-java_prepare() {
- cp "${FILESDIR}"/${P}-build.xml build.xml
-
- find . -type f \( -name \*.jar -o -name \*.class \) -print -delete
-
- java-pkg_jar-from --into lib hamcrest-core-1.3 hamcrest-core.jar
-}
-
-EANT_BUILD_TARGET="package"
-
-src_compile() {
- java-pkg-2_src_compile
-}
-
-EANT_TEST_TARGET="test"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar junit.jar
- dodoc doc/ReleaseNotes${PV}.md
-
- if use examples; then
- java-pkg_doexamples src/test/java/org/junit/samples
- fi
-
- if use source; then
- java-pkg_dosrc src/main/java/{org,junit}
- fi
-
- if use doc; then
- java-pkg_dojavadoc target/site/apidocs
- fi
-}