summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-06-15 23:20:39 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-06-15 23:20:39 +0000
commit0719c3a177a71d3c9695fe69850c26bd5d67630f (patch)
tree44159ecf7198f1e8f9a65750df9c374f138cdf1b /dev-java/junit
parentfix hppa build issue, bug#471914 (diff)
downloadgentoo-2-0719c3a177a71d3c9695fe69850c26bd5d67630f.tar.gz
gentoo-2-0719c3a177a71d3c9695fe69850c26bd5d67630f.tar.bz2
gentoo-2-0719c3a177a71d3c9695fe69850c26bd5d67630f.zip
Version bump to 4.11, needed for newer version of reverse dependency ant-junit.
(Portage version: 2.1.12.4/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/junit')
-rw-r--r--dev-java/junit/ChangeLog9
-rw-r--r--dev-java/junit/files/junit-4.11-do-not-unpack-hamcrest-sources.patch19
-rw-r--r--dev-java/junit/junit-4.11.ebuild103
3 files changed, 130 insertions, 1 deletions
diff --git a/dev-java/junit/ChangeLog b/dev-java/junit/ChangeLog
index f5f081a59db5..65c6b10b76d4 100644
--- a/dev-java/junit/ChangeLog
+++ b/dev-java/junit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/junit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.76 2013/06/14 19:51:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.77 2013/06/15 23:20:39 tomwij Exp $
+
+*junit-4.11 (15 Jun 2013)
+
+ 15 Jun 2013; Tom Wijsman <TomWij@gentoo.org>
+ +files/junit-4.11-do-not-unpack-hamcrest-sources.patch, +junit-4.11.ebuild:
+ Version bump to 4.11, needed for newer version of reverse dependency ant-
+ junit.
14 Jun 2013; Alexis Ballier <aballier@gentoo.org> junit-4.10.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-java/junit/files/junit-4.11-do-not-unpack-hamcrest-sources.patch b/dev-java/junit/files/junit-4.11-do-not-unpack-hamcrest-sources.patch
new file mode 100644
index 000000000000..d2d6f855323c
--- /dev/null
+++ b/dev-java/junit/files/junit-4.11-do-not-unpack-hamcrest-sources.patch
@@ -0,0 +1,19 @@
+--- a/build.xml 2012-11-14 20:23:00.000000000 +0100
++++ b/build.xml 2013-06-15 23:12:30.981988033 +0200
+@@ -138,7 +138,7 @@
+ </exec>
+ </target>
+
+- <target name="javadoc" depends="unjar.hamcrest">
++ <target name="javadoc">
+ <javadoc destdir="${javadocdir}"
+ author="false"
+ version="false"
+@@ -151,7 +151,6 @@
+ <excludepackage name="org.junit.experimental.theories.internal.*" />
+
+ <sourcepath location="${src}" />
+- <sourcepath location="${hamcrestsrc}" />
+ <link href="http://java.sun.com/javase/6/docs/api/" />
+ </javadoc>
+ </target>
diff --git a/dev-java/junit/junit-4.11.ebuild b/dev-java/junit/junit-4.11.ebuild
new file mode 100644
index 000000000000..e11f8733f32f
--- /dev/null
+++ b/dev-java/junit/junit-4.11.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-4.11.ebuild,v 1.1 2013/06/15 23:20:39 tomwij Exp $
+
+# WARNING: JUNIT.JAR IS _NOT_ SYMLINKED TO ANT-CORE LIB FOLDER AS JUNIT3 IS
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Simple framework to write repeatable tests"
+SRC_URI="mirror://github/${PN}-team/${PN}/${PN}${PV}.zip"
+HOMEPAGE="http://www.junit.org/"
+
+LICENSE="CPL-1.0"
+SLOT="4"
+
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux \
+ ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris \
+ ~x86-solaris"
+
+CDEPEND="dev-java/hamcrest-core:1.3"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.5
+ userland_GNU? ( >=sys-apps/findutils-4.3 )
+ ${CDEPEND}"
+
+S="${WORKDIR}/${PN}${PV}"
+
+EANT_BUILD_TARGET="jars samples-and-tests"
+
+src_unpack() {
+ default
+
+ # Unpack the source JAR.
+ mkdir -p "${S}/src/main/java" "${S}/src/test/java" \
+ || die "Unable to create source directories"
+
+ pushd "${S}/src/main/java" > /dev/null
+ jar xf "${S}/${P}-src.jar" || die "Unable to unpack sources."
+ popd >/dev/null
+
+ # Copy the Gentoo manifest to the working directory.
+ cp "${FILESDIR}/gentoo-manifest.mf" "${S}" || die
+}
+
+java_prepare() {
+ epatch "${FILESDIR}"/${P}-do-not-unpack-hamcrest-sources.patch
+
+ mkdir lib || die
+ java-pkg_jar-from --into lib hamcrest-core{-1.3,.jar,-1.3.jar}
+
+ # Fix javadoc compilation.
+ if use doc ; then
+ cp "${S}"/javadoc/stylesheet.css "${S}" \
+ || die "Unable to copy Javdoc stylesheet"
+ fi
+
+ # Remove binary and other generated files.
+ rm -rf javadoc temp.hamcrest.source *.jar \
+ || die "Unable to clean generated files."
+ find . -name "*.class" -delete \
+ || die "Unable to remove distributed class files"
+
+ # Let Ant know where its hamcrest went.
+ EANT_EXTRA_ARGS="-Dhamcrestlib=$(java-pkg_getjars hamcrest-core-1.3)"
+
+ # Add Gentoo manifest information to generated JAR files.
+ java-ant_xml-rewrite -f build.xml -c \
+ -e jar -a manifest -v "gentoo-manifest.mf"
+}
+
+src_test() {
+ mkdir classes || die "Unable to create build directory for tests."
+
+ local cp=$(java-pkg_getjars hamcrest-core-1.3):"${S}"/target/main
+
+ ejavac -classpath ${cp} \
+ -d classes $(find org/junit/internal -name "*.java")
+ ejavac -classpath ${cp}:"${S}/classes" \
+ -d classes $(find junit/tests org/junit/tests -name "*.java")
+
+ java -classpath ${cp}:classes \
+ org.junit.runner.JUnitCore junit.tests.AllTests || die "Tests failed."
+}
+
+src_install() {
+ java-pkg_newjar ${PN}${PV}-SNAPSHOT/${PN}-dep-${PV}-SNAPSHOT.jar
+ dodoc README.html doc/ReleaseNotes${PV}.txt
+
+ use examples && java-pkg_doexamples org/junit/samples
+ use source && java-pkg_dosrc src/main/java/org src/main/java/junit
+
+ if use doc; then
+ dohtml -r doc/*
+ java-pkg_dojavadoc ${PN}${PV}-SNAPSHOT/javadoc
+ fi
+}