summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-03-08 16:17:17 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-03-08 16:17:17 +0000
commit0cf12619c89fb96aefe39b5de7bed7a6dfd55372 (patch)
tree45a5bdd826513cd3b7f9c6425609d521f42f404b /dev-java/jflex
parentRevision bump. EAPI 5. (diff)
downloadgentoo-2-0cf12619c89fb96aefe39b5de7bed7a6dfd55372.tar.gz
gentoo-2-0cf12619c89fb96aefe39b5de7bed7a6dfd55372.tar.bz2
gentoo-2-0cf12619c89fb96aefe39b5de7bed7a6dfd55372.zip
Version bump to 1.5.0, EAPI 5, partially fixes bug #498874 reported by Mr. Anderson; remove old.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/jflex')
-rw-r--r--dev-java/jflex/ChangeLog11
-rw-r--r--dev-java/jflex/files/jflex-1.5.0-build.xml286
-rw-r--r--dev-java/jflex/jflex-1.4.1-r1.ebuild72
-rw-r--r--dev-java/jflex/jflex-1.5.0.ebuild78
4 files changed, 373 insertions, 74 deletions
diff --git a/dev-java/jflex/ChangeLog b/dev-java/jflex/ChangeLog
index c2edda562306..70c123ea3ead 100644
--- a/dev-java/jflex/ChangeLog
+++ b/dev-java/jflex/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jflex
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/ChangeLog,v 1.12 2013/10/20 16:32:51 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/ChangeLog,v 1.13 2014/03/08 16:17:17 tomwij Exp $
+
+*jflex-1.5.0 (08 Mar 2014)
+
+ 08 Mar 2014; Tom Wijsman <TomWij@gentoo.org> +files/jflex-1.5.0-build.xml,
+ +jflex-1.5.0.ebuild, -jflex-1.4.1-r1.ebuild:
+ Version bump to 1.5.0, EAPI 5, partially fixes bug #498874 reported by Mr.
+ Anderson; remove old.
20 Oct 2013; Agostino Sarubbo <ago@gentoo.org> jflex-1.4.3.ebuild:
Stable for ppc64, wrt bug #476958
diff --git a/dev-java/jflex/files/jflex-1.5.0-build.xml b/dev-java/jflex/files/jflex-1.5.0-build.xml
new file mode 100644
index 000000000000..0b0f32727da4
--- /dev/null
+++ b/dev-java/jflex/files/jflex-1.5.0-build.xml
@@ -0,0 +1,286 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 3/8/14 4:23 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jflex-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jflex-1.5.0"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/apache/ant/ant/1.7.0/ant-1.7.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/ant/ant-launcher/1.7.0/ant-launcher-1.7.0.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/apache/ant/ant/1.7.0/ant-1.7.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/ant/ant-launcher/1.7.0/ant-launcher-1.7.0.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*Test.java"/>
+ <include name="**/*Tests.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class"
+ value="jflex.Main"/>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/org/apache/ant/ant/1.7.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/apache/ant/ant/1.7.0/ant-1.7.0.jar"
+ dest="${maven.repo.local}/org/apache/ant/ant/1.7.0/ant-1.7.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/apache/ant/ant/1.7.0/ant-1.7.0.jar"
+ dest="${maven.repo.local}/org/apache/ant/ant/1.7.0/ant-1.7.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/apache/ant/ant-launcher/1.7.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/apache/ant/ant-launcher/1.7.0/ant-launcher-1.7.0.jar"
+ dest="${maven.repo.local}/org/apache/ant/ant-launcher/1.7.0/ant-launcher-1.7.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/apache/ant/ant-launcher/1.7.0/ant-launcher-1.7.0.jar"
+ dest="${maven.repo.local}/org/apache/ant/ant-launcher/1.7.0/ant-launcher-1.7.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.11"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/junit/junit/4.11/junit-4.11.jar"
+ dest="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.11/junit-4.11.jar"
+ dest="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/jflex/jflex-1.4.1-r1.ebuild b/dev-java/jflex/jflex-1.4.1-r1.ebuild
deleted file mode 100644
index 23cb48a0b2cc..000000000000
--- a/dev-java/jflex/jflex-1.4.1-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/jflex-1.4.1-r1.ebuild,v 1.1 2009/01/31 14:27:08 serkan Exp $
-
-# Currently, this package uses an included JFlex.jar file to bootstrap.
-# Upstream was contacted and this bootstrap is really needed. The only way to avoid it would be to use a supplied pre-compiled .scanner file.
-
-EAPI="1"
-JAVA_PKG_IUSE="source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="JFlex is a lexical analyzer generator for Java"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.jflex.de/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-RDEPEND=">=virtual/jre-1.4
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
- >=dev-java/ant-core-1.7.0
- >=dev-java/javacup-0.11a_beta20060608:0"
-
-DEPEND=">=virtual/jdk-1.4
- dev-java/junit:0
- >=dev-java/javacup-0.11a_beta20060608:0"
-
-IUSE="doc source vim-syntax"
-
-src_unpack() {
- unpack "${P}.tar.gz"
- cd "${S}/src"
- epatch "${FILESDIR}/${P}-build.xml.patch"
-
- mkdir "${S}/tools"
- cp "${S}/lib/JFlex.jar" "${S}/tools/JFlex.jar"
- rm -rf java_cup "${S}/lib/JFlex.jar"
-
- java-ant_rewrite-classpath
-}
-
-src_compile() {
- ANT_TASKS="javacup"
- jflex_cp="$(java-pkg_getjars --build-only junit):$(java-pkg_getjars ant-core,javacup)"
- cd "${S}/src"
- eant realclean
- eant -Dgentoo.classpath="${jflex_cp}" jar
-
- rm "${S}/tools/JFlex.jar"
- cp "${S}/lib/JFlex.jar" "${S}/tools/"
- rm "${S}/lib/JFlex.jar"
-
- eant realclean
- einfo "Recompiling using the newly generated JFlex library"
- eant -Dgentoo.classpath="${jflex_cp}" jar
-}
-
-src_install() {
- java-pkg_dojar lib/JFlex.jar
- java-pkg_dolauncher "${PN}" --main JFlex.Main
- java-pkg_register-ant-task
-
- dodoc doc/manual.pdf doc/manual.ps.gz src/changelog
- dohtml -r doc/*
-
- use source && java-pkg_dosrc src/JFlex
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins "${S}/lib/jflex.vim"
- fi
-}
diff --git a/dev-java/jflex/jflex-1.5.0.ebuild b/dev-java/jflex/jflex-1.5.0.ebuild
new file mode 100644
index 000000000000..689b13ec9d78
--- /dev/null
+++ b/dev-java/jflex/jflex-1.5.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/jflex-1.5.0.ebuild,v 1.1 2014/03/08 16:17:17 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source examples"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JFlex is a lexical analyzer generator for Java"
+HOMEPAGE="http://www.jflex.de/"
+SRC_URI="http://${PN}.de/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.5"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND=">=virtual/jre-1.5
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ >=dev-java/ant-core-1.7.0
+ >=dev-java/javacup-0.11a_beta20060608:0"
+
+DEPEND=">=virtual/jdk-1.5
+ dev-java/junit:0
+ >=dev-java/javacup-0.11a_beta20060608:0"
+
+IUSE="${JAVA_PKG_IUSE} source vim-syntax"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+# TODO: Try to avoid using bundled jar (See bug #498874)
+#
+# Currently, this package uses an included JFlex.jar file to bootstrap.
+# Upstream was contacted and this bootstrap is really needed. The only way to
+# avoid it would be to use a supplied pre-compiled .scanner file.
+
+EANT_GENTOO_CLASSPATH="ant-core"
+EANT_GENTOO_CLASSPATH_EXTRA="lib/${P}.jar"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+ANT_TASKS="javacup"
+
+src_compile() {
+ java-pkg-2_src_compile
+
+ # Compile another time, using our generated jar; for sanity.
+ cp target/${P}.jar ${EANT_GENTOO_CLASSPATH_EXTRA}
+ java-pkg-2_src_compile
+}
+
+# EANT_TEST_GENTOO_CLASSPATH doesn't support EANT_GENTOO_CLASSPATH_EXTRA yet.
+RESTRICT="test"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+ java-pkg_dolauncher "${PN}" --main jflex.Main
+ java-pkg_register-ant-task
+
+ if use doc ; then
+ dodoc doc/manual.pdf doc/manual.ps.gz src/changelog
+ dohtml -r doc/*
+ java-pkg_dojavadoc target/site/apidocs
+ fi
+
+ use examples && java-pkg_doexamples examples
+ use source && java-pkg_dosrc src/main
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins "${S}/lib/jflex.vim"
+ fi
+}