summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-11-30 08:29:53 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-11-30 08:29:53 +0000
commit3b1a8f3e398d4a1b55e373e19a58a4826a9f672a (patch)
treee5a921bcd2b1a4e8937ed718e7e213cf3099dce9 /dev-java/jdbc-postgresql
parentQuoted multiple S variables. Removed redundant cd ${S} call from start of src... (diff)
downloadgentoo-2-3b1a8f3e398d4a1b55e373e19a58a4826a9f672a.tar.gz
gentoo-2-3b1a8f3e398d4a1b55e373e19a58a4826a9f672a.tar.bz2
gentoo-2-3b1a8f3e398d4a1b55e373e19a58a4826a9f672a.zip
Version bump to 9.2_p1003. EAPI 5. Fixes bug #489082, reported by Gordon Pettey (petteyg359).
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/jdbc-postgresql')
-rw-r--r--dev-java/jdbc-postgresql/ChangeLog10
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-9.2_p1003.ebuild79
2 files changed, 87 insertions, 2 deletions
diff --git a/dev-java/jdbc-postgresql/ChangeLog b/dev-java/jdbc-postgresql/ChangeLog
index 26b01554967c..1e62e353ded6 100644
--- a/dev-java/jdbc-postgresql/ChangeLog
+++ b/dev-java/jdbc-postgresql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jdbc-postgresql
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/ChangeLog,v 1.48 2013/09/19 20:20:44 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/ChangeLog,v 1.49 2013/11/30 08:29:53 tomwij Exp $
+
+*jdbc-postgresql-9.2_p1003 (30 Nov 2013)
+
+ 30 Nov 2013; Tom Wijsman <TomWij@gentoo.org>
+ +jdbc-postgresql-9.2_p1003.ebuild:
+ Version bump to 9.2_p1003. EAPI 5. Fixes bug #489082, reported by Gordon
+ Pettey (petteyg359).
19 Sep 2013; Aaron W. Swenson <titanofold@gentoo.org>
jdbc-postgresql-8.3_p603.ebuild, jdbc-postgresql-8.3_p605.ebuild,
@@ -249,4 +256,3 @@
+jdbc-postgresql-8.0_p318.ebuild, +jdbc-postgresql-8.1_p408.ebuild,
+jdbc-postgresql-8.2_p504.ebuild:
Created new ebuilds that will replace jdbc3-postgresql package, bug #157973.
-
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-9.2_p1003.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-9.2_p1003.ebuild
new file mode 100644
index 000000000000..3e7e207aea18
--- /dev/null
+++ b/dev-java/jdbc-postgresql/jdbc-postgresql-9.2_p1003.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/jdbc-postgresql-9.2_p1003.ebuild,v 1.1 2013/11/30 08:29:53 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="postgresql-jdbc"
+MY_PV="${PV/_p/-}"
+MY_P="${MY_PN}-${MY_PV}.src"
+
+DESCRIPTION="JDBC Driver for PostgreSQL"
+SRC_URI="http://jdbc.postgresql.org/download/${MY_P}.tar.gz"
+HOMEPAGE="http://jdbc.postgresql.org/"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ doc? (
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ )
+ test? (
+ dev-java/ant-junit
+ dev-db/postgresql-server
+ )"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/postgresql-jdbc-${MY_PV}.src"
+
+java_prepare() {
+ find -name "*.class" -type f -exec rm -v {} + || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_DOC_TARGET="publicapi"
+
+src_compile() {
+ java-pkg-2_src_compile
+
+ # There is a task that creates this doc but I didn't find a way how to use system catalog
+ # to lookup the stylesheet so the 'doc' target is rewritten here to use system call instead.
+ if use doc; then
+ mkdir -p "${S}/build/doc"
+ xsltproc -o "${S}/build/doc/pgjdbc.html" http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl \
+ "${S}/doc/pgjdbc.xml"
+ fi
+}
+
+src_test() {
+ einfo "In order to run the tests successfully, you have to have:"
+ einfo "1) PostgreSQL server running"
+ einfo "2) database 'test' defined with user 'test' with password 'password'"
+ einfo " as owner of the database"
+ einfo "3) plpgsql support in the 'test' database"
+ einfo
+ einfo "You can find a general info on how to perform these steps at"
+ einfo "https://wiki.gentoo.org/wiki/PostgreSQL"
+
+ ANT_TASKS="ant-junit" eant test -Dgentoo.classpath=$(java-pkg_getjars --build-only junit)
+}
+
+src_install() {
+ java-pkg_newjar jars/postgresql.jar jdbc-postgresql.jar
+
+ if use doc ; then
+ java-pkg_dojavadoc build/publicapi
+ dohtml build/doc/pgjdbc.html
+ fi
+
+ use source && java-pkg_dosrc org
+}