summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-01-29 11:07:07 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-01-29 11:07:07 +0000
commit3a6eee032bfd9e8dad90685cab9c9707c9e2e1bf (patch)
tree5ea3936a509f68736b57daff1c0b2a3d503d1bf7 /dev-java/javacc
parentBy default, disable building of static libs. Fix automake call in 2.2.3. (diff)
downloadgentoo-2-3a6eee032bfd9e8dad90685cab9c9707c9e2e1bf.tar.gz
gentoo-2-3a6eee032bfd9e8dad90685cab9c9707c9e2e1bf.tar.bz2
gentoo-2-3a6eee032bfd9e8dad90685cab9c9707c9e2e1bf.zip
dev-java/javacc: some fixes
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/javacc')
-rw-r--r--dev-java/javacc/ChangeLog8
-rw-r--r--dev-java/javacc/javacc-5.0.ebuild20
2 files changed, 12 insertions, 16 deletions
diff --git a/dev-java/javacc/ChangeLog b/dev-java/javacc/ChangeLog
index 9d7b9f59a706..92695980e9ea 100644
--- a/dev-java/javacc/ChangeLog
+++ b/dev-java/javacc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/javacc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/javacc/ChangeLog,v 1.32 2010/03/21 15:32:57 phajdan.jr Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javacc/ChangeLog,v 1.33 2011/01/29 11:07:07 fordfrog Exp $
+
+ 29 Jan 2011; Miroslav Šulc <fordfrog@gentoo.org> javacc-5.0.ebuild:
+ Did some fixes with regard to jdk version in the ebuild, but it still fails
+ tests
21 Mar 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> javacc-4.2.ebuild:
x86 stable wrt bug #309265
diff --git a/dev-java/javacc/javacc-5.0.ebuild b/dev-java/javacc/javacc-5.0.ebuild
index 2f87d94a257c..1cc139a75880 100644
--- a/dev-java/javacc/javacc-5.0.ebuild
+++ b/dev-java/javacc/javacc-5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/javacc/javacc-5.0.ebuild,v 1.1 2010/03/16 11:12:41 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javacc/javacc-5.0.ebuild,v 1.2 2011/01/29 11:07:07 fordfrog Exp $
JAVA_PKG_IUSE="doc examples source test"
EAPI="2"
@@ -16,18 +16,10 @@ IUSE=""
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
DEPEND=">=virtual/jdk-1.5
dev-java/junit:0
- test? (
- >=virtual/jdk-1.5
- dev-java/ant-junit
- )
- !test? ( >=virtual/jdk-1.4 )"
-RDEPEND=">=virtual/jre-1.4
+ test? ( dev-java/ant-junit )"
+RDEPEND=">=virtual/jre-1.5
dev-java/junit:0"
-# We don't want 1.5 bytecode just because of the testcase
-JAVA_PKG_WANT_TARGET="1.4"
-JAVA_PKG_WANT_SOURCE="1.4"
-
S="${WORKDIR}/${PN}"
java_prepare() {
@@ -40,12 +32,12 @@ _eant() {
}
src_compile() {
+ # this testcase wants 1.5 and this seems the easiest way to do it
+ JAVA_PKG_WANT_SOURCE="1.5" JAVA_PKG_WANT_TARGET="1.5" java-ant_bsfix_one examples/JavaGrammars/1.5/build.xml
_eant jar $(use_doc)
}
src_test() {
- # this testcase wants 1.5 and this seems the easiest way to do it
- JAVA_PKG_WANT_SOURCE="1.5" JAVA_PKG_WANT_TARGET="1.5" java-ant_bsfix_one examples/JavaGrammars/1.5/build.xml
ANT_TASKS="ant-junit" _eant test
}