summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-07-25 16:31:33 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-07-25 16:31:33 +0000
commitdcf8c6a16e2264ec1fb35c753e6962aea4be5748 (patch)
tree3dc32ae5a40f23286ce7c515e1f043905dc10efb /dev-java/java-sdk-docs
parentVersion bump. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/177 ... (diff)
downloadgentoo-2-dcf8c6a16e2264ec1fb35c753e6962aea4be5748.tar.gz
gentoo-2-dcf8c6a16e2264ec1fb35c753e6962aea4be5748.tar.bz2
gentoo-2-dcf8c6a16e2264ec1fb35c753e6962aea4be5748.zip
Version bump. ~arm added to 1.8 SLOT.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'dev-java/java-sdk-docs')
-rw-r--r--dev-java/java-sdk-docs/ChangeLog8
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.8.0.51.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-java/java-sdk-docs/ChangeLog b/dev-java/java-sdk-docs/ChangeLog
index 6fb994fbcc01..b8492a5083a3 100644
--- a/dev-java/java-sdk-docs/ChangeLog
+++ b/dev-java/java-sdk-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/java-sdk-docs
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.127 2015/06/15 00:32:10 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.128 2015/07/25 16:31:33 chewi Exp $
+
+*java-sdk-docs-1.8.0.51 (25 Jul 2015)
+
+ 25 Jul 2015; James Le Cuirot <chewi@gentoo.org>
+ +java-sdk-docs-1.8.0.51.ebuild:
+ Version bump. ~arm added to 1.8 SLOT.
15 Jun 2015; Patrice Clement <monsieurp@gentoo.org>
-java-sdk-docs-1.5.0-r1.ebuild:
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.51.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.51.ebuild
new file mode 100644
index 000000000000..84814727812f
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.51.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.51.ebuild,v 1.1 2015/07/25 16:31:33 chewi Exp $
+
+EAPI="5"
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
+
+[[ "$(get_version_component_range 4)" == 0 ]] \
+ || MY_PV_EXT="u$(get_version_component_range 4)"
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/8/docs/"
+SRC_URI="${ORIG_NAME}"
+LICENSE="oracle-java-documentation-8"
+SLOT="1.8"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}