summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-10-20 15:47:02 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-10-20 15:47:02 +0000
commit4c7e5a43852f10810f74a924524fac0f6964c7e3 (patch)
treec768d734841f7c4e8dd39180ddd3d6c3b10881de /dev-java/guava/guava-18.0.ebuild
parentfix misnaming of unmask in no-emul-linux-x86 (diff)
downloadgentoo-2-4c7e5a43852f10810f74a924524fac0f6964c7e3.tar.gz
gentoo-2-4c7e5a43852f10810f74a924524fac0f6964c7e3.tar.bz2
gentoo-2-4c7e5a43852f10810f74a924524fac0f6964c7e3.zip
Version bump (bug #525600)
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java/guava/guava-18.0.ebuild')
-rw-r--r--dev-java/guava/guava-18.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-java/guava/guava-18.0.ebuild b/dev-java/guava/guava-18.0.ebuild
new file mode 100644
index 000000000000..4255e8509e29
--- /dev/null
+++ b/dev-java/guava/guava-18.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/guava/guava-18.0.ebuild,v 1.1 2014/10/20 15:47:02 ercpe Exp $
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A collection of Google's core Java libraries"
+HOMEPAGE="http://code.google.com/p/guava-libraries/"
+SRC_URI="http://search.maven.org/remotecontent?filepath=com/google/${PN}/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="Apache-2.0"
+SLOT="18"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+COMMON_DEP="
+ dev-java/javax-inject:0
+ dev-java/jsr305:0
+ java-virtuals/jdk-with-com-sun:0"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.6"
+DEPEND="${COMMON_DEP}
+ app-arch/unzip
+ >=virtual/jdk-1.7" # http://code.google.com/p/guava-libraries/issues/detail?id=635
+
+JAVA_GENTOO_CLASSPATH="jsr305,javax-inject"