summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-16 08:09:54 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-16 08:09:54 +0000
commit10dcd24ac1030c0f158176c00837c78cf37a7ccc (patch)
tree0bc31426a99fddb13837954b69143c2fca917867 /dev-java/gnu-jaxp
parentminor version update to fix compilation problem (diff)
downloadgentoo-2-10dcd24ac1030c0f158176c00837c78cf37a7ccc.tar.gz
gentoo-2-10dcd24ac1030c0f158176c00837c78cf37a7ccc.tar.bz2
gentoo-2-10dcd24ac1030c0f158176c00837c78cf37a7ccc.zip
Initial import. GNU JAXP, a free implementation of SAX parser API, DOM Level 2, Sun JAXP 1.1.
Diffstat (limited to 'dev-java/gnu-jaxp')
-rw-r--r--dev-java/gnu-jaxp/ChangeLog17
-rw-r--r--dev-java/gnu-jaxp/files/digest-gnu-jaxp-1.0_beta11
-rw-r--r--dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild25
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-java/gnu-jaxp/ChangeLog b/dev-java/gnu-jaxp/ChangeLog
new file mode 100644
index 000000000000..51909a6f0d19
--- /dev/null
+++ b/dev-java/gnu-jaxp/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for dev-java/gnu-jaxp
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-jaxp/ChangeLog,v 1.1 2003/03/16 08:09:54 absinthe Exp $
+
+*gnu-jaxp-1.0_beta1 (16 Mar 2003)
+
+ 16 Mar 2003; Dylan Carlson <absinthe@gentoo.org> gnu-jaxp-1.0_beta1.ebuild:
+ Initial import.
+
+ GNU JAXP, a part of the GNU Classpath Extensions project (hosted at
+ savannah.gnu.org) is a free implementation of the standard XML processing APIs
+ for Java:
+
+ - SAX Parser API
+ - DOM Level 2 generic XML data structures
+ - Sun's JAXP v1.1 interfaces
+
diff --git a/dev-java/gnu-jaxp/files/digest-gnu-jaxp-1.0_beta1 b/dev-java/gnu-jaxp/files/digest-gnu-jaxp-1.0_beta1
new file mode 100644
index 000000000000..ebcc1f2223ed
--- /dev/null
+++ b/dev-java/gnu-jaxp/files/digest-gnu-jaxp-1.0_beta1
@@ -0,0 +1 @@
+MD5 42b041800cc1237cf45e80c6ff35c476 gnujaxp-1.0beta1.zip 1652312
diff --git a/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild b/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild
new file mode 100644
index 000000000000..a81b8447f9b9
--- /dev/null
+++ b/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild,v 1.1 2003/03/16 08:09:54 absinthe Exp $
+
+S=${WORKDIR}/${PN}-${PV}
+P=${PN/-/}-${PV/_beta1/beta1}
+DESCRIPTION="GNU JAXP, a free implementation of SAX parser API, DOM Level 2, Sun JAXP 1.1."
+HOMEPAGE="http://www.gnu.org/software/classpathx/jaxp/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/classpathx/${P}.zip"
+DEPEND=">=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_install () {
+ cd ${WORKDIR}/${P}
+ dojar gnujaxp.jar || die "Unable to Install"
+ use doc && dohtml -r apidoc/*
+}