summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-04-14 18:25:45 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-04-14 18:25:45 +0000
commit3c19c552c953a685337edc6b4f4d269284a3f08a (patch)
treee1fe271a58e7544f88077b5b6a188f0f04101e86 /dev-java/gnu-hylafax
parentEAPI revbump (diff)
downloadgentoo-2-3c19c552c953a685337edc6b4f4d269284a3f08a.tar.gz
gentoo-2-3c19c552c953a685337edc6b4f4d269284a3f08a.tar.bz2
gentoo-2-3c19c552c953a685337edc6b4f4d269284a3f08a.zip
Remove dev-java/concurrent-util dependency. Patch sources to get them to compile using java.util.concurrent instead. Fix bug 546502.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> (Portage version: 2.2.14/cvs/Linux i686, signed Manifest commit with key 93491BB8)
Diffstat (limited to 'dev-java/gnu-hylafax')
-rw-r--r--dev-java/gnu-hylafax/ChangeLog9
-rw-r--r--dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch70
-rw-r--r--dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r1.ebuild43
3 files changed, 121 insertions, 1 deletions
diff --git a/dev-java/gnu-hylafax/ChangeLog b/dev-java/gnu-hylafax/ChangeLog
index 276e7d90a7a6..51693168a635 100644
--- a/dev-java/gnu-hylafax/ChangeLog
+++ b/dev-java/gnu-hylafax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/gnu-hylafax
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-hylafax/ChangeLog,v 1.1 2015/03/22 08:27:39 ercpe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-hylafax/ChangeLog,v 1.2 2015/04/14 18:25:45 monsieurp Exp $
+
+*gnu-hylafax-1.0.3-r1 (14 Apr 2015)
+
+ 14 Apr 2015; Patrice Clement <monsieurp@gentoo.org>
+ +files/gnu-hylafax-1.0.3-ClientPool.patch, +gnu-hylafax-1.0.3-r1.ebuild:
+ Remove dev-java/concurrent-util dependency. Patch sources to get them to
+ compile using java.util.concurrent instead. Fix bug 546502.
*gnu-hylafax-1.0.3 (22 Mar 2015)
diff --git a/dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch b/dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch
new file mode 100644
index 000000000000..51bae74646ed
--- /dev/null
+++ b/dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch
@@ -0,0 +1,70 @@
+--- gnu-hylafax-pool/main/java/gnu/hylafax/pool/ClientPool.java.orig 2015-04-14 18:20:17.113435400 +0000
++++ gnu-hylafax-pool/main/java/gnu/hylafax/pool/ClientPool.java 2015-04-14 18:20:58.310438791 +0000
+@@ -32,7 +32,7 @@
+ import org.apache.commons.logging.Log;
+ import org.apache.commons.logging.LogFactory;
+
+-import EDU.oswego.cs.dl.util.concurrent.LinkedQueue;
++import java.util.concurrent.ConcurrentLinkedQueue;
+
+ public class ClientPool implements gnu.hylafax.ClientPool {
+
+@@ -42,7 +42,7 @@
+
+ private HashMap clientMap;
+
+- private LinkedQueue clients;
++ private ConcurrentLinkedQueue clients;
+
+ private ClientPoolConfiguration configuration;
+
+@@ -66,7 +66,7 @@
+
+ public ClientPool(ClientPoolConfiguration configuration) {
+ this.configuration = configuration;
+- clients = new LinkedQueue();
++ clients = new ConcurrentLinkedQueue();
+ clientMap = new HashMap();
+ workingClients = new HashSet();
+ workingClientsToClose = new HashSet();
+@@ -163,8 +163,7 @@
+ blocked = true;
+ }
+
+- client = (PooledClient) clients.poll(getConfiguration()
+- .getRetryInterval());
++ client = (PooledClient) clients.poll();
+ if (client == null)
+ log.warn("No Clients Available.");
+ else if (!clientAdded)
+@@ -172,10 +171,10 @@
+ }
+
+ } else {
+- client = (PooledClient) clients.take();
++ client = (PooledClient) clients.poll();
+ }
+ }
+- } catch (InterruptedException e) {
++ } catch (Exception e) {
+ throw new ClientPoolException(
+ "Interrupted Thread and No Free Connection Available.");
+ }
+@@ -294,7 +293,7 @@
+ destroyClient(client);
+ addClient();
+ } else {
+- clients.put(client);
++ clients.offer(client);
+ size++;
+ }
+ }
+@@ -306,7 +305,7 @@
+
+ log.debug("Released Client.");
+
+- } catch (InterruptedException e) {
++ } catch (Exception e) {
+ log.warn("Was Interrupted.", e);
+ destroyClient(client);
+ } finally {
diff --git a/dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r1.ebuild b/dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..4b7c00ef92f0
--- /dev/null
+++ b/dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r1.ebuild,v 1.1 2015/04/14 18:25:45 monsieurp Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="source doc"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java API designed to implement the client protocol portion of the hfaxd server"
+HOMEPAGE="http://gnu-hylafax.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}-bin.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/commons-logging:0
+ dev-java/commons-cli:1
+ java-virtuals/javamail:0
+ dev-java/java-getopt:1
+ dev-java/log4j:0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="commons-logging,commons-cli-1,javamail,java-getopt-1,log4j"
+
+java_prepare() {
+ rm -rv "${S}"/lib || die
+ find -name "pom.xml" -delete || die
+
+ # tarball contains the same sources in gnu-.../sources and gnu-.../main/
+ rm -r gnu-hylafax-*/sources || die
+
+ # bug 546502
+ epatch "${FILESDIR}"/"${P}"-ClientPool.patch
+}