summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-01-25 00:47:50 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-01-25 00:47:50 +0000
commit07e9b4874be0d042fcef19b0e299a357f50a6eac (patch)
tree1fa68aae6ccd1e9b9319f320ccede806025ce8cf /dev-java/fop-bin/fop-bin-0.20.5.ebuild
parentsyntax highlighting for manpages (diff)
downloadgentoo-2-07e9b4874be0d042fcef19b0e299a357f50a6eac.tar.gz
gentoo-2-07e9b4874be0d042fcef19b0e299a357f50a6eac.tar.bz2
gentoo-2-07e9b4874be0d042fcef19b0e299a357f50a6eac.zip
Version bumped and fixed the headers.
Diffstat (limited to 'dev-java/fop-bin/fop-bin-0.20.5.ebuild')
-rw-r--r--dev-java/fop-bin/fop-bin-0.20.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/fop-bin/fop-bin-0.20.5.ebuild b/dev-java/fop-bin/fop-bin-0.20.5.ebuild
new file mode 100644
index 000000000000..1fef3d7441af
--- /dev/null
+++ b/dev-java/fop-bin/fop-bin-0.20.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fop-bin/fop-bin-0.20.5.ebuild,v 1.1 2004/01/25 00:47:36 plasmaroo Exp $
+
+MY_P=${P/-bin/}
+DESCRIPTION="Formatting Objects Processor is a print formatter driven by XSL"
+SRC_URI="http://xml.apache.org/dist/fop/${MY_P}-bin.tar.gz"
+HOMEPAGE="http://xml.apache.org/fop/"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=virtual/jdk-1.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ sed '2itest "$FOP_HOME" || FOP_HOME=/usr/share/fop/' fop.sh > fop
+ exeinto /usr/bin
+ doexe fop
+
+ env PN=${PN/-bin/} dojar lib/*.jar build/*.jar
+ dodoc LICENSE README CHANGES ReleaseNotes.html STATUS
+ dodoc lib/*.txt docs/*.pdf conf/*
+ dohtml -r docs/html-docs/*
+}