summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-11-02 09:02:43 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-11-02 09:02:43 +0000
commit894d87a1cc3a2c835a2b181fb5ddaca60be842a4 (patch)
treec45410d0c8cb2c22dbe4772e9ac0931024261ed5 /dev-java/eclipse-ecj
parentStable for alpha, wrt bug #523210 (diff)
downloadgentoo-2-894d87a1cc3a2c835a2b181fb5ddaca60be842a4.tar.gz
gentoo-2-894d87a1cc3a2c835a2b181fb5ddaca60be842a4.tar.bz2
gentoo-2-894d87a1cc3a2c835a2b181fb5ddaca60be842a4.zip
Version bump for www-servers/tomcat
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java/eclipse-ecj')
-rw-r--r--dev-java/eclipse-ecj/ChangeLog7
-rw-r--r--dev-java/eclipse-ecj/eclipse-ecj-4.4.1.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-java/eclipse-ecj/ChangeLog b/dev-java/eclipse-ecj/ChangeLog
index acdf1edd2b7a..95159af59dcc 100644
--- a/dev-java/eclipse-ecj/ChangeLog
+++ b/dev-java/eclipse-ecj/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/eclipse-ecj
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/eclipse-ecj/ChangeLog,v 1.90 2014/06/04 10:46:06 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/eclipse-ecj/ChangeLog,v 1.91 2014/11/02 09:02:43 ercpe Exp $
+
+*eclipse-ecj-4.4.1 (02 Nov 2014)
+
+ 02 Nov 2014; Johann Schmitz <ercpe@gentoo.org> +eclipse-ecj-4.4.1.ebuild:
+ Version bump for www-servers/tomcat
04 Jun 2014; Chema Alonso <nimiux@gentoo.org> eclipse-ecj-3.7.2-r1.ebuild:
Stable for amd64 wrt bug #503890
diff --git a/dev-java/eclipse-ecj/eclipse-ecj-4.4.1.ebuild b/dev-java/eclipse-ecj/eclipse-ecj-4.4.1.ebuild
new file mode 100644
index 000000000000..a2a5c8ad6c57
--- /dev/null
+++ b/dev-java/eclipse-ecj/eclipse-ecj-4.4.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/eclipse-ecj/eclipse-ecj-4.4.1.ebuild,v 1.1 2014/11/02 09:02:43 ercpe Exp $
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="ecj"
+DMF="R-${PV}-201409250400"
+
+DESCRIPTION="Eclipse Compiler for Java"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops4/${DMF}/${MY_PN}src-${PV}.jar"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="4.4"
+IUSE="+ant userland_GNU"
+
+COMMON_DEP="
+ || ( app-admin/eselect-java app-admin/eselect-ecj )"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.6"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.6
+ app-arch/unzip
+ userland_GNU? ( sys-apps/findutils )"
+PDEPEND="
+ ant? ( ~dev-java/ant-eclipse-ecj-${PV} )"
+
+S="${WORKDIR}"
+
+JAVA_PKG_WANT_SOURCE=1.6
+JAVA_PKG_WANT_TARGET=1.6
+
+java_prepare() {
+ # These have their own package.
+ rm -f org/eclipse/jdt/core/JDTCompilerAdapter.java || die
+ rm -fr org/eclipse/jdt/internal/antadapter || die
+
+ rm build.xml || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ find -name "*.properties" | xargs jar uvf "${S}/${PN}.jar" || die "jar update failed"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+
+ java-pkg_dolauncher ${MY_PN}-${SLOT} --main \
+ org.eclipse.jdt.internal.compiler.batch.Main
+
+ java-pkg_newjar ${PN}.jar ${MY_PN}.jar
+}
+
+pkg_postinst() {
+ einfo "To select between slots of ECJ..."
+ einfo " # eselect ecj"
+
+ eselect ecj update ecj-${SLOT}
+}
+
+pkg_postrm() {
+ eselect ecj update
+}