summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-02-28 18:40:32 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-02-28 18:40:32 +0000
commite58d07b98e750e8cf0b96ded3305a93baaa5f418 (patch)
tree6f7b36fa2b4511a1d2fc8acad81ca94d84ab24ea /dev-java/cpptasks
parentAdded ~x86-fbsd keyword (diff)
downloadgentoo-2-e58d07b98e750e8cf0b96ded3305a93baaa5f418.tar.gz
gentoo-2-e58d07b98e750e8cf0b96ded3305a93baaa5f418.tar.bz2
gentoo-2-e58d07b98e750e8cf0b96ded3305a93baaa5f418.zip
Add net/sf/antcontrib/cpptasks/antlib.xml from upstream svn because dev-java/jogl needs this file.
(Portage version: 2.1.2-r12)
Diffstat (limited to 'dev-java/cpptasks')
-rw-r--r--dev-java/cpptasks/ChangeLog9
-rw-r--r--dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild57
-rw-r--r--dev-java/cpptasks/files/antlib.xml22
-rw-r--r--dev-java/cpptasks/files/digest-cpptasks-1.0_beta4-r23
4 files changed, 90 insertions, 1 deletions
diff --git a/dev-java/cpptasks/ChangeLog b/dev-java/cpptasks/ChangeLog
index d35965ef3395..3e4b6a21c836 100644
--- a/dev-java/cpptasks/ChangeLog
+++ b/dev-java/cpptasks/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/cpptasks
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/cpptasks/ChangeLog,v 1.7 2007/02/10 12:43:51 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/cpptasks/ChangeLog,v 1.8 2007/02/28 18:40:32 betelgeuse Exp $
+
+*cpptasks-1.0_beta4-r2 (28 Feb 2007)
+
+ 28 Feb 2007; Petteri Räty <betelgeuse@gentoo.org> +files/antlib.xml,
+ +cpptasks-1.0_beta4-r2.ebuild:
+ Add net/sf/antcontrib/cpptasks/antlib.xml from upstream svn because
+ dev-java/jogl needs this file.
*cpptasks-1.0_beta4-r1 (10 Feb 2007)
diff --git a/dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild b/dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild
new file mode 100644
index 000000000000..d8e24da16ab2
--- /dev/null
+++ b/dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild,v 1.1 2007/02/28 18:40:32 betelgeuse Exp $
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-${PV/_beta/b}"
+DESCRIPTION="Ant-tasks to compile various source languages and produce executables, shared libraries and static libraries"
+HOMEPAGE="http://ant-contrib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ant-contrib/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc source examples"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/ant-core-1.7
+ >=dev-java/xerces-2.7"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=829906&group_id=36177&atid=416920
+ # https://bugs.gentoo.org/show_bug.cgi?id=156596
+ epatch "${FILESDIR}/1.0b4-profiling.patch"
+
+ cd "${S}"
+ # in svn but missing from the release
+ cp "${FILESDIR}/antlib.xml" src/net/sf/antcontrib/cpptasks/antlib.xml || die
+ rm -v *.jar || die
+ java-ant_rewrite-classpath
+}
+
+EANT_BUILD_TARGET="jars"
+EANT_DOC_TARGET="javadocs -Dbuild.javadocs=build/api"
+EANT_GENTOO_CLASSPATH="ant-core,xerces-2"
+
+#The actual files for testing are not part of the release
+#src_test() {
+# eant run-tests
+#}
+
+src_install() {
+ java-pkg_dojar build/lib/${PN}.jar
+
+ java-pkg_register-ant-task
+
+ dodoc NOTICE || die
+ use doc && java-pkg_dojavadoc build/api
+ use examples && dodoc samples/*
+ use source && java-pkg_dosrc src/net
+
+}
diff --git a/dev-java/cpptasks/files/antlib.xml b/dev-java/cpptasks/files/antlib.xml
new file mode 100644
index 000000000000..5f8af42ad557
--- /dev/null
+++ b/dev-java/cpptasks/files/antlib.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0"?>
+ <!--
+ *
+ * Copyright 2004 The Ant-Contrib project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ -->
+ <antlib>
+ <taskdef resource="cpptasks.tasks" />
+ <typedef resource="cpptasks.types" />
+ </antlib>
+ \ No newline at end of file
diff --git a/dev-java/cpptasks/files/digest-cpptasks-1.0_beta4-r2 b/dev-java/cpptasks/files/digest-cpptasks-1.0_beta4-r2
new file mode 100644
index 000000000000..9a584bcf595f
--- /dev/null
+++ b/dev-java/cpptasks/files/digest-cpptasks-1.0_beta4-r2
@@ -0,0 +1,3 @@
+MD5 1b770a0b07a9f2f3c558bca1ad619439 cpptasks-1.0b4.tar.gz 879715
+RMD160 bfd90f71412ead94023da3b0a4156309dd4f6f4a cpptasks-1.0b4.tar.gz 879715
+SHA256 3472af7389c5a7daaff48a054c2b9f10994b55352025b8a2249a7dfcebca14c8 cpptasks-1.0b4.tar.gz 879715