summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-02-24 22:05:51 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-02-24 22:05:51 +0000
commit270110037ae45751441e853cb14aabc94c3b5a1a (patch)
treeca11bd55288f0d735aefb0f89e906fed9cb32528 /dev-java/commons-daemon
parentmask 1.6 selinux packages (diff)
downloadgentoo-2-270110037ae45751441e853cb14aabc94c3b5a1a.tar.gz
gentoo-2-270110037ae45751441e853cb14aabc94c3b5a1a.tar.bz2
gentoo-2-270110037ae45751441e853cb14aabc94c3b5a1a.zip
Initial Import.
Diffstat (limited to 'dev-java/commons-daemon')
-rw-r--r--dev-java/commons-daemon/ChangeLog10
-rw-r--r--dev-java/commons-daemon/Manifest3
-rw-r--r--dev-java/commons-daemon/commons-daemon-1.0.ebuild38
-rw-r--r--dev-java/commons-daemon/files/digest-commons-daemon-1.01
-rw-r--r--dev-java/commons-daemon/metadata.xml5
5 files changed, 57 insertions, 0 deletions
diff --git a/dev-java/commons-daemon/ChangeLog b/dev-java/commons-daemon/ChangeLog
new file mode 100644
index 000000000000..58bf65a31168
--- /dev/null
+++ b/dev-java/commons-daemon/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/commons-daemon
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/ChangeLog,v 1.1 2004/02/24 22:05:51 zx Exp $
+
+*commons-daemon-1.0 (27 Feb 2004)
+
+ 27 Feb 2004; Chris Aniszczyk <zx@gentoo.org> commons-daemon-1.0.ebuild:
+ Initial Import.
+ Thanks to Greg Bowyer <bg115@gre.ac.uk> for the initial ebuild. Closes #37931
+
diff --git a/dev-java/commons-daemon/Manifest b/dev-java/commons-daemon/Manifest
new file mode 100644
index 000000000000..517e53178d0c
--- /dev/null
+++ b/dev-java/commons-daemon/Manifest
@@ -0,0 +1,3 @@
+MD5 6e2556e552a90e8bc475c8bcdb56fe64 commons-daemon-1.0.ebuild 974
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 594ef90d87023327ed87ea6bad1ce322 files/digest-commons-daemon-1.0 68
diff --git a/dev-java/commons-daemon/commons-daemon-1.0.ebuild b/dev-java/commons-daemon/commons-daemon-1.0.ebuild
new file mode 100644
index 000000000000..526c305b21df
--- /dev/null
+++ b/dev-java/commons-daemon/commons-daemon-1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/commons-daemon-1.0.ebuild,v 1.1 2004/02/24 22:05:51 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Tools to allow java programs to run as unix daemons"
+SRC_URI="ftp://ftp.ibiblio.org/pub/mirrors/apache/jakarta/commons/daemon/source/daemon-1.0-Alpha.tar.gz"
+HOMEPAGE="http://jakarta.apache.org/commons/daemon/"
+LICENSE="Apache-1.1"
+SLOT="0"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-1.4
+ virtual/glibc"
+KEYWORDS="~x86"
+IUSE="jikes doc"
+
+S=${WORKDIR}/daemon-${PV}-Alpha
+
+src_compile() {
+ cd src/native/unix
+ econf || die
+ emake || die
+ cd ${S}
+
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ ant ${antflags}
+}
+
+src_install () {
+ dobin src/native/unix/jsvc
+ java-pkg_dojar dist/${PN}.jar || die "Unable to install"
+ dodoc README RELEASE-NOTES.txt *.html
+ cp -R src/samples ${D}/usr/share/doc/${P}/
+ use doc && dohtml -r dist/docs/*
+}
diff --git a/dev-java/commons-daemon/files/digest-commons-daemon-1.0 b/dev-java/commons-daemon/files/digest-commons-daemon-1.0
new file mode 100644
index 000000000000..d77f6d60490b
--- /dev/null
+++ b/dev-java/commons-daemon/files/digest-commons-daemon-1.0
@@ -0,0 +1 @@
+MD5 266c684ece05fbf7261bdcd566453f35 daemon-1.0-Alpha.tar.gz 219634
diff --git a/dev-java/commons-daemon/metadata.xml b/dev-java/commons-daemon/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-daemon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>