summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-06-01 15:38:25 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-06-01 15:38:25 +0000
commit4be045080e2220f44e1af6390aecf2187558a063 (patch)
tree3dd85a34f003963e112cb6cf60496637f0703b68 /dev-java/bcmail
parentFixed junit dependency to be in DEPEND and tests to only be present when the ... (diff)
downloadgentoo-2-4be045080e2220f44e1af6390aecf2187558a063.tar.gz
gentoo-2-4be045080e2220f44e1af6390aecf2187558a063.tar.bz2
gentoo-2-4be045080e2220f44e1af6390aecf2187558a063.zip
Version bump to 1.49, reported by maksbotan; tests are restricted since tests for dependencies are restricted, see bug #471998. Dropped ~amd64-fbsd keyword since dev-java/bcprov and dev-java/bcpkix have no ~amd64-fbsd keyword, see bug #472010.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/bcmail')
-rw-r--r--dev-java/bcmail/ChangeLog13
-rw-r--r--dev-java/bcmail/bcmail-1.49.ebuild82
2 files changed, 92 insertions, 3 deletions
diff --git a/dev-java/bcmail/ChangeLog b/dev-java/bcmail/ChangeLog
index e10febffb0b0..abd088451e0b 100644
--- a/dev-java/bcmail/ChangeLog
+++ b/dev-java/bcmail/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/bcmail
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bcmail/ChangeLog,v 1.34 2012/05/12 03:42:10 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcmail/ChangeLog,v 1.35 2013/06/01 15:38:25 tomwij Exp $
+
+*bcmail-1.49 (01 Jun 2013)
+
+ 01 Jun 2013; Tom Wijsman <TomWij@gentoo.org> +bcmail-1.49.ebuild:
+ Version bump to 1.49, reported by maksbotan; tests are restricted since tests
+ for dependencies are restricted, see bug #471998. Dropped ~amd64-fbsd keyword
+ since dev-java/bcprov and dev-java/bcpkix have no ~amd64-fbsd keyword, see bug
+ #472010.
12 May 2012; Alexis Ballier <aballier@gentoo.org> bcmail-1.45.ebuild:
keyword ~amd64-fbsd
@@ -121,4 +129,3 @@
25 Mar 2007; William L. Thomson Jr. <wltjr@gentoo.org> ChangeLog:
Initial ebuild, should be pretty identical to bcprov ebuild. Ideal to keep
both in sync. Still to do, junit/test stuff, optional dep/compile test run
-
diff --git a/dev-java/bcmail/bcmail-1.49.ebuild b/dev-java/bcmail/bcmail-1.49.ebuild
new file mode 100644
index 000000000000..267780c0f83b
--- /dev/null
+++ b/dev-java/bcmail/bcmail-1.49.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcmail/bcmail-1.49.ebuild,v 1.1 2013/06/01 15:38:25 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-jdk15on-${PV/./}"
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+
+COMMON_DEPEND=">=dev-java/bcprov-${PV}-r2:0[test?]
+ >=dev-java/bcpkix-${PV}-r1:0[test?]
+ dev-java/sun-jaf:0
+ java-virtuals/javamail:0"
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ test? ( dev-java/junit:0 )
+ ${COMMON_DEPEND}"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+# Package can't be build with test as bcprov and bcpkix can't be built with test.
+RESTRICT="test"
+
+src_unpack() {
+ default
+ cd "${S}"
+ unpack ./src.zip
+}
+
+java_prepare() {
+ mkdir "${S}"/classes
+
+ if use test ; then
+ java-pkg_jar-from --build-only junit
+ fi
+}
+
+src_compile() {
+ find org -name "*.java" > "${T}"/src.list
+
+ local cp="$(java-pkg_getjars bcprov,bcpkix,sun-jaf,javamail)"
+ if use test ; then
+ cp="${cp}:junit.jar"
+ else
+ sed -i '/\/test\//d' "${T}"/src.list || die "Failed to remove test classes"
+ fi
+
+ ejavac -d "${S}"/classes -cp ${cp} "@${T}"/src.list
+
+ cd "${S}"/classes
+ jar -cf "${S}"/${PN}.jar * || die "failed to create jar"
+}
+
+src_test() {
+ local cp="${PN}.jar:bcprov.jar:bcpkix.jar:junit.jar"
+
+ java -cp ${cp} org.bouncycastle.mail.smime.test.AllTests | tee mail.tests
+
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ java-pkg_dojar "${S}"/${PN}.jar
+
+ use source && java-pkg_dosrc org
+ use doc && java-pkg_dojavadoc docs
+}