summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-01-01 23:55:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-01-01 23:55:17 +0000
commit8c92ce7b2c864514443694bb790cac47657b0b81 (patch)
tree0be73f0e26f2794a994665c3ed02febfeb8de8d4 /dev-haskell
parentmarked x86 per bug 436518 (diff)
downloadgentoo-2-8c92ce7b2c864514443694bb790cac47657b0b81.tar.gz
gentoo-2-8c92ce7b2c864514443694bb790cac47657b0b81.tar.bz2
gentoo-2-8c92ce7b2c864514443694bb790cac47657b0b81.zip
Version bump.
(Portage version: 2.2.0_alpha149_p11/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/libmpd/ChangeLog9
-rw-r--r--dev-haskell/libmpd/libmpd-0.8.0.1-r1.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-haskell/libmpd/ChangeLog b/dev-haskell/libmpd/ChangeLog
index 97380c4289aa..c2c70bb6068e 100644
--- a/dev-haskell/libmpd/ChangeLog
+++ b/dev-haskell/libmpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/libmpd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/libmpd/ChangeLog,v 1.3 2012/12/06 22:54:56 slyfox Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/libmpd/ChangeLog,v 1.4 2013/01/01 23:55:17 slyfox Exp $
+
+*libmpd-0.8.0.1-r1 (01 Jan 2013)
+
+ 01 Jan 2013; Sergei Trofimovich <slyfox@gentoo.org> +libmpd-0.8.0.1-r1.ebuild:
+ Version bump.
06 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org> libmpd-0.7.2.ebuild:
Get rid of 'dev-haskell/time' depend as it's a ghc's core library.
diff --git a/dev-haskell/libmpd/libmpd-0.8.0.1-r1.ebuild b/dev-haskell/libmpd/libmpd-0.8.0.1-r1.ebuild
new file mode 100644
index 000000000000..4bb698288c83
--- /dev/null
+++ b/dev-haskell/libmpd/libmpd-0.8.0.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/libmpd/libmpd-0.8.0.1-r1.ebuild,v 1.1 2013/01/01 23:55:17 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.2.18
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="An MPD client library."
+HOMEPAGE="http://github.com/joachifm/libmpd-haskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?]
+ <dev-haskell/mtl-2.2:=[profile?]
+ >=dev-haskell/network-2.1:=[profile?]
+ <dev-haskell/network-2.5:=[profile?]
+ =dev-haskell/text-0.11*:=[profile?]
+ >=dev-haskell/utf8-string-0.3.1:=[profile?]
+ <dev-haskell/utf8-string-0.4:=[profile?]
+ >=dev-lang/ghc-6.12.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10"
+
+src_prepare() {
+ cabal_chdeps \
+ 'network >= 2.1 && < 2.4' 'network >= 2.1 && < 2.5'
+
+ sed -e '/Test-Suite specs/,$d' \
+ -i "${S}/${PN}.cabal" || die "Could not remove incomplete tests"
+}