summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-08-11 10:20:38 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-08-11 10:20:38 +0000
commit75ce985de3148d5eb49f77a53ad257d3f049fec4 (patch)
treef02a78ed9ea731895351f1c17adc55435c23d7b5 /dev-haskell
parentUnmask dev-lang/ghc-7.8. (diff)
downloadgentoo-2-75ce985de3148d5eb49f77a53ad257d3f049fec4.tar.gz
gentoo-2-75ce985de3148d5eb49f77a53ad257d3f049fec4.tar.bz2
gentoo-2-75ce985de3148d5eb49f77a53ad257d3f049fec4.zip
Version bump (ghc-7.8 support).
(Portage version: 2.2.11_p9/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/haddock/ChangeLog10
-rw-r--r--dev-haskell/haddock/haddock-2.14.3.0.7.8.3.ebuild68
2 files changed, 76 insertions, 2 deletions
diff --git a/dev-haskell/haddock/ChangeLog b/dev-haskell/haddock/ChangeLog
index b98aacf4a1d8..5b65fa0378bc 100644
--- a/dev-haskell/haddock/ChangeLog
+++ b/dev-haskell/haddock/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/haddock
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.112 2013/09/22 06:44:28 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.113 2014/08/11 10:20:38 slyfox Exp $
+
+*haddock-2.14.3.0.7.8.3 (11 Aug 2014)
+
+ 11 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org>
+ +haddock-2.14.3.0.7.8.3.ebuild:
+ Version bump (ghc-7.8 support).
22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> haddock-2.13.2-r1.ebuild:
Stable for x86, wrt bug #483462
diff --git a/dev-haskell/haddock/haddock-2.14.3.0.7.8.3.ebuild b/dev-haskell/haddock/haddock-2.14.3.0.7.8.3.ebuild
new file mode 100644
index 000000000000..63da31823e6a
--- /dev/null
+++ b/dev-haskell/haddock/haddock-2.14.3.0.7.8.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.14.3.0.7.8.3.ebuild,v 1.1 2014/08/11 10:20:38 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal pax-utils
+
+DESCRIPTION="A documentation-generation tool for Haskell libraries"
+HOMEPAGE="http://www.haskell.org/haddock/"
+#SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="http://code.haskell.org/~slyfox/snapshots/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/ghc-paths:=[profile?]
+ >=dev-haskell/xhtml-3000.2:=[profile?] <dev-haskell/xhtml-3000.3:=[profile?]
+ >=dev-lang/ghc-7.8.3:= <dev-lang/ghc-7.9:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-haskell/hspec
+ >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3 )
+"
+
+src_prepare() {
+ if [[ ! -e "${S}/html" ]]; then
+ ln -s resources/html "${S}/html" || die "Could not create symbolic link ${S}/html"
+ fi
+}
+
+src_configure() {
+ # create a fake haddock executable. it'll set the right version to cabal
+ # configure, but will eventually get overwritten in src_compile by
+ # the real executable.
+ local exe="${S}/dist/build/haddock/haddock"
+ mkdir -p $(dirname "${exe}")
+ echo -e "#!/bin/sh\necho Haddock version ${PV}" > "${exe}"
+ chmod +x "${exe}"
+
+ # we use 'nocabaldep' to use ghc's bundled Cabal
+ # as external one is likely to break our haddock
+ # (known to work on 1.16.0 and breaks on 1.16.0.1!)
+ haskell-cabal_src_configure \
+ --ghc-options=-rtsopts \
+ --with-haddock="${exe}" \
+ --constraint="Cabal == $(cabal-version)"
+}
+
+src_compile() {
+ # when building the (recursive..) haddock docs, change the datadir to the
+ # current directory, as we're using haddock inplace even if it's built to be
+ # installed into the system first.
+ haddock_datadir="${S}" haskell-cabal_src_compile
+}
+
+src_install() {
+ cabal_src_install
+ # haddock uses GHC-api to process TH source.
+ # TH requires GHCi which needs mmap('rwx') (bug #299709)
+ pax-mark -m "${D}/usr/bin/${PN}"
+}