summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-08-05 18:09:18 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-08-05 18:09:18 +0000
commit75139cd0c97badbc9bd3644146d59c5328500bb5 (patch)
treec84368ee5acfeb6577381b575dda50d492696740 /dev-haskell
parentVersion bump dev-haskell/hsql. (diff)
downloadgentoo-2-75139cd0c97badbc9bd3644146d59c5328500bb5.tar.gz
gentoo-2-75139cd0c97badbc9bd3644146d59c5328500bb5.tar.bz2
gentoo-2-75139cd0c97badbc9bd3644146d59c5328500bb5.zip
Version bump dev-haskell/hsql-postgresql.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hsql-postgresql/ChangeLog10
-rw-r--r--dev-haskell/hsql-postgresql/files/hsql-postgresql-1.7.3-ghc68.patch51
-rw-r--r--dev-haskell/hsql-postgresql/hsql-postgresql-1.7.3.ebuild23
3 files changed, 82 insertions, 2 deletions
diff --git a/dev-haskell/hsql-postgresql/ChangeLog b/dev-haskell/hsql-postgresql/ChangeLog
index 659fe15bb98b..33d4328a7b25 100644
--- a/dev-haskell/hsql-postgresql/ChangeLog
+++ b/dev-haskell/hsql-postgresql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hsql-postgresql
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsql-postgresql/ChangeLog,v 1.9 2008/05/19 19:19:58 dev-zero Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsql-postgresql/ChangeLog,v 1.10 2009/08/05 18:09:18 kolmodin Exp $
+
+*hsql-postgresql-1.7.3 (05 Aug 2009)
+
+ 05 Aug 2009; Lennart Kolmodin <kolmodin@gentoo.org>
+ +hsql-postgresql-1.7.3.ebuild, +files/hsql-postgresql-1.7.3-ghc68.patch:
+ Version bump. Builds on ghc 6.10, patched to also build on ghc 6.8.
19 May 2008; Tiziano Müller <dev-zero@gentoo.org> ChangeLog:
Changed dependency for postgresql to virtual/postgresql-base
diff --git a/dev-haskell/hsql-postgresql/files/hsql-postgresql-1.7.3-ghc68.patch b/dev-haskell/hsql-postgresql/files/hsql-postgresql-1.7.3-ghc68.patch
new file mode 100644
index 000000000000..9f86a71b0622
--- /dev/null
+++ b/dev-haskell/hsql-postgresql/files/hsql-postgresql-1.7.3-ghc68.patch
@@ -0,0 +1,51 @@
+diff -rN -u old-hsql-postgresql-1.7.3/Database/HSQL/PostgreSQL.hsc new-hsql-postgresql-1.7.3/Database/HSQL/PostgreSQL.hsc
+--- old-hsql-postgresql-1.7.3/Database/HSQL/PostgreSQL.hsc 2009-07-23 14:10:46.000000000 +0200
++++ new-hsql-postgresql-1.7.3/Database/HSQL/PostgreSQL.hsc 2009-07-23 14:10:46.000000000 +0200
+@@ -21,7 +21,7 @@
+ import Data.Char
+ import Foreign
+ import Foreign.C
+-import Control.OldException (throwDyn, catchDyn, dynExceptions, Exception(..))
++import Control.Exception (throwDyn, catchDyn, dynExceptions, Exception(..))
+ import Control.Monad(when,unless,mplus)
+ import Control.Concurrent.MVar
+ import System.Time
+diff -rN -u old-hsql-postgresql-1.7.3/Setup.lhs new-hsql-postgresql-1.7.3/Setup.lhs
+--- old-hsql-postgresql-1.7.3/Setup.lhs 2009-07-23 14:10:46.000000000 +0200
++++ new-hsql-postgresql-1.7.3/Setup.lhs 2009-07-23 14:10:46.000000000 +0200
+@@ -16,14 +16,17 @@
+ import System.Process(runInteractiveProcess, waitForProcess)
+ import System.IO(hClose, hGetContents, hPutStr, stderr)
+ import Control.Monad(when)
+-import Control.OldException(try)
++
++import System.Directory(doesFileExist)
+
+ main = defaultMainWithHooks autoconfUserHooks{preConf= preConf
+ ,postConf= postConf}
+ where
+ preConf :: [String] -> ConfigFlags -> IO HookedBuildInfo
+ preConf args flags = do
+- try (removeFile "PostgreSQL.buildinfo")
++ exists <- doesFileExist "PostgreSQL.buildinfo"
++ when exists $
++ removeFile "PostgreSQL.buildinfo"
+ return emptyHookedBuildInfo
+ postConf :: [String] -> ConfigFlags -> PackageDescription -> LocalBuildInfo -> IO ()
+ postConf args flags _ localbuildinfo = do
+diff -rN -u old-hsql-postgresql-1.7.3/hsql-postgresql.cabal new-hsql-postgresql-1.7.3/hsql-postgresql.cabal
+--- old-hsql-postgresql-1.7.3/hsql-postgresql.cabal 2009-07-23 14:10:46.000000000 +0200
++++ new-hsql-postgresql-1.7.3/hsql-postgresql.cabal 2009-07-23 14:10:46.000000000 +0200
+@@ -7,8 +7,8 @@
+ Category: Database
+ Description: PostgreSQL driver for HSQL.
+ Exposed-modules: Database.HSQL.PostgreSQL
+-Build-depends: base >= 4.0.0.0, hsql, old-time
++Build-depends: base < 4 && >=3, hsql, old-time
+ Maintainer: nick.rudnick@googlemail.com
+ Extensions: ForeignFunctionInterface, CPP
+ Build-Type: Custom
+-Extra-libraries: pq
+\ No newline at end of file
++Extra-libraries: pq
+
diff --git a/dev-haskell/hsql-postgresql/hsql-postgresql-1.7.3.ebuild b/dev-haskell/hsql-postgresql/hsql-postgresql-1.7.3.ebuild
new file mode 100644
index 000000000000..f06abe207a32
--- /dev/null
+++ b/dev-haskell/hsql-postgresql/hsql-postgresql-1.7.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsql-postgresql/hsql-postgresql-1.7.3.ebuild,v 1.1 2009/08/05 18:09:18 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit base haskell-cabal versionator
+
+DESCRIPTION="A Haskell Interface to PostgreSQL via the PQ library."
+HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/hsql-postgresql"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1
+ >=dev-haskell/hsql-$(get_version_component_range 1-2 ${PV})
+ >virtual/postgresql-base-7"
+DEPEND="${RDEPEND}
+ dev-haskell/cabal"
+
+PATCHES=( "${FILESDIR}/${P}-ghc68.patch" )