summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-01-01 18:49:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-01-01 18:49:17 +0000
commit733e758dd28d85583257726747785a4fb1fd95c3 (patch)
treeadcd369bfbcf9cec50d25e604985a59defbf92a9 /dev-haskell
parents390/sh stable wrt #440872 (diff)
downloadgentoo-2-733e758dd28d85583257726747785a4fb1fd95c3.tar.gz
gentoo-2-733e758dd28d85583257726747785a4fb1fd95c3.tar.bz2
gentoo-2-733e758dd28d85583257726747785a4fb1fd95c3.zip
Removed old.
(Portage version: 2.2.0_alpha149_p11/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/haddock/ChangeLog8
-rw-r--r--dev-haskell/haddock/files/haddock-2.4.2-Setup.hs80
-rw-r--r--dev-haskell/haddock/haddock-2.4.2.ebuild80
3 files changed, 6 insertions, 162 deletions
diff --git a/dev-haskell/haddock/ChangeLog b/dev-haskell/haddock/ChangeLog
index 86b7f39667c1..616b30d58427 100644
--- a/dev-haskell/haddock/ChangeLog
+++ b/dev-haskell/haddock/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/haddock
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.95 2012/11/18 13:42:07 gienah Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.96 2013/01/01 18:49:17 slyfox Exp $
+
+ 01 Jan 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ -files/haddock-2.4.2-Setup.hs, -haddock-2.4.2.ebuild:
+ Removed old.
*haddock-2.13.1 (18 Nov 2012)
diff --git a/dev-haskell/haddock/files/haddock-2.4.2-Setup.hs b/dev-haskell/haddock/files/haddock-2.4.2-Setup.hs
deleted file mode 100644
index 19b2c5ba3a5e..000000000000
--- a/dev-haskell/haddock/files/haddock-2.4.2-Setup.hs
+++ /dev/null
@@ -1,80 +0,0 @@
-{-
-Setup.hs: based on code from ghc-paths of Simon Marlow
-Fixed to not use the .buildinfo, and use -Dfoo flags for both libraries and executables
-
-Modified 2010-03-30 to work with both cabal-1.6 and cabal-1.8. See bug #302489.
--}
-import Distribution.Simple
-import Distribution.Simple.Setup
-import Distribution.PackageDescription
-import Distribution.Simple.LocalBuildInfo
-import Distribution.InstalledPackageInfo
-import Distribution.Simple.Program
-import Distribution.Simple.PackageIndex as Pkg
-
-import System.Exit
-import System.IO
-import Data.IORef
-import Data.Char
-import Data.Maybe
-
-main = defaultMainWithHooks simpleUserHooks {
- confHook = myCustomConfHook
- }
- where
-{- With cabal-1.6, myCustomConfHook has this type
- myCustomConfHook :: (Either GenericPackageDescription PackageDescription, HookedBuildInfo)
- -> ConfigFlags
- -> IO LocalBuildInfo
- With cabal-1.8, myCustomConfHook has this type
- myCustomConfHook :: (GenericPackageDescription, HookedBuildInfo)
-
-So, better to not specify the type at all as we're not required to...
--}
- myCustomConfHook gpd flags = do
- -- get the default LBI
- lbi <- confHook simpleUserHooks gpd flags
- let programs = withPrograms lbi
-
- libdir_ <- rawSystemProgramStdoutConf (fromFlag (configVerbosity flags))
- ghcProgram programs ["--print-libdir"]
- let libdir = reverse $ dropWhile isSpace $ reverse libdir_
-
- ghc_pkg = case lookupProgram ghcPkgProgram programs of
- Just p -> programPath p
- Nothing -> error "ghc-pkg was not found"
- ghc = case lookupProgram ghcProgram programs of
- Just p -> programPath p
- Nothing -> error "ghc was not found"
-
- -- figure out docdir from base's haddock-html field
- base_pkg = case searchByName (installedPkgs lbi) "base" of
- None -> error "no base package"
- Unambiguous (x:_) -> x
- _ -> error "base ambiguous"
- base_html = case haddockHTMLs base_pkg of
- [] -> ""
- (x:_) -> x
- docdir = fromMaybe base_html $
- fmap reverse (stripPrefix (reverse "/libraries/base")
- (reverse base_html))
-
- let programs' = userSpecifyArgs "ghc" ["-DGHC_PATHS_GHC_PKG=" ++ show ghc_pkg,
- "-DGHC_PATHS_GHC=" ++ show ghc,
- "-DGHC_PATHS_LIBDIR=" ++ show libdir,
- "-DGHC_PATHS_DOCDIR=" ++ show docdir
- ] programs
- -- returning our modified LBI that includes the -D definitions
- return lbi { withPrograms = programs' }
-
-die :: String -> IO a
-die msg = do
- hFlush stdout
- hPutStr stderr msg
- exitWith (ExitFailure 1)
-
-stripPrefix :: Eq a => [a] -> [a] -> Maybe [a]
-stripPrefix [] ys = Just ys
-stripPrefix (x:xs) (y:ys)
- | x == y = stripPrefix xs ys
-stripPrefix _ _ = Nothing
diff --git a/dev-haskell/haddock/haddock-2.4.2.ebuild b/dev-haskell/haddock/haddock-2.4.2.ebuild
deleted file mode 100644
index eafd64f17c03..000000000000
--- a/dev-haskell/haddock/haddock-2.4.2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.4.2.ebuild,v 1.11 2012/09/14 07:03:20 qnikst Exp $
-
-CABAL_FEATURES="bin lib"
-# don't enable profiling as the 'ghc' package is not built with profiling
-inherit haskell-cabal autotools pax-utils
-
-GHCPATHS_PN="ghc-paths"
-GHCPATHS_PV="0.1.0.5"
-GHCPATHS_P="${GHCPATHS_PN}-${GHCPATHS_PV}"
-
-DESCRIPTION="A documentation-generation tool for Haskell libraries"
-HOMEPAGE="http://www.haskell.org/haddock/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz
- mirror://hackage/packages/archive/${GHCPATHS_PN}/${GHCPATHS_PV}/${GHCPATHS_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc"
-
-# haddock-2.4.2 also deps on the upgradeable package dev-haskell/filepath.
-# however, it's included in >=ghc-6.10, so we use the core package without
-# stating the dependency in DEPEND.
-
-# we bundle the dep on ghc-paths to reduce the dependencies on this critical
-# package. ghc-paths would like to be compiled with USE=doc, which pulls in
-# haddock, which requires ghc-paths, which pulls in haddock...
-
-# doesn't build with ghc-6.10.1, but that has never been in portage
-RDEPEND="=dev-lang/ghc-6.10*"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6
- doc? ( ~app-text/docbook-xml-dtd-4.2
- app-text/docbook-xsl-stylesheets
- >=dev-libs/libxslt-1.1.2 )"
-
-src_unpack() {
- unpack ${A}
-
- # use ghc-paths directly, not as a library
- sed -e "s|build-depends: ghc-paths|hs-source-dirs: ../${GHCPATHS_P}|" \
- -e "s|Simple|Custom|" \
- -i "${S}/${PN}.cabal"
-
- # ghc-paths has a custom Setup.hs, haddock has the default Setup.lhs.
- # we use a somewhat modified ghc-paths Setup.hs that works better for our
- # purposes.
- rm "${S}/Setup.lhs"
- cp "${FILESDIR}/${P}-Setup.hs" "${S}/Setup.hs"
-
- if use doc; then
- cd "${S}/doc"
- eautoreconf
- fi
-
-}
-
-src_compile () {
- cabal_src_compile
- if use doc; then
- cd "${S}/doc"
- ./configure --prefix="${D}/usr/" \
- || die 'error configuring documentation.'
- emake html || die 'error building documentation.'
- fi
-}
-
-src_install () {
- cabal_src_install
- # haddock uses GHC-api to process TH source.
- # TH requires GHCi which needs mmap('rwx') (bug #299709)
- pax-mark -m "${D}/usr/bin/${PN}"
-
- if use doc; then
- dohtml -r "${S}/doc/haddock/"*
- fi
- dodoc CHANGES README
-}