summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-25 06:05:27 +0000
committerMark Wright <gienah@gentoo.org>2012-11-25 06:05:27 +0000
commit6fef6c2d880210fc21e4f47a1fa805f98ff6a774 (patch)
tree63b42eabd93371aa76dcb12107f8b3c9c4e60b47 /dev-haskell
parentBump gtk to 0.12.3.1 (diff)
downloadgentoo-2-6fef6c2d880210fc21e4f47a1fa805f98ff6a774.tar.gz
gentoo-2-6fef6c2d880210fc21e4f47a1fa805f98ff6a774.tar.bz2
gentoo-2-6fef6c2d880210fc21e4f47a1fa805f98ff6a774.zip
Bump highlighting-kate to 0.5.3.3
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/highlighting-kate/ChangeLog8
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.3.3.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-haskell/highlighting-kate/ChangeLog b/dev-haskell/highlighting-kate/ChangeLog
index ca82d9496a6f..9e0f98381873 100644
--- a/dev-haskell/highlighting-kate/ChangeLog
+++ b/dev-haskell/highlighting-kate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/highlighting-kate
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.5 2012/09/12 14:49:13 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.6 2012/11/25 06:05:27 gienah Exp $
+
+*highlighting-kate-0.5.3.3 (25 Nov 2012)
+
+ 25 Nov 2012; Mark Wright <gienah@gentoo.org>
+ +highlighting-kate-0.5.3.3.ebuild:
+ Bump highlighting-kate to 0.5.3.3
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org>
highlighting-kate-0.2.9-r1.ebuild, highlighting-kate-0.5.0.5.ebuild,
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.3.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.3.ebuild
new file mode 100644
index 000000000000..ea7047cd8957
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.3.ebuild,v 1.1 2012/11/25 06:05:27 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="http://github.com/jgm/highlighting-kate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?]
+ <dev-haskell/blaze-html-0.6:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/regex-pcre-builtin:=[profile?]
+ pcre-light? ( dev-haskell/pcre-light:=[profile?] )
+ !pcre-light? ( dev-haskell/regex-pcre-builtin:=[profile?] )
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag executable) \
+ $(cabal_flag pcre-light)
+}