summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-04-14 10:35:59 +0000
committerMark Wright <gienah@gentoo.org>2012-04-14 10:35:59 +0000
commit63d80e13167e26aedc5f6c899b71e89782b026b2 (patch)
tree12ae5a43998f0a3cf90fe8a12e3030e693a29213 /dev-haskell
parentVersion bump (non-maint commit, bug 410277). (diff)
downloadgentoo-2-63d80e13167e26aedc5f6c899b71e89782b026b2.tar.gz
gentoo-2-63d80e13167e26aedc5f6c899b71e89782b026b2.tar.bz2
gentoo-2-63d80e13167e26aedc5f6c899b71e89782b026b2.zip
Bump text to 0.11.2.0
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/text/ChangeLog7
-rw-r--r--dev-haskell/text/text-0.11.2.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-haskell/text/ChangeLog b/dev-haskell/text/ChangeLog
index 4c9470f6d505..02235d5983c1 100644
--- a/dev-haskell/text/ChangeLog
+++ b/dev-haskell/text/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/text
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/ChangeLog,v 1.9 2012/03/25 04:02:49 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/ChangeLog,v 1.10 2012/04/14 10:35:59 gienah Exp $
+
+*text-0.11.2.0 (14 Apr 2012)
+
+ 14 Apr 2012; Mark Wright <gienah@gentoo.org> +text-0.11.2.0.ebuild:
+ Bump text to 0.11.2.0
25 Mar 2012; Mark Wright <gienah@gentoo.org> text-0.11.1.13-r1.ebuild:
Loosen test dependency on test-framework.
diff --git a/dev-haskell/text/text-0.11.2.0.ebuild b/dev-haskell/text/text-0.11.2.0.ebuild
new file mode 100644
index 000000000000..c044769c1a13
--- /dev/null
+++ b/dev-haskell/text/text-0.11.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/text-0.11.2.0.ebuild,v 1.1 2012/04/14 10:35:59 gienah Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="4"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type."
+HOMEPAGE="https://github.com/bos/text"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-haskell/deepseq-1.1.0.0[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.4.0.1[profile?]
+ >=dev-haskell/test-framework-0.4[profile?] <dev-haskell/test-framework-0.7[profile?]
+ <dev-haskell/test-framework-hunit-0.3[profile?]
+ <dev-haskell/test-framework-quickcheck2-0.3[profile?]
+ )"
+
+src_configure() {
+ # the tests need a utf-8 locale
+ cabal_src_configure $(use test && use_enable test tests) #395351
+}