summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-07-20 18:11:50 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-07-20 18:11:50 +0000
commit2202ea5415e94292f30204069e5b545230c3d6d4 (patch)
treec82afee1ce6cd64e9141031afc6eacce5ca98150 /dev-haskell
parentFast, accurate CommonMark (Markdown) parser and renderer, initial import. A d... (diff)
downloadgentoo-2-2202ea5415e94292f30204069e5b545230c3d6d4.tar.gz
gentoo-2-2202ea5415e94292f30204069e5b545230c3d6d4.tar.bz2
gentoo-2-2202ea5415e94292f30204069e5b545230c3d6d4.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/highlighting-kate/ChangeLog8
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.6.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-haskell/highlighting-kate/ChangeLog b/dev-haskell/highlighting-kate/ChangeLog
index a30af93b070a..9dc8057c5f92 100644
--- a/dev-haskell/highlighting-kate/ChangeLog
+++ b/dev-haskell/highlighting-kate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/highlighting-kate
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.22 2015/06/06 11:24:55 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.23 2015/07/20 18:11:50 slyfox Exp $
+
+*highlighting-kate-0.6 (20 Jul 2015)
+
+ 20 Jul 2015; Sergei Trofimovich <slyfox@gentoo.org>
+ +highlighting-kate-0.6.ebuild:
+ Version bump.
06 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.6.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.6.ebuild
new file mode 100644
index 000000000000..13e001791e4c
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/highlighting-kate-0.6.ebuild,v 1.1 2015/07/20 18:11:50 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="http://github.com/jgm/highlighting-kate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?] <dev-haskell/blaze-html-0.9:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ pcre-light? ( >=dev-haskell/pcre-light-0.4:=[profile?] <dev-haskell/pcre-light-0.5:=[profile?] )
+ !pcre-light? ( >=dev-haskell/regex-pcre-builtin-0.94.4.8.8.35:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/diff )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag pcre-light pcre-light)
+}